Probléme WIFI et clé enc:xxxxx



  • Bonsoir,
    J'ai un soucis avec le WIFI.
    J'arrive à configurer le WIFI mais à chaque reboot, il ne marche plus.
    La clé sauvé en enc:xxxxx ne semble pas valide et est refusé par mon routeur.

    Je reboot en utilisant soit l'interface web soit le menu.

    Recallbox est installé dans un bartop sur un raspberry pi.

    Antoine


  • Moderator
    Moderator
    Team

    @nimco123 fais le test suivant:

    1. Démarre Recalbox. Le wifi ne fonctionne pas, ne le reconfigure pas à la main
    2. Fais Select, Redémarrer, et attend que ça redémarre sans rien faire d'autre
    3. Au démarrage suivant, est-ce que le wifi fonctionne ?


  • Bonsoir @oyyodams
    J'ai essayé de
    1- configurer la connection,
    2- de rebooter, le WIFI est refusé par mon routeur car mauvais mot de passe,
    3- Si si je reboote ça ne marche toujours pas

    Il semble que dans des cas exceptionel ça fonctionne. C'est comme ci l'un des paramétres utilisés pour le decoding était absent.

    J'ai regardé le recalbox-encode.sh mais pas eu le temps de tester.

    Antoine


  • Moderator
    Moderator
    Team

    @nimco123 le enc:*** est normal, t'as déjà regardé recalbox.conf ?

    ## after rebooting the recalbox, the "new key" is replace by a hidden value "enc:xxxxx"
    ## you can edit the "enc:xxxxx" value to replace by a clear value, it will be updated again at the following reboot
    

    Ton problème ne vient pas de là. D'où l'importance de suivre pas à pas:

    1. Est-ce que ça fonctionne quand tu configures la première fois ?
    2. Si tu fais Select, et Redémarrer (et j'insiste sur ce protocole), est-ce que ça fonctionne encore après le redémarrage ?

    Hors de question d'arrêter, rebooter autrement, bidouiller des fichiers, chercher midi à 14h...

    Merci :)



  • Bonjour @OyyoDams,

    Donc, si je configure le WIFI, le WIFI fonctionne. Si ensuite je redémarre avec Select, et Redémarrer, après redémarrage, le WIFI ne fonctionne plus. Comme je l'ai dit plus tôt dans certains cas, le WIFI fonctionne mais dans 95% des cas, la clé décrypté n'est pas accepté par mon routeur.

    C'est pour cela que j'ai regardé la procédure d'encodage après avoir lu le recalbox.conf.

    Merci
    Antoine


  • Moderator
    Moderator
    Team

    @nimco123 alors testons autre chose:

    1. Tu configures le wifi dans Recalbox
    2. Tu fais Select, Eteindre et tu attends un peu avant de débrancher ton RPI
    3. Tu retires la micro SD et tu la mets dans ton PC
    4. Depuis ton PC, tu accèdes à la micro SD, tu peux en lire une partie depuis Windows. Il y a un fichier nommé recalbox-boot.conf que tu peux ouvrir avec n'importe quel éditeur de texte. Peux-tu me dire ce qu'il y a dedans ?


  • Salut @OyyoDams
    Voilà le contenu de recalbox-boot.conf
    sharedevice=INTERNAL
    wifi.ssid=maison_reseau
    wifi.key=08faafc044ae
    wifi.ssid=maison_reseau
    wifi.key=08faafc044ae

    C'est normal que ce soit là 2 fois? La clé et le ssid sont correcte.
    Merci
    Antoine


  • Moderator
    Moderator
    Team

    @nimco123 il y a du y avoir un loupé dans un des redémarrages...

    Vire un des doublons (ssid et key), et redémarre pour voir

    Tu dois avoir:

    sharedevice=INTERNAL
    wifi.ssid=maison_reseau
    wifi.key=08faafc044ae
    


  • Salut @OyyoDams
    ça a fonctionné au premier reboot.
    Ensuite des lignes dupliquées ont été rajoutées.
    Antoine


  • Moderator
    Moderator
    Team

    @nimco123 bizarre ton histoire... Et si tu ne laisses que la ligne sharedevice=INTERNAL ?

    Tu es sur de ne pas avoir configuré 2 fois ton wifi dans recalbox.conf ?



  • Coucou !
    Je souhaitais dire que j'avais exactement le même problème de mon côté. J'ai fais mon installation avec un câble RJ45 branché si cet indice peut changer la donne.
    RPI3, manette XBOX et rien d'autre.
    Bonne soirée !


  • Moderator
    Moderator
    Team

    @wapata si le RJ45 est branché, le wifi est automatiquement désactivé.



  • @oyyodams il est automatiquement désactivé mais reste sur ON il me semble


  • Moderator
    Moderator
    Team

    @gaetan peu importe, c'est un piège, tu ne peux pas utiliser le wifi si le RJ45 est branché.



  • Je confirme, j'ai galéré ma race pour activer un wifi sur un PI3B+, sauf que mon RJ 45 était branché. Puis un jour, je le débranche et là, la magie s'est opérée !.. Bref, débranchez votre RJ45 pour que le wifi s'active et détecte votre connexion internet :)



  • Je n'ai branché QUE lors de l'installation. C'était une indication complémentaire au constat 100% identique au premier post de ce sujet.



  • Avec le web Manager j'ai remplis les trois réseaux dispo avec le ssid et le code de mon wifi.
    ...
    Et du coup maintenant ça fonctionne automatiquement chez moi. Mais probablement pas sur le wifi-1 qui a la clé de mal encodée.
    Solution de secours validée !


  • Moderator
    Moderator
    Team

    @wapata dans 99.99% des cas les gens pensent que ça vient de l'encodage, alors que non l'encodage n'est pas en cause. L'encodage est là simplement pour éviter de faire apparaître en clair ton mot de passe wifi dans le fichier recalbox.conf, mais Recalbox sait très bien le décoder.

    Le problème est ailleurs.



  • Ah okay, le mot de passe "enc.blabla" est la version masquée du vrais.
    Bon... Ben que puis-je tester d'autre pour faire avancer le shmilblick ?
    (Dans quelques années ce mot ne sera plus compris.. )


  • Moderator
    Moderator
    Team

    @wapata bah si tu dis qu'il marche en wifi2, c'est que la conf dans wifi1 doit avoir un loupé et qu'il prend la conf de wifi2 pour se connecter. Donc Si tu veux pousser les tests, vire la conf de wifi1, et recopie la conf de wifi2 dans wifi1, puis vire la conf de wifi2, tu verras que ça marche ;)


Log in to reply
 

Want to support us ?

Join us on :

405
Online

31205
Users

15135
Topics

113857
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.