WIN98 sous DOSBOX



  • Je sais qu'il est possible d'installer Win98 avec DOSBOX sous windows (déjà fait). Je me suis donc dit "tiens pourquoi pas le mettre dans la DOSBOX de RECALOS ?".

    Ok dans le principe l'installation ce lance mais, de file en aiguilles et bien je trouve que c'est très lent. Il me semble avoir lu que nous ne pouvons pas aller plus loin que 64mo de mémoire sous DOSBOX. Mis à part cela je ne comprends pas pourquoi c'est si lent.

    L'installation est terminée et malheureusement écran noir lorsque j'essaye de démarrer....

    Je précise que je modifie mon BAT dosbox entre l'installation et le lancement, car je monte un lecteur de disquette virtuel pour faire booter l'installation.

    Une idée sur les paramètres à changer sur les fichiers de conf DOSBOX ?


  • Themer

    @injall tu essayes d'émuler Windows98 avec un Pi3 ?


  • Banned

    @Injall
    Si Windows95 te suffit, mieux vaut essayer, au moins ça marche et des jeux comme Lemmings s'exécutent.



  • @voljega Oui pourquoi cela te semble surprenant ?


  • Themer

    @injall ça me semble surtout voué à l'échec niveau performances ...



  • @dragu Win95 devrait suffire mais, j'ai le même problème ! En revanche, il démarre en sans échec.



  • @voljega win 98 je ne sais pas, mais win 95 se virtualise bien sous raspbian. Par contre, pour ce qui est de l'émuler je ne sais pas...


  • Themer

    @noktambule je dis juste que les performances ne vont pas être terribles



  • @voljega faut voir...
    Win 95 demande :
    Processeur : Intel 80486
    Espace disque dur : 420 Mo
    Mémoire vive : 8 Mo de RAM

    Avec 1 GHz de processeur et 1 go de ram, ça doit pouvoir tourner sans trop de soucis, non ?


  • Banned

    @noktambule
    En tout cas, chez moi il tourne. Mais c'était plutôt comme gadget, la description est ici :
    https://forum.recalbox.com/topic/9218/windows95-under-recalbox



  • Pour un 98se :

    Configuration minimale

    Processeur : 486 DX2/66 MHz
    Espace disque dur : 165 Mo
    Mémoire vive : 16 Mo de RAM (24 Mo de RAM pour la Deuxième Édition)
    VGA ou moniteur de résolution supérieure (640x480 pixels)

    Configuration recommandée

    Processeur : Pentium
    Espace disque dur : 355 Mo
    Mémoire vive : 24 Mo de RAM



  • @dragu Ok je compare pour voir ce qui cloche chez moi alors !



  • @dragu Ton fichier DOSBOX.CFG tu le mets dans le répertoire win95.pc et on ne touche pas aux fichiers de configuration dans \share\system\configs\dosbox ni dans \share\system.dosbox ?


  • Banned

    @Injall
    Non, non, je ne fous pas de la merde dans les bytes de Substring, il y a juste la configuration locale de dosbox.cfg. Mais j'avait seulement un succès avec la version floppy de W95. La raison est plutôt dans les drivers de Windows qui vont rouspéter s'ils ne trouvent pas leur hardware. Aussi pour l'installation il faut passer par Microsoft Dos, mais c'est décrit.



  • @dragu Donc il faut créer un fichier DOSBOX.CFG dans win95.pc !?


  • Banned

    @Injall
    Je ne sais pas si tu as déja installé des jeux sous dosbox, la copie de dosbox.conf vers dosbox.cfg locale est basique pour travailler convenablement avec dosbox, sinon tu ne peux pas définir une configuration unique pour une certaine application.



  • @dragu Ok j'ai compris.
    donc dans mon répertoire win95.pc j'ai :

    • le répertoire S3d
    • 622c.img
    • datas.img
    • os.img
    • dosbox.bat
    • dosbox.cfg

    dans mon dosbox.cfg j'ai :

    [sdl]

    fullscreen=true
    vsync=false
    fullresolution=desktop
    windowresolution=original
    output=texture
    renderer=auto
    autolock=true
    sensitivity=100
    waitonerror=true
    priority=higher,normal
    mapperfile=win95.map

    [dosbox]

    language=
    machine=svga_s3
    captures=capture
    vmemsize=8
    memsize=64

    [render]

    frameskip=0
    aspect=false
    scaler=none

    [cpu]

    core=dynamic
    cputype=pentium_slow
    cycles=auto
    cycleup=100
    cycledown=100

    [mixer]

    nosound=false
    rate=44100
    blocksize=1024
    prebuffer=20

    [midi]

    mpu401=intelligent
    mididevice=default
    midiconfig=

    [sblaster]

    sbtype=sb16
    sbbase=220
    irq=7
    dma=1
    hdma=5
    sbmixer=true
    oplmode=auto
    oplemu=default
    oplrate=44100

    [gus]

    gus=false
    gusrate=44100
    gusbase=240
    gusirq=5
    gusdma=3
    ultradir=C:\ULTRASND

    [speaker]

    pcspeaker=true
    pcrate=44100
    tandy=auto
    tandyrate=44100
    disney=true

    [joystick]

    joysticktype=auto
    timed=true
    autofire=false
    swap34=false
    buttonwrap=false

    [serial]

    serial1=dummy
    serial2=dummy
    serial3=disabled
    serial4=disabled

    [dos]

    xms=true
    ems=true
    umb=true
    keyboardlayout=none

    [autoexec]

    et dans mon dosbox.bat :

    imgmount 0 622c.img -t floppy -fs none
    imgmount 2 os.img -size 512,63,64,1023 -t hdd -fs none
    imgmount 3 datas.img -size 512,63,64,1023 -t hdd -fs none
    boot os.img

    Malgré ça j'ai toujours un écran noir !
    Tu as une idée ?


  • Themer

    @injall oui enfin la conf minimale de win98 c'est pour une installation et utilisation directement sur du hardware x86 nu, là tu essayes d'installer ça dans dosbox lui même tournant sur un processeur ARM.

    En règle générale en émulation il faut 3/4 fois la puissance du truc d'origine pour émuler correctement et ds ce cas précis il faut même surement plus


  • Banned

    @Injall
    Il faut jouer avec mount et imgmount alternativement, pour arriver au but et passer des dossiers.
    Concernant ta dosbox.bat, si tu laisse "imgmount 0 622c.img -t floppy -fs none"
    sans signe commentaire, il va toujours vouloir booter en Dos et pas en Windows. Maintenant pour moi difficile, tu est là en test avec W98 ou W95 ? En plus il faut comme dernière ligne dans dosbox.bat (dans ma version la seule ligne) "boot -l c" et pour starter Dos622 (pour l'installation) "boot -l a". Ce qui est bien écrit dans le text du link.



  • @dragu Ok je suis ton sujet à la ligne et je reviens vers toi ! Merci


Log in to reply
 

Want to support us ?

Join us on :

224
Online

31352
Users

15156
Topics

113973
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.