supprimer hotkey+r2 dans retroarch



  • Bonjour,

    Je souhaite supprimer le fonction shader suivant dans retroarch.
    En effet, ma borne d'arcade a le hotkey sur R2 et donc forcement pendant un jeu si j'appuie sur R2 cela me fait la combinaison hotkey+r2 donc shader suivant.

    J'ai tenté de modifier le retroarch.cfg la ligne input_shader_next_btn = 7 en mettant un # devant ou input_shader_next_btn = "nul" je sauvegarde avec wscp mais quand je redémarre ES la ligne est modifié avec la valeur d'origine donc =7

    Je précise que j'ai bien appliquer la commande mount -o remount,rw / avant.

    La je sèche

    Une petite idée ?

    D'avance merci pour votre retour.



  • regarde dans
    /recalbox/share_init/system/configs/retroarch
    (c'est dans share_init que les conf d'origine sont)



  • Bonjour,

    Merci pour ton retour.

    J'ai regardé mais je n'ai rien niveau config dans ce .cfg à cet endroit pour shader next, jai juste une ligne pour hotkey=16



  • @mroizo59 said in supprimer hotkey+r2 dans retroarch:

    J'ai tenté de modifier le retroarch.cfg la ligne input_shader_next_btn = 7 en mettant un # devant ou input_shader_next_btn = "nul" je sauvegarde avec wscp mais quand je redémarre ES la ligne est modifié avec la valeur d'origine donc =7

    Est-ce que à un moment, tu as réussi à faire en sorte que Hotkey+R2 soit désactivé ? (même si après reboot, la modif n'est pas gardée)

    Si oui, alors il suffit de scripter la modification du fichier à chaque boot de ta recalbox via custom.sh



  • Oulala mes connaissances sont limitées tout de même

    J'ai trois fichier retroarch dans recalbox : 1 dans le chemin que tu m'as indiqué c'est retroarchcustom.cfg.origin. Et là pas de notion de commande pour hotkey+R2
    ensuite 2 autre fichier retroarchcustom.cfg.origin (le même) et retroarchcustom.cfg dans /recalbox/share/system/configs/retroarch

    C'est le retroarchcustom.cfg que je modifie mais qui ne garde pas ma modif en mémoire.

    Je suis un peu perdu...



  • @mroizo59 said in supprimer hotkey+r2 dans retroarch:

    C'est le retroarchcustom.cfg que je modifie mais qui ne garde pas ma modif en mémoire

    --> ça garde pas la modif en mémoire si tu redémarres la machine, ok. Mais est-ce que ça marche au moins jusqu'au prochain redémarrage?



  • @unik314r
    Bonjour, j'ai essayé avec les bons droits sur la ligne input_shader_next_btn = 7

    1. de mettre un # en début de ligne
    2. de mettre = nul
    3. de mettre =null
    4. de mettre = none
    5. de mettre = false
    6. de mettre une autre valeur par exemple = +2

    Rien ne fonctionne j'enregistre après ma modification avec winscp et avec les bons droits avant.
    Je retourne sur la borne et next shader toujours actif.
    Je ne reboot pas car toute modification est effacée( pour faire les tests)

    Je dois louper une étape je pense mais je ne sais pas laquelle

    Pour précision, je modifie le retroarchcustom.cfg dans /recalbox/share/system/configs/retroarch
    Il n'y a que dans ce fichier où j'ai un input pour shader next

    D'avance merci pour votre retour



  • @mroizo59
    Hum je sèche.
    Je n'utilise pas de R2 chez moi, donc mes lignes sont:

    #input_shader_next_btn = 5
    #input_shader_prev_btn = 4
    

    Essaie de changer via le menu retroarch:
    en cours de jeux, Hotkey+B pour accéder au menu retroarch.
    Puis, Settings > Input > Input Hotkey Binds
    Tu trouveras Next shader et Previous shader (chez moi ils ont respectivement Key: m et Key: n)
    Essaie de binder quelque chose d'autre?



  • @unik314r

    Ca avance un peu j'ai fait la manip j'affecte le bouton 5.

    C'est bon je n'ai plus le soucis de R2+ hotkey.

    Par contre, j'ai relancé un jeux et de nouveau bouton 7

    Je modifie de nouveau et ensuite je reviens en arrière configuration\save current configuration je relance de nouveau bouton 7
    Idem je reviens en arrière configuration\save new configuration je relance de nouveau bouton 7.

    GRRR ça m'énerve mais on avance je peux déjà y mettre le bouton 5. Plus qu'à trouver comment bien enregistrer cette config au bon endroit pour qu'au lancement de retroarch ce soit cette config qui est prise.



  • @Mroizo59 Dans ce cas, fais ta modif, puis "save new configuration" au lieu de current.
    Ca va créer un nouveau .cfg (spécifique à l'émulateur utilisé à ce moment là) dans /recalbox/share/system/.config/retroarch/config/
    (EDIT: il est possible que ce soit en fait dans /recalbox/share/system/configs/retroarch/ me souviens pu trop... il faut regarder ce qu'il affiche quand tu sauves^^)

    Et pour que ce cfg soit lancé à chaque lancement de l'émulateur correspondant, il suffit de l'indiquer dans ton /recalbox/share/system/recalbox.conf

    L'exemple qui y est donné pour la snes c'est snes.configfile=/path/to/my/configfile.cfg

    Donc chez moi pour la game boy j'ai :
    gb.configfile=/recalbox/share/system/.config/retroarch/config/gambatte_libretro.cfg



  • @unik314r

    ok et va falloir que je le fasse pour chaque emulateur ? car cette suppression de shader next=7 et mettre 5 à la place c'est pour tous les emulateurs



  • @unik314r

    Bon j'ai tenté sur amstrad cpc la manip

    Quand je fait save new configuration le chemin est le suivant : /recalbox/share/system/configs/retroarch/

    Il me sauvegarde sous le nom retroarchcustom.cfg.

    Hors j'ai déjà le même fichier dans ce répertoire.

    Quand je regarde dans ce dernier le next shader est toujours sur 7 et non 5.

    Apparemment c'est bien ce fichier que je dois modifié mais impossible que sauvegarder les changements.

    Je peux essayer de l'extraire de ce répertoire, le supprimer, le modifier avec note ++ sur pc et le copier de nouveau dans ce répertoire? qu'en penses tu ?



  • @unik314r

    ou bien mettre un # plutot devant la ligne input_shader_next_btn = 7 afin de "tuer" cette fonction



  • @unik314r

    Enfin pour précision, quand je fait propriété sous winscp concernant le fichier retroarchcustom.cfg

    J'ai ceci : groupe : root propriétaire : root
    permission propriétaire r et w sont coché
    permission groupe r est coché
    permission autre r est coché
    octal 0644
    Voila j'attends donc ton avis concernant l'effacement de ce fichier le modifier sur pc et le copier de nouveau dans ce répertoire.

    Je n'ose pas le faire sans l'avis d'un pro, je ne veut pas tout casser

    D'avance merci



  • @Mroizo59 mettre un # devant input_shader_next_btn devrait normalement désactiver cette fonction oui, mais ne l'avais-tu pas déjà testé (sans succès) au début?

    Je ne suis pas sûr que le rapatrier, supprimer, réécrire et renvoyer soit très efficace vu le nombre de manips...

    Par contre tu me parles de /recalbox/share/system/configs/retroarch/ alors que moi je parlais de /recalbox/share/system/.config/retroarch/config/ (c'est .config et non pas config: peux-tu me lister le contenu de ce dernier dossier?
    Parce que c'est normalement là que les .cfg perso (genre comme mon gambatte_libretro.cfg) sont stockés quand tu "save new configuration"



  • @unik314r

    Bonsoir,
    la manip rapatrier, supprimer , modifier et renvoyer c'est simple en 2 minutes cela peut être fait.

    Mais j'ai peur de tout casser glupps...

    sinon dans le répertoire indiqué j'ai plusieurs dossiers :

    0_1520278476017_8af91847-1e93-4c5e-8cb0-8fa5bab99df4-image.png



  • @mroizo59 a priori tous ces dossiers correspondent à des émulateurs, et normalement, il y a des .cfg dans chaque.
    Il "suffit" de commenter, dans chaque cfg, la ligne qui t'embête: input_shader_next_btn = 7

    Et ensuite, indiquer dans /recalbox/share/system/recalbox.conf d'utiliser tel ou tel cfg
    Par ex pour moi je rajoute gb.configfile=/recalbox/share/system/.config/retroarch/config/gambatte_libretro.cfg
    et apparemment chez toi ça pourrait être gb.configfile=/recalbox/share/system/.config/retroarch/config/Gambatte/gambatte_libretro.cfg



  • @unik314r

    Ok j'ai compris dans les dossiers j'ai des cfg par jeux pour ceux que j'ai personnalisé

    Les cap32_libreto.cfg correspond à l'enregistrement que je fais quand j'affecte le bouton 5
    Je vais donc aller sur ce fichier mettre "nul" à la place apparemment c'est ce qui est utilisé pour affecter aucun bouton c'est encore mieux.

    C'est l'étape suivante où cela dépasse mes compétences.
    Je dois donc aller dans mon fichier recalbox.conf
    Jusque la tout va bien mais comment je rajoute les bonnes lignes et surtout a quel endroit ?
    J'ajoute juste la ligne ou il faut que je reprenne l'ensemble de la config comme expliqué en exemple pour la snes ?

    D'avance encore un merci pour ton retour

    Ci après le copier coller de mon recalbox.conf (partie où je pense que je dois ajouter les lignes "qui vont bien" mais je ne sais pas comment ni ou...)

    ------------ I - EMULATORS CHOICES -----------

    You can override the global configuration here

    Here is the snes example

    ;snes.videomode=CEA 4 HDMI
    snes.core=snes9x_next
    ;snes.shaders=/recalbox/share/shaders/shaders_glsl/mysnesshader.gplsp
    snes.ratio=4/3
    ;snes.smooth=0
    ;snes.rewind=1
    ;snes.autosave=0
    ;snes.emulator=libretro
    ;snes.integerscale=0

    If you do not want recalboxOS to generate the configuration for the emulator :

    ;snes.configfile=/path/to/my/configfile.cfg

    Default cores for RPi3

    snes.core=snes9x_next
    gba.core=mgba
    mame.core=mame078
    nes.core=fceunext

    NeoGeo emulator

    You can use pifba or a libretro core (fba2x,libretro)

    neogeo.emulator=libretro

    If you set libretro as neogeo.emulator, the line below sets the retroarch core (fba,imame4all)

    neogeo.core=fba

    N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution)

    So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).

    If your screen is not compatible with one of these video modes, please check the recalbox's wiki.

    n64.videomode=CEA 1 HDMI

    If you are using a CRT screen, please change the setting above with this one :

    n64.videomode=default

    Dreamcast emulator

    Like N64, such a CPU intensive emulator needs a small resolution

    Consider DMT 4 HDMI (640480) or DMT 9 HDMI (800600). If you have a black screen on dreamcast, try DMT 9 HDMI here

    dreamcast.videomode=DMT 4 HDMI

    Configurations generated by Recalbox

    system.es.menu=default
    controllers.xboxdrv.enabled=0
    controllers.xboxdrv.nbcontrols=2
    fba.smooth=0
    fba.ratio=4/3
    psx.smooth=1
    nes.ratio=4/3
    n64.ratio=4/3
    gba.ratio=4/3
    gbc.ratio=4/3
    gb.ratio=4/3
    megadrive.ratio=4/3
    sega32x.ratio=4/3
    mastersystem.ratio=4/3
    gamegear.ratio=4/3
    sg1000.ratio=4/3
    psx.ratio=16/9
    pcengine.ratio=4/3
    mame.ratio=4/3
    neogeo.ratio=4/3
    atari2600.ratio=4/3
    atari7800.ratio=4/3
    lynx.ratio=4/3
    ngp.ratio=4/3
    ngpc.ratio=4/3
    prboom.ratio=4/3
    atarist.ratio=4/3
    amstradcpc.ratio=4/3
    msx.ratio=4/3
    fba.emulator=default
    o2em.ratio=custom
    pcenginecd.ratio=custom
    supergrafx.ratio=custom
    vectrex.ratio=custom
    wswan.ratio=custom
    wswanc.ratio=custom
    zxspectrum.ratio=custom
    segacd.ratio=custom



  • @mroizo59 Tu peux rajouter tes lignes à la toute fin du fichier, genre

    .
    .
    wswan.ratio=custom
    wswanc.ratio=custom
    zxspectrum.ratio=custom
    segacd.ratio=custom
    
    BLABLA_ICI_BLABLA
    

    Ce qu'il faut mettre: par exemple chez moi pour game boy j'ai
    gb.configfile=/recalbox/share/system/.config/retroarch/config/Gambatte/gambatte_libretro.cfg

    Donc toi pour ton cap32 tu peux mettre:
    EMULATEUR.configfile=/recalbox/share/system/.config/retroarch/config/cap32_libreto.cfg
    (par contre je sais pas comment se résume EMULATEUR, pour cap32... faut chercher dans le wiki, peut être que c'est le même nommage que son dossier rom, regarde dans /recalbox/share/roms/ comment il s'appelle, et remplace EMULATEUR par ce nom de dossier)

    Et pour la super nes tu peux rajouter:
    snes.configfile=/recalbox/share/system/.config/retroarch/config/Snes9x\ 2010/TON_FICHIER.cfg (pareil, je sais pas comment se nomme ton fichier cfg à l'intérieur du dossier Snes9x 2010/)

    et tout ça donc, tout en bas du /recalbox/share/system/recalbox.conf (fais une sauvegarde de ce fichier avant ;) )



  • @unik314r

    ok super j'ai compris.

    Je test de suite sur amstrad cpc

    Si c'est bon, plus quà le faire pour chaque émulateur.

    Je te remercie GRANDEMENT pour ton aide !!!



Want to support us ?

Join us on :

261
Online

28844
Users

14649
Topics

110718
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.