Support WHDload et modif config par Défaut



  • Bonjour. Tout d'abbord bravo pour Recalbox qui est vraiment une révélation pour le gamer qui est en moi. Très abouti, très simple, bien pensé, Bravo.
    Avec bonheur, je viens de découvrir le support de ma plateforme préférée : l'Amiga.
    J'ai lu le wiki, regardé les tuto mais je n'aarive pas à lancer un WHDload. Je dois être trop bête mais il est dit qu'il faut compier le répertoire avec les slaves, enlever le .info au même niveau que ce répertoire, créer un .uae avec exactement le même nom que le répertoire et c'est tout (pour la config personnalisée, je verrai plus tard). A chaque fois que je lance un des 4 jeux suivant BattleChess, BlackViper, Wings of death et Wings of fury , retour au sélecteur de jeux. Something is wrong with me. Qu'est ce que j'ai mal fait ?

    Sinon, j'aurais une autre question : Est-il possible de modifier la configuration par défaut de l'amiga ? J'ai remarqué que la vitesse de lecture en X8 des ADF ne gêne en rien la compatibilité avec les jeux que j'ai essayé jusqu'à maintenant et améliore considérablement le confort d'utilisation.

    Encore bravo pour votre travail, surtout à toi Voljega, tu as fait vibrer mon p'tit coeur d'Amigaiste.



  • @rnuls lance un jeu, et au retour sous es, génère une archive de support


  • Moderator
    Moderator
    Team

    @rnuls salut, avant tout, as-tu mis les bios Amiga ?


  • Themer

    @rnuls salut je sais pas si je pourrais t'aider ce soir mais ce weekend sans faute


  • Themer

    @rnuls bon je peux déjà te dire que pour moi le WHDL marche bien dans la dernière version ;)

    la suite ce weekend, en premier lieu assure toi d'avoir les bon bios avec les bon MD5 et bien renommés, un des testeurs avait eu des soucis avec des bios pourtant très officiels mais pas avec le même MD5, l'émulateur est capricieux là dessus



  • @oyyodams said in Support WHDload et modif config par Défaut:

    @rnuls salut, avant tout, as-tu mis les bios Amiga ?

    Oui, j'ai vérifié, ce sont les BIOS recommandés.

    Peut être faut il préciser que j'avais déjà installé amiga4recalbox dispo sur GitHub, version du 15 décembre et que j'avais déjà le problème.

    Pour la mise à jour, j'ai écrit l'image sur ma microSD, pas mise à jour depuis le pi.

    Autre précision, mes roms et BIOS sont sur une clé USB, ah et petite constatation à l'instant, les adf de mon répertoire 1200 ne fonctionnent plus (j'avais Rocketz et Deluxe Galaga qui fonctionnaient pourtant précédemment). Le mystère s'épaissit.

    Merci de vos réponses.



  • Je viens aussi d'essayer de passer par la microSD et pas par l'USB, pareil, plus de 1200. Le 600 tourne bien pour info.
    Peut être dois-je effacer tout ce qui concerne l'amiga ? Je me demande s'il n'y a pas conflit entre la version de github et celle de la mise à jour, C'est quand même étrange que rien ne fonctionne sur le 1200 alors qu'avant, les adf se lançaient.



  • @substring said in Support WHDload et modif config par Défaut:

    @rnuls lance un jeu, et au retour sous es, génère une archive de support

    Tu peux aussi me repondre @rnuls ;)


  • Themer

    @rnuls said in Support WHDload et modif config par Défaut:

    Pour la mise à jour, j'ai écrit l'image sur ma microSD, pas mise à jour depuis le pi.

    Du coup tu es reparti sur une install de zero ? Parce que je vois pas dans ce cas comment tu pourrais avoir un conflit avec la version github comme tu le dis dans ton message d'après ....

    C'est étonnant pour le WHDL du coup est ce que c'est à toi que j'avais donné des commandes à exécuter à la main pour débugger ?



  • @voljega said in Support WHDload et modif config par Défaut:

    @rnuls said in Support WHDload et modif config par Défaut:

    Pour la mise à jour, j'ai écrit l'image sur ma microSD, pas mise à jour depuis le pi.

    Du coup tu es reparti sur une install de zero ? Parce que je vois pas dans ce cas comment tu pourrais avoir un conflit avec la version github comme tu le dis dans ton message d'après ....

    C'est étonnant pour le WHDL du coup est ce que c'est à toi que j'avais donné des commandes à exécuter à la main pour débugger ?

    Tout à fait d'accord pour le conflit, c'est pour ça que j'ai préféré repartir de zéro sur la SD mais vu qu'il restait le répertoire de l'install sur la clé, j'ai pensé à ça ... j'émet des hypothèses.

    Quand aux commandes à la main, ce n'est pas à moi que tu les avais données.


  • Themer

    @rnuls ok .... sur la clé je pense pas que ça crée trop de souci par contre vérifie que tu as toujours bien le répertoire amiga/whdl dans les bios et qu'il y a des choses à l'intérieur

    Tu es un peu habitué aux commandes manuelles ? Sinon ça va être difficile

    Et n'hésite pas à répondre à @Substring ça devrait aider :op



  • @substring said in Support WHDload et modif config par Défaut:

    @substring said in Support WHDload et modif config par Défaut:

    @rnuls lance un jeu, et au retour sous es, génère une archive de support

    Tu peux aussi me repondre @rnuls ;)

    Voici un premier rapport avec le lancement d'un WHDload dans un répertoire WHD situé dans roms/amiga1200 : http://dl.free.fr/nH8lXWFoh

    Voici un second rapport avec le lancement d'un jeu 1200 dans roms/amiga1200 : http://dl.free.fr/bNlAmWAw8

    @voljega said in Support WHDload et modif config par Défaut:

    @rnuls ok .... sur la clé je pense pas que ça crée trop de souci par contre vérifie que tu as toujours bien le répertoire amiga/whdl dans les bios et qu'il y a des choses à l'intérieur

    Tu es un peu habitué aux commandes manuelles ? Sinon ça va être difficile

    Et n'hésite pas à répondre à @Substring ça devrait aider :op

    Désolé pour les délais de réponse, j'étais justement en train d'uplouader les fichiers.

    Dans BIOS il y a .whdlbak et whdl contenant une arborescence type amigaOS avec C Devs S et les fichiers qui vont bien.

    Pour les commandes manuelles, je fait un peu de shell sous amiga et un peu de DOS je pense que ça ira


  • Themer

    @rnuls "IOError: No amiga1200 kickstarts found"

    là ça dit clairement qu'il ne trouve pas kick31.rom dans /recalbox/share/bios

    et ça dit pareil pour le jeu en ADF



  • Et pourtant il y est, et vérifié md5 !


  • Themer

    @rnuls tu peux aller dans le répertoire des bios et me donner le retour de la commande ls -l | grep kick31.rom ?



  • @voljega J'ai du nouveau : ça fonctionne.
    En fait, j'avais un fichier "Kick31.rom" et "Kick31CD32.rom". J'ai effecé la rom de la CD32 et renommé en minuscules (il ne voulait pas renommer la rom j'ai du la copier/renommer temporairement et l'effacer pour ensuite renommer avec le bon nom kick31.rom en minuscules. J'ai lancé directement et ça fonctionne. Merci beaucoup de votre aide, de votre réactivité et votre patience, sans oublier la compétence. Chapeau Bas et encore merci.
    Problème résolu.

    Et concernant la modif de la configuration par défaut ? Est-ce possible "simplement" ?


  • Themer

    @rnuls ah bah oui bon à savoir pour l'avenir contrairement à Windows sous n'importe quel système linux, kickstart31.rom et Kickstart31.rom ce n'est pas le même fichier, la casse est importante ;)

    bon jeu, du coup je te conseille de privilégier le WHDLoad et sous amiga1200, la plupart des jeux fonctionnent sans aucune modification

    pour la modif, je te renvoie au wiki, il y a des exemples de config modifiées, que souhaite tu changer exactement ? il y a deux systèmes complémentaires de modification



  • Je souhaite que par défaut lorsque je lance un ADF, le lecteur soit à la vitesse de 800%, ce qui accélérera le lancement des jeux (je sais via les WHDload, on oublie ce type de désagréments).


  • Themer

    @rnuls ah ok la modification de conf n'est possible que oour le whdl.

    Je n'ai pas mis ce paramètre par défaut parce que c'est censé être instable et faire planter certaines disquettes.... Peux tu me dire où dans le GUI de l'emulateur tu modifies ce paramètre ? Devrait avoir moyen de te faire bricoler un truc



  • Dans l'onglet "floppy drives" en bas, il y a "floppy emulation speed" qui est par défaut à "100% (compatible)" sauf que ça déconne jamais donc autant charger rapidement. Certes il y a peut être 0,01% des jeux qui ne tourneront pas à 800% mais bon ... Ah petite question aussi, est-il possible de générer des .uae à partir d'un répertoire car je me paluche tout à la mais et c'est loooooooonnnnnng



Want to support us ?

Join us on :

151
Online

28822
Users

14643
Topics

110694
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.