Recalbox 7.0

Problème Overlays



  • Bonjour tous le monde !

    Alors voila, j'ai complètement fini de configurer mon recalbox. Tout est beau, propre, scraper... Parfait en somme !

    J'ai juste un dernier petit problème !

    En effet, j'ai voulu mettre des overlays pour certain jeux ! Je fais tout ce qu'il faut, tout marche, les overlays sont en place, bref, que du bonheur !

    Mais voila, il y a un petit couac ! Je vais expliquer avec mon exemple concret pour essayer de bien me faire comprendre !

    Alors voila, je met 2 overlays, 1 pour space invader et un pour Ghouls'n'Ghost. Jusque la, tout va bien ! Mais c'est à partir de la que ça se complique !

    Les réglages vidéos de space invader et de ghouls'n'ghost sont différents !
    Du coup, quand je passe en custom pour racalibrer la gauche et le haut de l'écran, bah ça me le fait pour les deux ! En gros, quand je calibre parfaitement Ghouls, Space invader n'est plus calibré !

    Est-ce possible de faire des configs pour chaque jeux ? J'ai bien vu qu'il y avait "Save Game Overrides" et "Create game-options files ....... spacedx"
    Ce serait en passant par ces options la ?

    Deuxièmement, mon écran n'est pas calibré. J'ai un cadre noir, l'overlay et le jeu. Comment puis-je enlever le cadre noir autour de l'overlay ? En passant par les Groups_hdmi et tout ?

    Merci d'avance pour vos réponses !

    Bonne journée !



  • Ah et super ! J’ai encore été trop pressé et têtu, j’ai utilisé les deux options que j’ai cité dans le’ post du dessus, maintenant j’ai les réglages de ghouls par défaut. Tout les jeux ont l’overlay de ghouls, et la taille d’ecran Que j’ai défini sur ghouls .... on peut remettre par défaut ? 😕



  • Désolé pour le triple poste, je n’arrive n’y a modifier ni à supprimer un post !

    Pour mon deuxième post, cents réglé, je suis revenu aux réglages de base, mais ça n’en resoud toujours pas mon problème de calibrage !



  • Personne pour répondre à ma question ? 😕



  • @helsephyne tu dois pouvoir mettre les infos de calibrage dans le .cfg de l'overlay. Sinon, tu peux mettre ca dans configs/retroarch/system/nomrom.cfg

    System = le nom du systeme dans le rep de roms (mame ou fba_libretro eb general)
    Nomrol : le nom denla rol sans extension

    Ce fichier sera lu en plus du retroarchcustom.cfg



  • @Substring merci beaucoup !
    Dans le cfg du rom, il faut mettre la config en entier ? Ou juste les paramètres pour les pos x et y ?
    Genre, le système lit retroarchcustom ET monrom.cfg ou juste monrom.cfg ?



  • @helsephyne que ce qui te sert, à la base. Ca devrait surement aussi tenir dans le .cfg de l'overlay, si tu veux limiter les fichiers à créer



  • @Substring ca marche !

    Du coup dans le nomrom.cfg ou nomrom.zip.cfg de l’overlay ?



  • @helsephyne à ton aise, essaie les 2



  • @Substring d’accord!

    Donc si je récapitule :
    Dans le fichier config de l’overlay, à la suite, je rajoute juste quelque chose du genre :

    custom_viewport_x = "306"
    custom_viewport_y = "89"
    custom_viewport_width = "980"
    custom_viewport_height = "728"



  • @helsephyne oui ca devrait marcher. sinon, tu connais l'autre solution



  • @Substring l’autre solution ?



  • @helsephyne mettre dans configs/retroarch/system/nomrom.cfg



  • @Substring Je reviens vers toi avec un peu de retard, semaine bien chargée !

    Alors, déjà, je te remercie énormément, en rentrant les paramètres dans le fichier nomderom.zip.cfg de l'overlay, ça fonctionne !!!!

    J'ai juste un dernier problème :

    Quand j'ajoute un nouvel overlay, j'ai une ligne qui s'ajoute a RetroArch.custom.cfg, a chaque fois, avec Input............monoverlay.cfg, ce qui fait que le dernier overlay est activé pour tout les autres jeux ( excepté ceux avec déjà un overlay) .
    Du coup, si je vais supprimer la ligne, ca marche, jusqu'au redémarrage, ou il remet la ligne...

    Merci encore !



  • @Substring Ouai, j'ai refait le test plusieurs fois, j'ai toujours la ligne :

    input_overlay = "/recalbox/share/overlays/fba_libretro/1941.cfg"

    qui se rajoute au fichier 😕

    (1941 changeant en le dernier overlay mis )



  • @helsephyne aurais-tu activé le save on exit dans retroarch ?



  • @Substring oui, je ne dois pas ?



  • @Substring bon écoute, j’ai enlevé le save on exit... et ça marche !!

    Merci beaucoup !!



  • @helsephyne you'renwelcome 🙂 au moins un qui sait lire les tutos sur les overlays 🙂



  • This post is deleted!

Log in to reply
 

Want to support us ?

109
Online

79.1k
Users

20.4k
Topics

149.2k
Posts