Pb Shaders et Overlays



  • Hello,

    Quelques mots pour résumer mon problème :

    J’ai DL des overlay principalement pour mes emu portables, j’installe, tout fonctionne nickel, je paramètre le calage image dans retroarch et là... j’ai dû faire une erreur car mon skin GBC est le même pour ma GB, alors que j’avais juste avant, un joli skin GB.

    De plus, aucun shader sur GB...
    Que ce soit depuis le menu de la recal ou le recal manager (gb.shader=retro par exemple) rien ne fonctionne SAUF, les shaders in game (retroarch)

    J’ai nettoyer toutes mes manips du recalbox.conf en mettant celui d’origine, toujours rien...

    Je pense que mon pb vient d’une mauvaise manip sur retroarch, car dans mon emu gb, retroarch>settings>onscreen display>onscreen overlay>overlay preset>gbc.cfg et non pas gb.cfg...

    Mais je ne sais pas le changer...

    Help ?


  • Moderator
    Moderator
    Team

    @g-fox dommage que tu ne soit plus sur le chat mais on va continuer ici.

    1. Connecte-toi à Recalbox en mode terminal
    2. Tape:
    cd .config
    rm -rf retroarch
    cd
    cd configs/retroarch/
    export TERM=xterm
    nano retroarchcustom.cfg
    
    1. Vérifie que config_save_on_exit est bien à false
    2. Ctrl X (pour quitter nano)
    3. Réessaye


  • Salut OyyoDams !

    Merci tout d'abord pour ta réponse

    J'ai tenté ce que tu m'a dis de faire, mais j'ai le niveau informatique d'un fœtus, première fois que j’accédais dans des lignes de commandes mdr

    Bref, le save on exit était bien en false...
    Mais j'ai un peu fouiller dans toute ces lignes pour voir si je ne trouvais pas un truc en rapport et j'avais 2 lignes :

    savestate_directory = /recalbox/share/saves/gbc
    savefile_directory = /recalbox/share/saves/gbc

    j'ai voulu tester en supprimant le gbc à la fin de ces 2 lignes et tadaaaaaaa ! Magie, ça a fonctionné ! Je te remercie encore pour m'avoir montré le chemin, à moi maintenant de ne plus recommencer la même erreur ;)

    See You


  • Moderator
    Moderator
    Team

    @g-fox nickel amuse toi bien ;)



  • Re !

    Une dernière question, en ayant mis l'overlay, je règle l'aspect ratio et la position de l'image pour caler avec l'overlay, mais je n'arrive pas a désactiver définitivement la fonction "Integer Scale" et je n'ai pas trouvé la ligne de code correspondante pour la modifier en racine dans les fichier .cfg.

    Help ?



  • @oyyodams
    Re !

    Une dernière question, en ayant mis l'overlay, je règle l'aspect ratio et la position de l'image pour caler avec l'overlay, mais je n'arrive pas a désactiver définitivement la fonction "Integer Scale" et je n'ai pas trouvé la ligne de code correspondante pour la modifier en racine dans les fichier .cfg.



  • Après avoir pris le temps de lire plus en profondeur le wiki, je viens de trouver la réponse à ma question ; )

    Merci pour le travail de ouf que vous accomplissez tant à travers l’expérience vidéo-ludique que sur le plan instructif ! Bravo



  • @g-fox said in Pb Shaders et Overlays:

    OyyoDams

    Bonjour G-Fox et OyyoDams,

    Je me permets de remonter ce sujet car j'ai exactement le même problème que je ne suis arriver à résoudre malgré vos réponses.
    J'ai installer les Overlays, ils fonctionnent tous sauf pour le gb qui m'affiche l'overlay du gbc et la mastersystem qui m'affiche l'overlay de la megadrive. Tous mes fichiers config m'ont l'air correct, je ne comprends pas d'où peut venir le problème.

    Merci pour votre aide.



  • @snapouille
    Bonjour, j'ai eu un problème similaire. Dans Retroarch je n'avais pas supprimé l'option "save on exit". Une fois l'option mise sur off tout est rentré dans l'ordre.



  • Merci pour ta réponse Tornelf mais mon problème ne vient pas de l'option "save on exit" que j'ai bien désactivé.
    Mon problème ne concerne que la gb et la master system, sur tous les autres systèmes les bezels sont fonctionnels.



  • @snapouille Je ne comprend pas comment il peut y avoir une exception dans retroarch pour GB ou MS. Soit tout fonctionne, soit rien. Donc soit t'as une faute de frappe dans ton fichier config, soit t'as un paramètre de retroarch qui fait planter l'overlay sur ces deux systèmes soit tes overlays sont pas en 1280 x 720.



  • @Tornelf
    mon fichier config me semble correct (en tout cas il est identique aux autres fichier config qui fonctionnent) et mes overlays sont bien en 1280 x 720.

    Quand je lance GB et que je vois voir dans les options de Retroarch au niveau du "overlay preset" j'ai "gbc.cfg" qui est indiqué au lieu de "gb.cfg".

    Mais dans mon gb.cfg j'ai bien :
    input_overlay = "/recalbox/share/system/configs/retroarch/overlays/gb.cfg"



  • @snapouille il cherche le fichier gameboy color... Et sur gameboy color t'as gbc aussi?



  • @Tornelf, oui sur gameboy color j'ai bien le gbc.
    Je sais pas si le fait que j'ai mes roms sur usb change quelque chose à la donne ?



  • @snapouille non les miennes le sont aussi.



  • Et t'es sure que dans le menu retroarch/settings/configurations y'a bien save on exit off?

    Sinon à tout hasard t'as pas un répertoire avec un fichier GB custom dans /recalbox/share/system/.config/retroarch/config?



  • @tornelf said in Pb Shaders et Overlays:

    ecalbox/share/

    Oui save on exit est bien sur off.
    Dans le .config/retroarch/config j'ai juste un fichier mGBA.cfg



  • @snapouille Je ne vois pas...



  • merci quand même. Je cherche, je cherche, mais je trouve pas le moment ou j'ai pu foirer...
    J'ai du toucher à quelque chose à moment car au début ça fonctionnait bien...



  • @snapouille Au pire comme t'as les Roms sur USB tu peux réinstaller pour voir si ça change quelquechose.


Log in to reply
 

Want to support us ?

Join us on :

235
Online

28884
Users

14657
Topics

110787
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.