USB N64 controller mapping



  • I've searched the forums extensively, but can only find outdated posts that do not solve my problem.

    I am running Recalbox V4.1.00DEV on an ODroid Xu4. I have an iNNEXT n64 USB gamepad that shows up as [Generic USB Joystick ]

    no matter what I do, i cannot get this to work properly with N64 games. I found several links stating that i need to edit the share/system/configs/mupen64/InputAutoCfg.ini file to match my inputs and then post the following line (n64.configfile=dummy) to my recalbox.conf file, which i did. This doesn't seem to do anything.

    There was already a section in my InputAutoCfg.ini for [Generic USB Joystick] that appears to have the buttons mapped correctly. but it doesn't seem to be using that configuration for some reason.

    I connected via SSH and ran cat /proc/bus/input/devices to see how my controller was listed, it showed up like:

    [Generic USB Joystick ]

    I noticed that there were two spaces after the word joystick so i edited my InputAutoCfg.ini to match that, it still doesn't work.

    It is almost as if it is pulling it's config from a different file location.

    any ideas?



  • After manually looking through the file system at various locations, i think i got it resolved.

    In order to get the mupen64 controls to match up to my uxb n64 controller, i had to make the changes in a different file:

    First, the file system is read only, so you have to make it writable by running the following command:

    mount -o remount,rw /

    then edit the following file:

    /recalbox/share/system/configs/mupen64/InputAutoCfg.ini

    add the following text:

    [Generic USB Joystick ]
    plugged = True
    plugin = 2
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    Mempak switch =
    Rumblepak switch =
    mouse = False
    A Button = button(6)
    B Button = button(8)
    C Button R = button(1)
    C Button U = button(0)
    C Button L = button(3)
    C Button D = button(2)
    DPad D = hat(0 Down)
    DPad L = hat(0 Left)
    DPad R = hat(0 Right)
    DPad U = hat(0 Up)
    L Trig = button(4)
    R Trig = button(5)
    Start = button(9)
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)
    Z Trig = button(7)

    This will set your controls properly. THen you will most likely run into issues with hotkeys. As it turns out mupen64 has it's own hotkeys that are separate from the default ones. to change them, you have to edit the following file:

    /recalbox/share/system/configs/mupen64/mupen64plus.cfg

    look for the section titled

    [CoreEvents]

    locate the joy mapping shortcut you wish to disable and change the value to ""

    for example, to disable fast forward, find this:

    Joystick event string for fast-forward

    Joy Mapping Fast Forward = "J0B4/H0V2"

    and change it to:

    Joystick event string for fast-forward

    Joy Mapping Fast Forward = ""

    repeat for all hotkeys you wish to disable. (screenshots and save states were really messing with mine)



  • thx thx thx god bless you. i Love. Yesterday bought two innext n64 Kontroller 4 my odroid. now i am happy. greetings from germany/bavarian


Log in to reply
 

Want to support us ?

Join us on :

334
Online

29844
Users

14892
Topics

112146
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.