Moonlight black screen



  • Hello,

    I have started a new topic on this regarding the moonlight not displaying the screen.

    I am currently running recalbox 17.12.02 and moonlight 2.2.2

    I have tried GEF 2.11.2 up to and currently 3.0.4. In total I have tried about 8 different versions. This includes 3.11 which works just the same.

    If I click on the moonlight emulator and the stream file inside the emulator. It will take me to the loading screen which is black, recalbox logo at the bottom and the version to the left. This is then stuck on that screen.

    I am however able to then log into the Pi 3 using putty and run the command "moonlight stream"

    For me this gets everything how I would expect it to be. Screen on, controller working and sound. If I then leave the stream, I go back to the black screen, at this point I have to re-start the Pi in under to go back to the emulation selection screen.

    Is there a command I can create which would run the "moonlight stream" when I click on a file inside the moonlight emulator folder. The only issue is that it needs to enter the loading screen for it to show the screen.

    If I just ran the "moonlight stream" command anywhere such as the home screen, the sound will come through, the computer and controller will kick in to play but the screen won't show. I can just leave the stream and everything works fine again.

    I would also like to mention that my roms are stored on a network shared folder. I know it retropie, this causes issues with some emulators. Could be the same thing happening here? I would need to test this my self when I have time.



  • I have a similar problem with this. I'm using GFE 3.11.0.73 and the latest recalbox.

    I successfully paired recalbox and moonlight. Could not scrape as it said thegamesdb was down but the games do show up in my list under moonlight in emulation station.

    When I attempt to launch any games I get stuck to the black loading screen (with recalbox logo on bottom) and it just stays there.

    Unlike the OP if I run 'moonlight stream' I get an error that says I need to pair first. But if I run '/.Moonlight.sh pair' again I get another error saying that I'm already paired.

    So I can do nothing but reboot. No games will launch at all.


Log in to reply
 

Want to support us ?

Join us on :

216
Online

28853
Users

14652
Topics

110740
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.