N64 écran 7" raspberry



  • Bonjour à toutes et à tous,

    Je suis novice en la matière donc je galère vraiment sur un point bien particulier.

    En effet, j'ai installé ma recalbox sur un raspberry pi 3 avec l'écran officiel de 7" (magnifique !). Après avoir résolu le problème d'écran inversé je me suis confronté à un énorme problème avec l'émulateur N64. Les jeux ne fonctionnent pas sauf si dans le fichier recalconf la ligne relative à la résolution de l'émulateur est sur "default".

    Ok pour le moment ça va sur l'écran 7" les jeux fonctionnent mais, il a fallu que je modifie le fichier de configuration MUPEN64PLUS pour activer le mode plein écran.

    Mon problème : lorsque je démarre avec le port HDMI la console s'affiche avec le son sur ma TV, tout fonctionne sauf évidement les jeux sous l'émulateur N64. En effet les jeux sont très lents et le son je n'en parle pas c'est une catastrophe !

    Savez-vous de quoi il s'agit ? D'après ce que je comprends c'est un problème entre le mode plein écran et le mode fenêtre (oui en mode fenêtre dans le fichier de configuration MUPEN64PLUS les jeux fonctionnent bien en HDMI mais l'écran affiche une toute petite fenêtre en bas à gauche)

    Ma configuration :
    Raspberry pi 3
    Ecran officiel 7"
    Boitier noir

    Lignes de configuration :
    RECALCONF :
    n64.videomode=default

    MUPEN64PLUS :
    Fullscreen = True
    ScreenWidth = 640
    ScreenHeight = 480
    AspectRatio = True
    VerticalSync = True

    Par avance merci !


  • Moderator
    Team

    @injall Tu es dans un cas particulier qu'on ne peut pas encore supporter ... Tu dois mettre default pour ton écran, mais ca oblige a rester en 1080p quand tu es sur ta TV ...

    Donc aujourd'hui, il n'existe pas de réponse technique possible. Mais comme je t'ai dit "pas encore supporter", c'est que j'ai avancé sur la simplification de la config des écrans, mais je n'ai pas prévu le cas où en configuration automatique, no doit quand même forcer un mode particulier ... Ca ne devrait pas être trop dur



  • @Substring Merci pour ta réponse. Et bien je cherche....



  • J'ai une piste ! Il faudrait que j'arrive à dire pendant le BOOT que lorsqu'il détecte que le port HDMI est utilisé alors il faudra utiliser un fichier de configuration différent du RECALCONF !



  • Par exemple :

    • Je démarre sur mon écran de 7", le fichier de configuration utilisé est le "recalbox.conf"
    • Je démarre sur le port HDMI, le fichier de configuration utilisé est le "recalbox.hdmi.conf"

    Tu vois ce que j'essaye de faire ?


  • Moderator
    Team

    @injall oui.

    Tu dois créer un script d'init qui s'occupera de ca. Pour savoir qui est connecté, utilise tvservice -s. Je crois que l'ecran 7" de Raspberry ressort en DSI. Sinon tu auras HDMI (ou DVI). Si tu connais un peu linux, ca sera du pipi de chat tout ca. Le probleme, c'est qu'un de tes .conf ne sera pas mis à jour lors des upgrade ... Donc le mieux c'esst d'utiliser les fonction de sauvegarde de valeur de configgen et de se contenter de changer la valeur de n64.videomode



  • J'ai déjà résolu ce PB propre à l'écran Officiel.
    Regarde mes posts et tu trouveras la solution.
    De mémoire, passe le paramètre juste en dessous de la résolution sur false et cela devrait le faire.



  • @substring Hmm, ton histoire de script m’intéresse mais, je crains que mes compétences ne soient pas à la hauteur...



  • @jidem J'ai bien pris connaissance de tes messages sur le sujet mais, en respectant tes indications en mode HDMI l'affiche est bien en plein écran (en 640x480) mais, les jeux sont ralentis et le son, aussi ! (avec l'écran 7" débranché ou non, même problème)

    Configuration :

    Dans recalbox.conf la ligne n64.videomode = default

    Dans mupen64plus.cfg :
    [Video-General]

    Fullscreen = True
    ScreenWidth = 640
    ScreenHeight = 480
    AspectRatio = False
    VerticalSync = False



  • Ok je regarde ce soir car c'est nickel chez moi.



  • @jidem Merci !

    Je ne sais pas si c'est nécessaire de vous signaler que j'ai suivi le tuto disponible ici pour avoir la possibilité de démarrer soit sur l'écran DSI ou sur l'HDMI. De plus ma configuration actuelle est overclockée en extrême depuis le menu de configuration sous ES.



  • @injall j'avais vu ce tuto mais je trouvais que c'était une usine à gaz. Un interrupteur sur l'alim de l'écran fait le même job.



  • @injall alors je pense avoir trouvé
    Passe fullscreen sur false et widowed mode sur true et fait nous un retour



  • @injall à la place de ton tuto à rallonge si tu as l'occasion teste ça: édite config.txt et rajoute la ligne suivante :
    display_default_lcd=0
    Normalment avec cette commande si la cable hdmi est branché l'écran 7´ n'est plus prioritaire.



  • @jidem Salut,
    Merci pour tes réponses. J'ai des recherches dans le fichier MUPEN64PLUS et je n'ai pas trouvé le "widowed mode" !



  • @injall je regarde ce soir...
    Je n'avais pas ma Recalbox de dispo hier. 😉
    Et cet saloperie de correcteur d'orthographe à modifié ma ligne...lire windowed mode
    Tu mets True pour cette ligne et false pour fullscreen



  • @jidem Je ne trouve pas la ligne "windowed mode" dans le fichier MUPEN64PLUS !



  • @injall je regarde ce soir comme promis...pas impossible qu'il faille la rajouter ! 😉



  • @injall bon je viens de faire mumuse pendant 2 heures et je rejoint @substring , on ne pourra pas avoir du beurre, l'argent du beurre et le cul de @substring en bonus! LOL

    Jouer à la 64 sur l'écran 7 pouces convenablement et sur la prise HDMI sans passer par des scripts à gogo est impossible.
    En gros, comme la commande tvservice ne fonctionne pas avec l'écran connecté en DSI, en passant le paramètre sur défaut impose un affichage avec la résolution max de l'écran connecté soit 800x600 pour l'écran 7 officiel et 1080 pour la tv en hdmi.
    Maintenant en modifiant le paramètre fullscreen sur true de mupen64plus.cfg on étire pas le 640x480 mais on force la résolution max de l'écran.
    Cela reste invisible sur l'écran officiel car on passe de 640x480 avec la bande noire sur le côté droit à 800x600.
    Mais sur la TV en HDMI, on passe de 640x480 en bas à gauche de l'écran à du 1080 et là, même avec le pi3 overcloké à mort ça rame un poil!
    Il y a surement moyen d'améliorer tout ça mais pour ma part le compromis me suffit. ;-)


  • Moderator
    Team

    J'ai un développement fini si correspond presque à ce genre de situation ... J'ai ajouté un videomode auto qui vérifie si l'ecran supporte la résolution voulue (pour le moment juste le CEA 4), sinon il propose default

    Là on est dans un cas différent puisqu'on ne veut pas du tout la N64 en CEA 4. Je devrais pouvoir ajouter une option pour choisir le mode attendu. Rien de difficile. La seule condition est que l'écran DSI ne renvoie pas que 640x480 est une résolution qu'il supporte


Log in to reply
 

Want to support us ?

Join us on :

310
Online

28074
Users

14385
Topics

108945
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.