Problème appairage Wiimote



  • Bonjour !

    J'ai suivi les indications de cette page afin de pouvoir connecter une Wiimote car le système automatique de l'interface ne fonctionne pas pour moi. J'ai un message du style "Appairage impossible" ou quelque chose comme ça.

    J'ai donc lancé une session SSH avec Putty, puis lancé bluetoothctl, et taper les commandes suivantes :

    agent on
    default-agent
    power on
    scan on

    sans problème.

    Le scan détecte apparemment correctement la Wiimote une fois celle-ci en mode détection.

    Ensuite je tape pair suivis de l'adresse MAC de la Wiimote. Ca me demande alors un code PIN... que je ne connais pas. Forcément, une erreur d'authentification se produit car le PIN n'est pas bon, c'est ce qui est dit explicitement dans le message.

    Je ne connais pas exactement ce que fait la commande trust mais j'imagine que ça doit avoir un rapport avec le fait de ne pas avoir besoin du code PIN. Je le fais donc suivant de l'adresse MAC.

    Ensuite je fais connect suivis toujours de l'adresse MAC de la Wiimote et ça fonctionne. La diode du joueur 1 sur la Wiimote reste allumée et je peux utiliser celle-ci dans recalbox, du moins dans l'interface.

    Le problème c'est si je redémarre le bouzin la manette n'est plus reconnue, je suis forcé de refaire la manipulation depuis Putty... Pas très pratique vous en conviendrez ;-).

    Une idée de solution ?

    Merci d'avance !

    Précision : je n'utilise pas de dongle BT.


  • Moderator
    Moderator
    Team

    @vilikt salut, pour mettre ta wiimote en mode appairage, tu passes bien par le bouton situé dans le logement à piles ? Car l'appui sur les boutons 1 et 2 ne fonctionne pas.



  • @oyyodams

    Merci beaucoup ! J'avais oublié ce fameur bouton !


Log in to reply
 

Want to support us ?

Join us on :

279
Online

31122
Users

15123
Topics

113786
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.