Games don't start when using Sega Master System Control Pad 3020



  • Hi there,

    I successfully converted a Sega Master System Control Pad 3020 to USB with this circuit: http://www.raphnet-tech.com/products/nes2usb/

    The gamepad is detected by Recalbox and I am able to configure the directional pad and the two buttons. The "1 / Start" button as "B" and the "2" button as "A", but I've also tried other settings.

    Unfortunately if I start ROMS (not only for SMS) the screen goes black and returns to menu after a few seconds.

    With Xbox Controller 360 and NES30 Pad everything works fine.

    I suppose the problem is related with the lack of a configured Start or / and Select button, but I'm not sure about it.

    Is there anything I can do to get / provide more information that helps to solve the problem?

    PS: I've got it running with Lakka, but I prefer Recalbox.



  • My assumption regarding lack of Start / Select button in controller configuration was right.

    I solved the problem by simply adding fake entries to /recalbox/share/system/.emulationstation/es_input.cfg



Want to support us ?

Join us on :

244
Online

31178
Users

15131
Topics

113836
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.