SAMBA Connections Problems



  • Hi,

    I have recently updatef my recalbox to version 'Linux RECALBOX 4.4.13-v7 '. After the update, SAMBA client stopped to work on KODI.

    I am afraid that there is an incompatibility between the server side which works with samba v1 (Version 3.0.37, It doesn't suport v2/v3 connections) and the client. I've tried to execute smbclient from terminal (by ssh recalbox),

    smbclient -L //<hdd-ip> -U <username>%<password>

    Server does not support EXTENDED_SECURITY but 'client use spnego = yes and 'client ntlmv2 auth = yes'
    session setup failed: NT_STATUS_ACCESS_DENIED

    Does anybody know whether the configuration can be changed to support samba v1? If It is posible how it can be done?

    Thanks in advance
    Iago



  • I resolve the problem by editing the files ./.smb/smb.conf and /etc/samba/smb.conf to add

    client use spnego = no
    client ntlmv2 auth = no

    to edit these files I changed to recovery mode :

    mount -o remount, rw /boot
    nano /boot/config.txt
    avoid_safe_mode=0
    reboot
    mount -o remount, rw /
    nano ./.smb/smb.conf
    client use spnego = no
    client ntlmv2 auth = no

    I hope it helps.



  • Wow Thanks it worked for me as well!!

    I think I had the same problem since the last update (17.11.10.2) with smb shared folders requiring a login and password.
    I find it wierd that nobody else seems to have reported this issue though, maybe I'm just not good at searching :)


Log in to reply
 

Want to support us ?

Join us on :

243
Online

28779
Users

14634
Topics

110629
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.