This:

VideoCore VI graphics, supporting OpenGL ES 3.x

I think there will be an improvement in the following emulators:

n64 dreamcast playstation (beetle-hw)

All require GLES 3.x for full support ;-)

Will this affect Recalbox in the future?:

Buster will release with a 32-bit userland, as backwards compatibility for all previous models is important. The Pi 4 kernel uses LPAE but eventually we'll ship a 64-bit kernel.

PS: Possibly more performance in MAME with 2 or 4 Gb of RAM (i think)