Falsche Uhrzeit



  • Hallo bin Forum Neuling.
    Ich habe das Problem mit der Uhrzeit in Kodi. Ich bin schon seit einigen Wochen auf der Suche nach einer Lösung, jedoch ohne Erfolg.
    Des weiteren komme ich auch nich mehr über Putty auf den Raspi über Wlan. Jedoch wenn ich ein Lan Kabel nutze klappt Patty. Die Zeit bleibt bei Beinen Varianten falsch.


  • Team
    Moderator
    Translator

    @teus

    Hallo,

    was bedeutet "falsche Uhrzeit" in deinem Fall genau?
    Bist du denn über wlan auch anständig verbunden (zeigt recalbox den Status connected)?

    EDIT: Informationen zur recalbox Version und deinem pi wären auch interessant.



  • Die Uhrzeit ist immer auf 1Uhr und 1970. Der Raspi ist c.a. 5m neben dem Reuter. Und ich kann auch ohne Probleme auf mein NAS zugreifen. Auch verschiedene Online Dienst kann ich nuzten.


  • Team
    Moderator
    Translator

    @teus

    Informationen zur recalbox Version und deinem pi wären interessant.



  • Ok mache ich gerne. Kann das aber erst ab 20Uhr. Es ist ein Paspberry PI3 und ich habe am Wochenende die aktuelle version runtergeladen und installiert. Ich habe die OSMC version direkt installiert da funktioniert alles. Aber ich möchte auch öfter alte Games zocken. Daher mochte ich auf Recalbox bleiben.


  • Team
    Moderator
    Translator

    @teus

    Das liest sich abenteuerlich und ich tappe etwas im Dunkeln.

    Zum Verständnis:
    Bei einer wlan Verbindung ist der Zugriff auf dein NAS und Online-Dienste (vom pi aus) möglich, putty jedoch nicht. <-- Für mich stimmt da grundsätzlich etwas nicht.

    Wie wurde recalbox installiert, über NOOBS oder Download über die Webseite?https://github.com/recalbox/recalbox-os/releases

    Test 1:
    Gib den Befehl date über ssh ein.

    Test 2:
    Bevor du Kodi startest, schau mal bitte in recalbox (ES Gui) in den Netzwerkeinstellungen, ob du wirklich verbunden bist.



  • Erst einmal Danke für die Schnelle Antwort.
    ich habe jetzt nochmal alles neu Installiert "recalboxOS-4.0.1"!
    Und über Kabel funktioniert alles richtig.
    Doch wenn der Raspi über Wlan verbunden ist kommt immer wieder dir Zeit 1 Uhr 1970. Aber er ist mit dem Internet Verbunden. Hier ein par Bilder wenn ich mit Wlan Arbeite:
    0_1504638042778_Raspi1.jpg
    0_1504638071082_Raspi2.jpg
    Und im Explorer wird er auch angezeigt.
    0_1504638267537_Raspi3.jpg
    Mit dem Chrome Webbrowser komme ich auch drauf.
    und eine SSH Verbindung klappt nicht.

    Ich danke im voraus für eure Hilfe.


  • Team
    Moderator
    Translator

    @teus

    Ich habe es gerade mal LIVE getestet (mit Version 4.0.2).
    wifi aktiviert - mit ssid und passwort
    reboot
    Kodi gestartet - Uhrzeit und Datum sind ok.

    Vielleicht braucht dein wlan zu lange, und es verursacht dadurch Probleme.

    Teste mal folgendes in der Konsole:
    echo "/etc/init.d/S49ntp star" > ~/custom.sh
    chmod u+x ~/custom.sh

    Dies würde einen Neustart von NTP (Network Time Protocol) am Ende des Bootvorganges erzwingen.
    (allerdings erklärt es nicht die Probleme mit ssh über wlan).

    Sorry wegen den Eingaben im Terminal, recalbox ist eigentlich ein out-of-the-box System, welches bei mir auch genau so funktioniert.
    Aber wir müssen bei Problemen oder Fehlern jede eventuelle Lösung finden bzw. ausloten.



  • Also ich habe jetzt auf Version 4.0.2 upgedatet
    Und habe das Terminal über F4 anschließend Alt+F2 geöffnet dann mit date probiert, da kommt wieder 1 Uhr 1970.
    Anschließend folgendes Probiert:
    echo "/etc/init.d/S49ntp star" > ~/custom.sh
    chmod u+x ~/custom.sh
    und wieder mit date geschaut, keine Veränderung.
    auch nach einem Neustart, nichts.
    Nun habe ich die Vermutung da meine Zeit nicht stimmt kann das mit Putty auch nicht klappen.

    Nun eine andere Frage:
    Kann ich ein Time Clock Modul (DS3231) verwenden?


  • Team
    Moderator
    Translator

    @teus

    So langsam gehen mir echt die Ideen aus.
    Du könntest dies hier durchführen, da kann sich das mal ein Profi anschauen bei Zeiten.
    https://github.com/recalbox/recalbox-os/wiki/recalbox-Support-%28DE%29

    Ich sehe mit deinem Zeitproblem und Putty keinen Zusammenhang.

    Aber mal nebenbei:
    Ich sehe in deinem Bild oben "free memory=366mb".
    Wie groß ist deine SD Karte?
    Kommst du in die "Systemeinstellungen (system settings) von recalbox"?

    Zu dem Time Clock Modul (DS3231) kann ich dir leider nichts schreiben.



  • ich habe eine 4GB karte zum Testen benutzt.
    Mit welchem Befehl kann ich die Uhrzeit und datum von Hand eingeben.
    Und wie komme ich wieder zurück auf die Recalbox Oberfläche ohne Reboot.


  • Team
    Moderator
    Translator

    @teus

    Es soll mindestens eine 8GB Micro SD Karte verwendet werden.
    Wenn du Kodi beendest (nicht herunterfahren), solltest zu zur recalbox Oberfläche zurückkehren.



  • Ok ich teste mit einer 16 GB Karte.
    Ich möchte von dem Terminal wieder zurück auf die Recalbox Oberfläche


  • Team
    Moderator
    Translator

    @teus

    teste mal emulationstation

    EDIT:
    EmulationStation stoppen: 
    /etc/init.d/S31emulationstation stop
    EmulationStation starten: 
    /etc/init.d/S31emulationstation start


Log in to reply
 

Want to support us ?

Join us on :

155
Online

28895
Users

14663
Topics

110812
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.