Bouton power reset nes sur raspberry pi zero w


  • Themer

    Bonjour,

    Après pas mal de bidouille j'ai réussi à créer un nouveau mode pour ma vieille nes. Je me suis d'ailleurs bien inspiré des différents topic que l'on trouve sur le sujet.

    0_1494840539573_upload-53009222-b17a-4af3-a452-86542033815c

    Du coup comme vous pouvez le voir j'ai installé un raspberry pi zero w, j'ai branché les manettes de la nes en gpio (cela fonctionne parfaitement). Et j'ai également branché les boutons powers et la
    led sur le gpio, mais malheureusement j'ai beau renseigner la commande "system.power.switch=PIN356ONOFFRESET" dans recalbox.conf cela ne fonctionne pas.

    Pour le raspberry j'ai monter l'image grâce au tuto de @simba51

    "Télécharger le fichier "recalbox.img" version rpi1 de recalbox 4.1 unstable (https://archive.recalbox.com/updates/v1.0/unstable/)

    flasher l'image sur votre carte micro-sd comme vous faite habituellement avec Win32disk par exemple

    Recupérer les fichiers :

    bcm2708-rpi-0-w.dtb
    bootcode.bin
    fixup.dat
    start.elf
    

    de la dernière version de "2017-03-02-raspbian-jessie-lite.img"

    J'ai également vérifier que le script était bien existant dans recalbox/scripts/.
    Et j'ai vérifier plusieurs fois mes soudures sur le branchement suivant:
    -Power+ (Fil marron) --> GPIO3 (pin 5)
    -Reset+ (Fil jaune)--> GPIO2 (pin 3)
    -LED+ --> GPIO14 (pin 😎 avec résistance 330 ohm
    -Power- (Fil rouge), Reset- (Fil orange), LED-(fil blanc) --> GND (pin 6).

    Bref je ne sais plus ou chercher...

    Ps: touts les câblages sont dissocier de la carte nes d'origine, pour cela j'ai utiliser des broches de 40 pins ( à droite sur la photo )

    0_1494841354523_upload-ed751be6-4aa6-4943-a71c-0ab4271c8f59



  • Salut,

    pour l'avoir effectué une fois, il me semble qu'il faut soit inverser la polarité de LED soit couper une piste sur le PCB d'origine de la NES.


  • Themer

    Effectivement, j'ai loupé cette information, pas faute de l'avoir lu plusieurs fois pourtant.
    J'ai opter pour l'ajout d'une led indépendante du pcb d'origine , et du coup tout fonctionne.

    Merci!



Want to support us ?

371
Online

80.4k
Users

21.6k
Topics

157.8k
Posts