Problema sonido dentro de las roms



  • Buenas, os comento mi problema a ver si vosotros podeis echarme una mano.

    Tengo una raspberry pi3, con recalbox 4.0.1 instalada, utilizo un adaptador HDMI a VGA, cuando termino de instalar todo, tanto imagen con la resolución que mas se adapta a mi monitor de 19", ajusto la salida de audio minijack y desactivo las comillas de config.txt, dejándolo asi:

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    disable_overscan=1

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1
    #hdmi_mode=1

    comment to get jack audio

    hdmi_drive=2

    config_hdmi_boost=0

    force hdmi while the tv can take time before sending the signal on the hdmi output

    hdmi_force_hotplug=1

    uncomment for composite PAL

    #sdtv_mode=2

    uncomment for lirc-rpi

    #dtoverlay=lirc-rpi

    if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it

    boot_delay=3

    uncomment if you don't want the rainbow at startup

    disable_splash=1

    Overclock

    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512

    avoid_safe_mode=1

    kernel=zImage

    NOOBS Auto-generated Settings:

    hdmi_force_hotplug=1

    Pues bien, cuando me muevo por el menú de emulationstation, el sonido va perfectamente, el problema llega cuando abro un juego no funciona, no se oye absolutamente nada, podrias echarme una mano al respecto?????

    Un saludo.



  • This post is deleted!


  • @camelorro
    En la Documentación de raspberry:

    Here the output is being set to 2, which is HDMI. Setting the output to 1 switches to analogue (headphone jack). The default setting is 0 which is automatic.

    en tu config.txt:

    # comment to get jack audio
    hdmi_drive=2.

    hdmi_drive=2 es sonido por HDMI, 1 por jack y 0 auto, déjalo en valor 0 para que pueda cambiar solo de HDMI a jack o comenta con una # almohadilla esa linea como te indica el comentario que hay en config.txt en la linea anterior. Si en auto a 0 no te funcionase siempre puedes forzarlo a 1 audio solo por jack.



Want to support us ?

301
Online

80.5k
Users

21.7k
Topics

158.4k
Posts