Recalboy: remote control and Demo Mode for Recalbox!



  • @neb Rhâââ encore ce fichu composer, il a bien pris la version du Github, mais visiblement il l'a pas déplacé (mais pourquoiiiiiiiii), du coup les 2 commandes d'install sont pas passées (d'où l'erreur 500).

    Bon je vais passer sur un truc bullet proof, vraiment désolé pour ces erreurs. Je tiens au courant quand j'aurais trouvé autre chose, je fais ça au plus vite !



  • @kjbstar

    Prend ton temps, y'a pas de souci, je ne suis pas pressé perso, et puis je suis out pour ce soir, j'ai un truc à regarder avec madame ^^
    On progresse, doucement mais sûrement.
    Et ne t'excuse pas hein, le principal c'est qu'on finisse par y arriver ;-)



  • Salut @neeeeb

    J'ai fini par finalement créer une VM toute propre, à télécharger ici :

    https://www.dropbox.com/s/faba7eeev7cpwxj/Recalboy.ova?dl=1

    Dans VirtualBox : Fichier > Importer un appareil virtuel.
    Tu valides tout, tu démarres
    , il va râler que la carte réseau est pas la même, tu cliques sur changer les réglages réseaux, ca ouvre une fenêtre, c'est déjà ta carte réseau donc rien à changer, tu valides, et 20 secondes plus tard tu tombes sur un écran qui t'indique ton adresse IP, et ça marche :)

    alt text

    Il te restera à ouvrir dans ton navigateur, aller dans les paramètres (roue crantée) pour aller mettre l'IP de ta Recalbox et activer les network commands.

    Et voilou !

    Je mettrais à jour le wiki dans le weekend :)



  • @kjbstar

    Cool !! j'essaierai ça demain si j'ai un peu de temps !!



  • @kjbstar
    Bon j'ai eu le temps de tester.
    Alors je sais pas si je suis maudit ou quoi mais j'ai eu du mal...
    Pas avec l'install, tout ça s'est bien passé, encore heureux avec ton pack prémaché ^^
    Non c'est juste au moment où ça donne l'adresse IP, ça me la donnait en IPV6 et chrome voulait rien savoir avec...
    J'ai du redémarrer la machine 3 fois avant de voir une IPV4.
    J'ai tout paramétré et j'ai trouvé le bouton pour entrer en mode démo (pas simple quand y'a rien d'écrit).
    Le seul souci c'est qu'au bout de 2 jeux qui passent en démo, bah j'ai écran noir sur ma borne...
    Et toujours au bout de 2 jeux (j'ai essayé plusieurs fois).
    Peut être du au fait que la VM passe en veille ? (écran noir aussi)

    Dommage parce que c'est canon le démo mode !!
    Merci encore en tout cas.



  • @neeeeb Pour l'IP, figure-toi que j'ai eu le même souci que toi y'a une heure (enfin presque : moi c'était vide !), et je suis justement en train d'uploader une VM mise à jour (je sais pas si ça jouera sur l'IPV6 par contre, jamais eu ça).

    Comme c'est en ADSL, c'était un peu long... Le lien est désormais dans le Wiki, tout juste à jour.
    (je ne vais pas garder le fichier sur Dropbox, maintenant c'est sur Drive)

    Pour l'écran noir, c'est un bug connu ^^'
    https://github.com/kjbstar/recalboy/wiki/Known-limitations-&-bugs
    Je le comprend pas encore, et j'ai pas encore eu le temps de revenir dessus (je me focus sur la construction de ma borne en ce moment). C'est pas lié à la VM, ça rentre pas vraiment en veille et peut tourner des jours et des jours sans qu'on y touche.
    D'ailleurs je l'avais différemment ce bug : une fois sorti de la Démo, je pouvais lancer un jeu manuellement 1 fois, pas plus. Et je restais souvent sur un seul jeu en démo (pour test des touches : tu peux prendre le contrôle d'un jeu et ainsi annuler le mode démo en appuyant sur un bouton d'action).
    Faudra que je replonge dedans !

    En tout cas avec la VM, maintenant plus d'excuse pour tester/feedbacker pour personne :D



  • @kjbstar

    Ok, je referai des tests avec la nouvelle VM et peut être en augmentant un peu demo_duration (j'avais mis à 60sec).
    Je te tiendrai au courant.



  • @neeeeb Logiquement tu n'auras pas de vrai besoin de prendre la nouvelle VM, généralement les routeurs se débrouillent pour conserver la même attribution d'IP, et son affichage à l'allumage est le seul changement. Et au pire, dans la VM tu tapes "hostname -I" (grand i).



  • @kjbstar

    J'ai complètement oublié de te faire un retour.
    J'a quand même pris la nouvelle VM pour ne pas être coincé avec cette histoire d'IP.
    C'est beaucoup mieux, ça s'est affiché du premier coup (je sais que ça garde la même IP, je voulais juste vérifier ahah).
    Je kiffe le mode démo, dommage que ça freeze sur un black screen au bout d'un moment.
    Merci en tout cas, ça fait son petit effet lol



  • Et moi j'ai oublié de me repencher dessus lol.
    Merci c'est cool pour l'ip !



Want to support us ?

Join us on :

230
Online

40534
Users

16949
Topics

127569
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.