Recalbox 7.0

(Résolu)Probleme wifi avec Belkin surf n300



  • Bonjour à tous, passionné de retrogamibg depuis plusieurs années, je viens de passer après trois bornes d arcade pc au raspberry, et viens de découvrir recalbox qui m a bluffé. Je suis en trains de fabriquer un bartop pour mon fils, et bute actuellement sur la connection en wifi chez moi. J ai regardé sur le wifi de github afin d être sur de pouvoir trouver une clé usb compatible. Me voila donc de retour du taff ce matin avec une belkin surf n300 version f7d2102az toute neuve, je branche, et....... Rien J essaie de me connecter avec les paramètres reseau dans mon recalbox, mais rien, enfin si, j ai erreur de configuration wifi. Bref, où est ce que je pêche? Y a t il une installation de la cle a faire? Je précise que je fais mes debut en rasp, et que je suis un peu noobs du coup.pour info, version de recalbox 3.2.11. Merci d avance a tous



  • Salut et bienvenue! As tu essayé de configurer ton wifi via le fichier recalbox.conf? Ce dernier est partagé sur ton réseau local comme tes roms, bios, sauvegardes.



  • Salut, je t avouerais que je n ai pas essayé de passer par recalbox.conf, je tenais avant à savoir si je n avais pas de manipulation particulière a faire avec ma clé, mais apres avoir un peu parcouru le forum et le wiki, il me semble bien que rien n est a faire. Bref, aujourd'hui je suis coincé au taff jusqu a tard ce soir, mais je ferais des essais demain. Merci pour l info en tout cas.....



  • Bonsoir à tous, en ce délicieux soir un peu frais d'avril, et ayant pu faire mes tests, il s'avère que tout fonctionne, avec la saisie directe des ssid et wep dans recalbox.conf. Bien joué rockaddicted, une bonne chose de faite, maintenant la suite avec l'installation des drivers gpio, j'avance petit à petit. Bonne soirée et merci pour ton aide.



  • Ha bonne nouvelle. Concernant les pilotes gpio leur activation se fait via le même fichier config que celui que tu viens d'utiliser pour le wifi. Tu as le schéma de câblage dans la notice (lien dans ma signature). Je passe ce post en résolu.



  • OK, merci, ta réponse me donne un autre début d'information sur une interrogation que j'avais en regardant le wiki de github, si j'en crois ce que j'ai lu et tes dires, les pilotes du gpio sont déjà installés, et il suffit juste d'activer les paramètres voulus dans le recalbox.conf?



  • C'est tout à fait ça. Juste à suivre le schéma de câblage et activer le tout dans recalbox.conf. Notre retroboy national a tout inclus dans la box.



  • C'est vraiment un truc de fou cette distrib, c'est tout prêt..... Donc je viens de me mettre sur la ligne de commande, j'ai juste une interrogation sur les valeurs de enable_mk_gpio et mk_gpio_args. Je vais utiliser la version de cablage a 2 joysticks, donc je suppose que ça me donnera 1 sur enable_mk_gpio et 2 sur mk_gpio_args..... Ou me trompe-je? (quelle belle conjugaison alakon, je suis fier) Et ça donnerai ça : ## GPIO Controllers ## enable controllers on GPIO (mk_arcard_joystick_rpi) enable_mk_gpio=1 ## mk_gpio arguments (map=1 for only one gpio controller) mk_gpio_args=map=2



  • Ouh là, je viens de chercher un peu plus, je pense que ma ligne de commande ne sera pas bonne.



  • Alors je n'ai pas encore eu la chance de pouvoir tester personnellement les gpio. Mais il me semble que pour 2 sticks c'est mk_gpio_args=map=1,2



  • Oui, je reviens de glaner sur le fofo, et j'en suis arrivé aussi à cette affirmation. Bon, encore du taff ce week end, mon panel est prêt, j'attends juste un PI Cobbler qui est dans les mains de GLS (sic), et samedi je fini le cablage propre de mes boutons, et les premiers tests. Bonne soirée


  • Tester

    Je confirme que les arguments à utiliser pour un câblage à 2 joysticks c'est : enable_mk_gpio=1 mk_gpio_args=map=1,2



  • Bon......... De plus en plus étrange. GPIO câblé ce week end, et essai hier soir, avec la ligne de commande correspondant au gpio activée dans recalbox.conf. Au moment de configurer les manettes, les player 1 et deux apparaissent, mais lors de la manipulation de certains boutons ou direction, le pi redémarre, comme si il y avait un appui sur un bouton reset. J'avoue que je suis un peu septique sur ce qu'il se passe là, quelqu’un aurait une idée ou un truc que j'airais loupé? Cela me fait de tête avec les directions haut et bas du player 1, ainsi qu'avec le select . plus un ou deux boutons du player 2.


  • Global moderator
    Team

    Bonjour un problème similaire avait été évoqué il me semble dû au fait que la masse n'etait pas relié sur les gpio. as tu vérifié ton câblage ?



  • Testé hier soir avant branchement sur le pi (j utilise un t cobbler plus). Je n ai pas vérifié toutes les masses par contre. Je pars bosser et rentre demain après midi, je ferais les tests à ce moment la, je vous tiens au courant dès que j ai vérifié.



  • Alors juste une ou deux précisions. Avant de partir au taff, j ai débranché le cobbler et fait des tests pin par pin, enfin quelques uns, j allais partir. Il s avére que des choses bizarres se passent..... J ai uniquement fait mes tests avec le haut du player 1. Masse du pin 39 avec gpio 4(pin7), je redémarre. Masse 6 et 9 avec gpio 4, rien ne se passe. Masse 25 et gpio 4 me donne un appui select..... Pourtant sur le wiki de github il est précisé que les masses sont pourtant équipotentielles entre elles, bref je dois avouer que je patauge un peu quand même..... Je ne sais pas quoi penser de tout ça. Des idées?



  • Bon du coup stoppez tout je crois avoir trouvé, à vérifier demain, mais je viens de regarder la table de placement des pin du gpio sur une image, et j ai inversé le sens d affectation des pins, en gros pour moi le haut du rasp est vers les usb, mais c est en fait l inverse. Du coup le contact masse gpio 4 doit en fait etre un contact 5v avec masse, donc court jus, ce qui occasionne surement un redémarrage par sécurité pour ne pas flinguer la carte. Je vais refaire des essais demain, bon dimanche a tout les gens en week end, courage pour le taff au autres..... P.s. A force de vous parler de ce bartop, je vais vous faire deux ou trois tofs et le présenter dans la rubrique adéquate, ciao a tous.....



  • Bonjour a tous, voila ca marche. C etait bien une inversion complète du gpio, heureusement je n'ai rien cramé sur le pi(espèce d âne baté t aurais eu l air malin). Donc du coup tout fonctionne, royal.... Et une petite tof dans ma bagnole pour illustrer......


  • Global moderator
    Team

    Bonne nouvelle ! 🙂 Content que tu ai trouvé ce qui clochait ^^. Bonne fin de journée et merci pour ton retour. Hate de voir d'autres photos 😉



  • Bonjour à tous, quelques news, le bartop est en place, mon fils se régale, j'ai attaqué deux autres projets à base de rasp, un sur un x arcade dual que j'ai racheté une bouchée de pain sur lbc, avec tout intégré dedans, l'autre sur base d'une playstation vidée et reremplie avec une framboise, en bluetooth, avec deux arcade stick sur la base d'electronique de sixaxis.   Du coup voici des photos en vrac.



Want to support us ?

185
Online

79.1k
Users

20.3k
Topics

149.1k
Posts