Recalbox 7.0

Problème commandes SUDO



  • bonjour a tous ! déjà merci pour cet belle distrib , sa marche vraiment bien ! avec un camarade on doit réaliser un projet pour notre BTS , on a choisit une borne d'arcade a base de rasp pi et de recalbox . on a pas mal avancer vite mais on c'est retrouver bloquer (surement pour un truc débile en plus ...) on a stoppé a l'installation des packages pour le fonctionnement des GPIO . je m'explique : téléchargement avec la commande -wget on a réussi , ouvrir le dossier aucun soucis , mais c'est a l’exécution du script .SH que sa bloque . quand je commence la commande par SUDO (comme normalement)il me dit qu'il connais pas. quand j ne met pas le SUDO il me dit que j'ai pas la permission . j'ai essayer de lancer SU et pleins d'autres choses mais rien ne bouge . on maîtrise un peut linux mais surtout RASPBIAN , et la a priori ce n'est pas bien pareil . un ptit coup de main de quelqu'un qui passe nous aiderais beaucoup 🙂



  • sudo n'est pas installé sur recalbox si vous vous connectez en root sur recalbox, pas besoin de sudo pour exécuter des commandes normalement. un chmod pour rendre le script executable?



  • un chmod pour rendre le script executable?

    Oui j'avais pensé à ça aussi

    chmod +x script.sh
    ./script.sh
    

    Si cela ne fonctionne pas pouvez vous nous envoyer les erreurs ?



  • Attention recalbox est compilée avec buildroot, elle ne permet pas l'installation de package via apt-get comme une debian classique. Pour plus d'informations : ici et



  • cela ne fonctionne pas , la premiere commande tous passe bien , la deuxième il me dit ENABLE TO INSTALL REQUIRED DEPENCIES et me dit qu'il a un sudo et en gros qu'il le comprend pas .



  • Si tu veux pouvoir installer des packages et remanier l'OS il faudrait peu être te tourner vers un retropie qui lui est basé sur une version de rapsbian. Après j'ai également vu que tu parlais de GPIO, sache que recalbox intègre déjà un support des GPIO en natif.



  • cela ne fonctionne pas , la premiere commande tous passe bien , la deuxième il me dit ENABLE TO INSTALL REQUIRED DEPENCIES

    Donc effectivement ton script n'était pas exécutable. Mais je n'ai pas tout saisi en fait tu essayes d'installer le package sur la recalbox ou la raspbian ? Si c'est la recalbox tu vas devoir suivre le premier lien de rockaddicted. Sur Raspbian il te faut installer les dépendances du package que tu veux installer.



  • oui on a remarquer il y'a 5 minutes apres avoir fini les connexions et suivi la config gpio native , on a juste une seul position qui marche , (un joystick 4 contact et deux boutons ) et on a un seul contact du joystick qui marche alors que les shéma sonts bon !



  • as tu activé les pilotes GPIO via le fichier recalbox.conf ?


Log in to reply
 

Want to support us ?

183
Online

79.1k
Users

20.3k
Topics

149.0k
Posts