Recalbox 7.0

[Resolu]Raspberry Pi3, Wifi clé WPA très longue



  • Bonjour à tous. Déjà merci pour votre distribution, c'est une solution vraiment incroyable que vous nous avez faite 🙂 Mon réseau Wifi est en WPA2 avec une clé wifi très longue et très complexe :

    • Majuscules/Minuscules
    • Chiffres
    • Les caractères spéciaux suivants : $, &, !, et -
    • Elle fait 64 caractères de long

    J'ai installé Recalbox sur un raspberry pi 3 , puis j'ai tenté de rentrer la clé WPA2 à la main, sans succès. Je me suis donc connecté en ethernet (au "cul" de la box) pour tester à la main la configuration du wifi. Si j'utilise le script recalbox-config.sh avec des doubles guillemets (") cernant le clé WPA2, j'ai le message d'erreur suivant :

    ./recalbox-config.sh wifi enable Pierre_Claire "xxx&!7xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" ./recalbox-config.sh wifi enable Pierre_Claire "xxx&killall wpa_supplicantxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" killall: wpa_supplicant: no process killed ifdown: interface wlan0 not configured Failed to connect to non-global ctrl_ifname: wlan0  error: No such file or directory Successfully initialized wpa_supplicant Line 5: Invalid passphrase length 82 (expected: 8..63) 'xxx&killall wpa_supplicantxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"'. Line 5: failed to parse psk '"xxx&killall wpa_supplicantxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"'. Line 6: failed to parse network block. Failed to read or parse configuration '/var/lib/wpa_supplicant.conf'. Successfully initialized wpa_supplicant Line 5: Invalid passphrase length 82 (expected: 8..63) 'xxx&killall wpa_supplicantxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"'. Line 5: failed to parse psk '"xxx&killall wpa_supplicantxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"'. Line 6: failed to parse network block. Failed to read or parse configuration '/var/lib/wpa_supplicant.conf'. Failed to connect to non-global ctrl_ifname: wlan0  error: No such file or directory Failed to connect to non-global ctrl_ifname: wlan0  error: No such file or directory ^C

    J'ai volontairement laissé le point d'exclamation et l’esperluette qui se trouvent dans ma clé WPA. Étant un raccourci en bash, on peut voir que le point d'exclamation est remplacé par killall wpa_supplicant et que la configuration ne fonctionne pas du tout. Si maintenant je fait la même commande avec des simples cotes, cela fonctionne parfaitement et le wifi est en marche :

    ./recalbox-config.sh wifi enable Pierre_Claire 'xxx&!xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx' killall: wpa_supplicant: no process killed ifdown: interface wlan0 not configured Failed to connect to non-global ctrl_ifname: wlan0  error: No such file or directory Successfully initialized wpa_supplicant wlan0: Trying to associate with SSID 'Pierre_Claire' wlan0: Associated with 5c:33:8e:df:da:e7 wlan0: WPA: Key negotiation completed with 5c:33:8e:df:da:e7 [PTK=CCMP GTK=CCMP] wlan0: CTRL-EVENT-CONNECTED - Connection to 5c:33:8e:df:da:e7 completed [id=0 id_str=]

    Mon fichier /var/lib/wpa_supplicant.conf est alors correctement renseigné. Quant à mon fichier recalbox.conf, la clé WPA2 est bien renseignée, mais entourée de double guillemets. Si maintenant je reboot Recalbox, je n'ai plus de wifi, et le fichier /var/lib/wpa_supplicant.conf contient un clé WPA2 "en double"

    psk=""xxxpsk=""!7xxxxxpsk=""xxxxxsk=""xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxi"

    J'ai bien tenté de remplacer les doubles guillemets par des simples cotes dans le fichier recalbox.conf, mais sans succès. Est-ce un problème lié à l'association des doubles guillemets et du point d'exclamation? En vous remerciant d'avance. Pierre



  • Et remplacer ton simplement ta clé WPA par une moins ... casse couille... N'est pas envisageable ?



  • Mouais, j'ai déjà tous mes équipements et mes PC avec cette clé, et cela ne m'a jamais posé de problème. Et puis, imaginons quelqu'un qui utilise comme clé WPA "recalboxrocks!" Il risque d'être lui aussi confronté au problème. Je vais quand même scruter un peu le script de configuration pour voir. Et aussi voir si on ne peut pas "échapper" les caractères.



  • Autre expérience, depuis le bash de mon PC :

    [pierre ~] $ echo "ddffre,porfe!efzfezfezf" bash: !efzfezfezf: event not found [pierre ~] $ psk="ddffre,porfe!efzfezfezf" bash: !efzfezfezf: event not found [pierre ~] $ echo $psk [pierre ~] $ psk='ddffre,porfe!efzfezfezf' [pierre ~] $ echo $psk ddffre,porfe!efzfezfezf [pierre ~] $

    Or dans le fichier recalbox-config.sh, ligne 324, la variable psk reçoit le 4em argument avec des doubles guillemets,  je vais quand même tester de bidouiller ça.



  • J'ai trouvé la solution : j'ai échappé tous les caractères qui pouvaient poser problème. Et je n'ai mis aucun guillemet sur le SSID et sur la clé WPA. Là sa fonctionne 🙂


Log in to reply
 

Want to support us ?

133
Online

79.1k
Users

20.4k
Topics

149.2k
Posts