System SEGA MODEL3 : une galère à démarer



  • Bonjour,

    Je recherche quelqu'un qui a réussi à exécuter ce "nouveau" système?

    Je ne pense pas qu'il y ait beaucoup de monde, parce que pourquoi avoir mis un romset 0.219 aussi rare... personne ne l'a.
    Une fois que nous parvenons à trouver ce célèbre romset, comment extraire uniquement les jeux Model3 de ce dernier pour les mettre dans le dossier \share\roms\model3\ ?

    Je trouve très compliqué de jouer sur ce nouveau système, svp aidez-moi.


  • Staff
    Global moderator
    Team

    @Denys06
    Parce que l'émulateur fonctionne avec ce romset qui est bien disponible.
    Maintenant si tu as un romset plus récent
    Tu sors les model 3 du romset.
    Et tu mets à niveau avec clrmamepro.
    Et avant tester avec des romsets récent.
    Rends sur discord dans le vocal chan pr avoir des explications sur clrmamepro
    L arcade pas facile ça se mérite.



  • Bonjour Denys06, Il faut extraire les jeux Model3 depuis un romset MAME minimum 0.220. Pourquoi? paracerque nous avons testé les sets depuis cette version. Ensuite grâce à clrmamepro et un DAT mame 0.220 Tu peux créer ton propre DAT Model 3. Tu charges le DAT dans clrmamepro, ensuite tu vas dans scanner. Dans la page scan results tu clique sur "set information". Capture.png
    Ensuite Capture_2.png Dans cette nouvelle fenêtre tu rentres cette valeur dans "select sets": %s=model3.cpp
    Ensuite tu cliques sur "Apply" et après "Export..."
    Tu as créé un DAT model 3 que tu peux charger pour faire ensuite le "rebuild" afin d'extraire les jeux. Tu glisses tout ça dans ton dossier model3 de recalbox et voilou.



  • Je n'ai pas plus de chance que @Denys06. Impossible de démarrer la moindre rom. J'ai essayé les romset 0.219 , 0.220 et 0.224. Pas un jeu ne se lance (7 ou 8 roms différentes).

    Recalbox x86_64
    q9650 + radeon4850


  • Staff
    Global moderator
    Team

    @Scorpio70
    romset vérifié en ordre avec clrmamepro ?
    dire que ça marche pas, facile, trouver une solution à partir d'information complète c est mieux.

    j'ai toutes les roms fonctionnelles sur model 3 sur un NUC i7 7eme generation.
    Mes roms sont vérifiés et validés par clrmamepro



  • @acris ben j'ai essayé avec toutes les romset existantes...c'est déjà pas mal comme test non ? 🙂
    je suis en train d'essayer avec les 0.221/0.222/0.223
    c'est les roms originales des romsets...je vais essayer clr après pour voir



  • je pense qu'il vaut revalider tes romset avec le logiciel qu'ils indiquent.
    Je vais le faire dès que j'ai le temps mais normalement un romset devrait être fonctionnel dès qu'on le dézip... (puisque censé être à la bonne version).

    Vraiment trop compliqué cette arcade ça serait bien de simplifier tout ça car je suis sûr que même les membres de la team recalbox galère aussi dessus parfois 😈


  • Staff
    Global moderator
    Team

    @Scorpio70
    j'avais pas vu que tu avais une carte graphique radeon,
    arrives tu à faire tourner les roms atomiswares ? gamecube avec ton pc ?

    on a testé sur nvidia, et intel gpu, je ne suis pas sûr que ta radeon soit supporté par l'émulateur.

    On en peut pas simplifier on ne fournit pas de roms, C'est à l utilisateur de faire un effort de compréhension



  • @acris pour les gamecube ça fonctionne. Atomisware, je vais récupérer une rom je te dis ça asap



  • @acris Atomiswave fonctionne. Par contre impossible de démarrer une rom de model 3 malgré clrmamepro. certainement un soucis avec les radeon.



  • J'ai suivi le tuto de @bega48000 à la lettre et je me retrouve avec 24 roms précis pour SEGA MODEL3.

    J'ai les bon roms (en provenance de "MAME 0.219 ROMs merged").
    J'utilise le set 0.219 car c'est ce qui est indiqué dans le fichier .txt

    Et bien aucuns jeux ne ce lance. Le système refuse le lancement des jeux très rapidement. J'ai essayé avec d'autres jeux en provenance d'autres romset inconnu et rien ne ce lance.

    Sur la quantité de roms testés il y à peut de chance que rien ne soit compatibles, je pense qu'il y à un problème de configuration dans recalbox ou compatibilité avec l’émulateur. Je suis sous PC X86

    Dans l'attente de vous lire, merci d'avance



  • @Denys06 Hello

    D'après la documentation : https://recalbox.gitbook.io/documentation/hardware-compatibility/emulators-compatibility, cela ne fonctionne qu'avec un PC avec une architecture 64 bits (x86_64) et pas 32 bits



  • Excusez-moi je me suis trompé : je suis bien sous x86_64



  • Salut les amis. J'ai moi aussi aucune rom qui démarre sur pc x64 mais avec carte nvidia ( voir config dans signature). C'est un romset qui fonctionne sous windows et ok sous clearmamepro... j'ai entendu dire hier soir @Bkg2k que ça pouvait arriver car il n'a pas été testé sur beaucoup de configs...



  • Bonsoir à tous,

    L'émulateur est très sensible. Avez-vous bien paramétré vos manettes?(réglages manettes) C'est un peu compliqué en effet car nous n'avons pas toutes vos machines en stock à la maison😊
    J'espère pouvoir vous en dire plus dans quelques jours.



  • D'accord,
    Chez moi tout est bien paramétrais et tout tourne niquel sur les autres systèmes (Neogeo, Atomi, PSX, Dreamcast, etc.
    Je pense qu'une petite maj devra être réaliser pour système, en espérant que se topic puisse y bénéficier.



  • @bega48000 ça peut venir du paramétrage des manettes effectivement. mon es_launch_stderr.log ci-dessous si ça peut aider :

    Traceback (most recent call last):
    File "usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", line 450, in <module>
    exitcode, waitNeeded = main(args)
    File "usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", line 352, in main
    command = getGenerator(system.config['emulator']).generate(system, playersControllers, recalboxSettings, arguments)
    File "/usr/lib/python2.7/site-packages/configgen/generators/supermodel/supermodelGenerator.py", line 248, in generate
    supermodelControllers.generateControllerConfig(self, Generator, playersControllers, system)
    File "/usr/lib/python2.7/site-packages/configgen/generators/supermodel/supermodelControllers.py", line 402, in generateControllerConfig
    supermodelControllersSettings.setOption(self.SECTION_GLOBAL, x, '"{}{}+{}{}"'.format(padIndex, getConfigValue(pad.inputs["hotkey"]), padIndex, getConfigValue(input)))
    File "/usr/lib/python2.7/site-packages/configgen/generators/supermodel/supermodelControllers.py", line 281, in getConfigValue
    return '{}'.format(SUPERMODEL_JOY[DIGITAL_JOYSTICK_P1[x]])
    KeyError: 'InputUIChangeSlot'


  • Spanish moderator
    Local Moderator

    J'ai la même erreur.

    Traceback (most recent call last):
    File "usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", line 450, in <module>
    exitcode, waitNeeded = main(args)
    File "usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", line 352, in main
    command = getGenerator(system.config['emulator']).generate(system, playersControllers, recalboxSettings, arguments)
    File "/usr/lib/python2.7/site-packages/configgen/generators/supermodel/supermodelGenerator.py", line 248, in generate
    supermodelControllers.generateControllerConfig(self, Generator, playersControllers, system)
    File "/usr/lib/python2.7/site-packages/configgen/generators/supermodel/supermodelControllers.py", line 402, in generateControllerConfig
    supermodelControllersSettings.setOption(self.SECTION_GLOBAL, x, '"{}{}+{}{}"'.format(padIndex, getConfigValue(pad.inputs["hotkey"]), padIndex, getConfigValue(input)))
    File "/usr/lib/python2.7/site-packages/configgen/generators/supermodel/supermodelControllers.py", line 281, in getConfigValue
    return '{}'.format(SUPERMODEL_JOY[DIGITAL_JOYSTICK_P1[x]])
    KeyError: 'InputUIChangeSlot'


  • Staff
    Global moderator
    Team

    @Denys06 @Scorpio70 @ProfMielPops @Beho @toniosj

    ya eu des fix pour model 3
    passez en version 7.1.1
    https://gitlab.com/recalbox/recalbox/-/blob/master/RELEASE-NOTES.md

    en attendant vos retours et un détail sur vos configurations PC X64

    ASSUREZ VOUS , d'avoir reconfiguer votre manette dans le menu emulationstation > options manettes.


  • Spanish moderator
    Local Moderator

    @acris J'ai reconfiguré les commandes à nouveau et le même problème persiste. Lors de l'exécution du jeu, il revient au menu en disant que les roms / bios sont manquants.

    Mon PC est un i5 avec Nvidia GTX970.



Want to support us ?

313
Online

81.4k
Users

22.2k
Topics

161.3k
Posts