7.0.1 Toujours problème avec Nespi4case ventilateur ne s'éteint pas



  • Bonjour,

    J'ai toujours le même problème avec la nouvelle mise à jour 7.0.1
    J'éteins le Nespi4case avec le bouton on/off du boitier et le ventilateur continue de tourner une fois le boitier éteint.Obligé de débrancher l'alim pour le stopper.

    Avez vous une solution s'il vous plait?Faut il faire la même manip que sur le superpi case en enlevant le ;?

    Merci pour tout votre travail.



  • Bonsoir,
    Je confirme la même chose chez moi. Si je lance l'extinction dans le menu ES et qu'ensuite j'appuie sur le power le ventilateur s'éteint mais si j'appui directement sur power il continue de tourner.
    Merci encore pour votre boulot. Ma femme va être particulièrement heureuse de retrouver la télécommande pour commander kodi👍



  • La même ici! 🙂


  • Global moderator
    Team

    Bonjour @Stefs @cdtpepette @Spidey
    l information est remonté.



  • Merci du retour.



  • Bonjour à tous,

    Oui même chose dans mon cas.



  • @cdtpepette idem pour la mienne 😉👍👌


  • Global moderator
    Team

    vous avez décommenté la ligne du safeshutdown dans recalbox.conf ?
    @max7730



  • @acris said in 7.0.1 Toujours problème avec Nespi4case ventilateur ne s'éteint pas:

    vous avez décommenté la ligne du safeshutdown dans recalbox.conf ?
    @max7730

    Faut il décommenter la ligne du safeshutdown dans recalbox.conf pour que le ventilateur se coupe après extinction du boitier?



  • Pour ce qui me concerne, j'ai cru aussi que le ventilateur ne s'éteignait pas, mais j'ai l'impression qu'il tourne environ 30 secondes avant de s'arrêter. Avez-vous essayé d'attendre un peu ?



  • J'ai testé la mise à jour vers RB7.0.1.
    Je confirme : le ventilateur ne se coupe toujours pas, même après avoir attendu 2min...

    J'ai vérifié le fichier recalbox.conf
    Sur RB7.0.0, il était comme ça par défaut :

    # ------------ A - System Options ----------- #
    #    Uncomment the system.power.switch you use
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    ;system.power.switch=MAUSBERRY           # http://mausberry-circuits.myshopify.com/pages/setup
    ;system.power.switch=REMOTEPIBOARD_2003  # http://www.msldigital.com/pages/support-for-remotepi-board-2013
    ;system.power.switch=REMOTEPIBOARD_2005  # http://www.msldigital.com/pages/support-for-remotepi-board-plus-2015
    ;system.power.switch=WITTYPI             # http://www.uugear.com/witty-pi-realtime-clock-power-management-for-raspberry-pi
    ;system.power.switch=PIN56ONOFF          # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    ;system.power.switch=PIN56PUSH           # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    ;system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    ;system.power.switch=PIN356PUSHRESET     # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    

    Donc détecté automatiquement, même si en double en commentaire

    Sur RB7.0.1, il est comme ça :

    # ------------ A - System Options ----------- #
    #    Uncomment the system.power.switch you use
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    

    Je crois que ça va, le system a bien détecté que j'avais un Nespi4case ! 😂 😂

    J'ai viré au cas où les 8 lignes en trop, mais toujours pas de ventilo qui se coupe

    Tout le reste du script marche : ON/OFF, restart, led rouge une fois fini de démarrer. Mais le ventilo ne s'arrête plus jamais après le 1er démarrage



  • Merci dJ0 pour tes précisions.Je suis toujours dans le même cas sans solution.
    Le ventilateur ne s'arrête pas.



  • Franchement, la 1ère fois où j'ai vu ça, j'ai tout de suite eu la crainte d'un bug hard et d'une mauvaise conception de la part de RetroFlag
    J'espère que je me trompe et qu'ils ont mis le ventilo sur GPIO, mais je finis par avoir un doute...



  • Pareil,je n'arrive pas à comprendre.

    Si quelqu'un a une solution,merci par avance.



  • Alors j'ai moi même le boitier Nespi4case avec un RPI4.
    Tout marche parfaitement sans aucune intervention de ma part sur les fichiers de configs.
    La seule chose que j'ai changer, c'est mettre l’interrupteur "safe shutdown" dans le boitier Nespi4case sur on.

    Avez vous vérifiez la position de l interrupteur ?



  • Oui la position de l'interrupteur est bien sur ON



  • Idem, il est bien sur ON
    Ça commence à être sacrément bizarre cette histoire 🤔

    Il n'y aurait pas déjà plusieurs versions de Nespi4case ? Parce qu'entre les ventilos qui réagissent différemment, ainsi que les SSD qui parfois font déconner chez les uns et pas chez les autres...



  • idem le ventilo tourne encore



  • Bien content de trouver ce topic, je rencontre le même soucis. J'ai passé une partie de la soirée à faire des tests et voici le comportement:

    • RB 7.0.1 fresh install

    • les boutons sont reconnus de suite mais le power off est inconsistant. Sur 10 tests, l'interface se coupe à chaque fois mais le ventilateur continue de tourner environ 4x sur 10.

    • mon fichier recalbox.conf correspond au post de @dJ0

    • un ps -ef|grep - i shut montre bien le script Python qui tourne

    • les 3 scripts sont bien présent dans /opt/Retroflag

    Ce qui contourne le problème chez moi:
    installer https://github.com/crcerror/retroflag-picase ne fonctionne que partiellement, la partition étant en RO, mais le power off fonctionne alors à chaque fois. Le comportement (reset différent selon interface etc) n'est pas présent, aucun changement de la fonction des boutons.
    Afin de confirmé j'ai désinstallé via le uninstall script présent également sur la page et je retourne au comportement décrit plus haut.

    Ceci confirme qu'il n'y pas de soucis hardware/boitier me semble-t-il.


  • Global moderator
    Team

    @shamael_1 said in 7.0.1 Toujours problème avec Nespi4case ventilateur ne s'éteint pas:

    la partition étant en RO,

    faut monter la partition avant d'appliquer des changements.



Want to support us ?

213
Online

79.8k
Users

21.1k
Topics

154.9k
Posts