Consolen overlays Einfügen klappt nicht



  • Hallo liebes Forum, weil ich nicht weiter komme wende ich mich heute an euch .Nachdem ich nun die 4.1 drauf habe, wollte ich für meine vier consolen overlays einbinden,das die schwarzen Streifen an beiden Seiten weg sind.Nun dachte ich das wird schneller gehen als gedacht.Falsch gedacht,fünf Stunden habe ich gestern gewerkelt und es geht nicht. Die Anleitung vom Git habe ich befolgt doch diese wirft mehr Fragen als Antworten auf.Wie bin ich nun vorgegangen.Als erstes habe ich mir die consolenname.png,consolenname.cfg und die consolenname_overlay.cfg besorgt und diese mit Notepad bearbeitet so das sie stimmen?!Diese habe ich dann in recalbox/Share/System/config/retroarch geschoben.Dort habe ich noch den Ordner overlays angelegt.Dann habe ich die png Datei und die consolenname_overlay.cfg in den neuen Ordner getan.Die consolenname.cfg habe ich im Ordner retroarch belassen und dort den Input overlay hinzugefügt.Danach habe ich versucht im Retroarch Menü bei Settings ein overlay zu wählen aber das ist dort nicht möglich,es wird zwar was angezeigt aber gehe ich auf present overlay steht dort no item.So war die Vorgehensweise laut Git hub beschrieben aber gehen tut nix. Ich habe mir auch viele Videos darüber angeschaut aber da war jedes anders auch die retroarch Menüpunkte.Dann habe ich im retroarch den overlay Pfad gesucht und auch gefunden.recalbox/Share/System/.config/retroarch/overlay.Also habe ich nun dort meine o.g. Files dort reingeschoben was aber auch nix gebracht hat. Ich habe so viel versucht und bin mit meinem Latein am Ende und hoffe ihr könnt mir helfen. Eine Anleitung wäre toll und wenn’s geht nicht in Englisch!



  • alsi ich mache das so

    ins retroarch menu:
    settings
    onscreen Display
    Overlay

    dann das overlay mit der Option im Menü sichtbar machen, auswählen und einstellen
    zum schluß noch Save to the core oder Game



  • @marcsmily So hab ich es auch versucht aber im RetroArch nimmt es mir das Oberlandesgericht nicht an .Ich wähle es aus aber es erscheint nix,hast du zufällig ein Overlay mit den nötigen cfg Dateien als Beispiel für mich? Und wo hast du die overlays abgelegt?



  • @fluffydo Oberlandesgericht sollte overlay heißen 😜



  • schau mal auf arcadepunks



  • @marcsmily ok 👌



  • So hab jetzt mal geschaut aber hat nix gebracht.Die Anleitung vom GitHub geht definitiv nicht!Overlays zeigt es bei mir im RetroArch an aber möchte ich diese auswählen passiert nix sie wird nicht angenommen.Entweder stimmt die cfg Datei nicht oder ich oder ich muss irgendetwas vergessen haben.Noch mal zum verstehen.Ich braue zwei Dateien,die cfg.und die png. Datei oder noch eine dritte?Laut arcadepunks sind es zwei diese schiebe ich einfach in den Ordner Overlay dann in RetroArch unter dem Punkt Settings die Overlay Datei anwählen und Speichern. Alles gemacht aber die blöden Streifen bleiben.Was mache ich bloß falsch.Habs jetzt aufgegeben.Falls doch noch einer mir helfen kann einfach hier melden!!!


  • Team
    Moderator
    Translator

    @fluffydo

    Guten Abend,

    ich schaue mir das Morgen mal an und werde versuchen Hilfestellung zu geben.
    Wäre doch gelacht wenn wir das Problem nicht gelöst bekommen ;)



  • @abunille vielen Dank für die Hilfestellung mal sehen ob wir es hinbekommen?!wenn ich was zur Lösung beisteuern kann sag Bescheid 😜👍


  • Team
    Moderator
    Translator

    @fluffydo

    Guten Morgen, das kannst du in der Tat.
    Zeige mir anhand eines deiner Konsolen wie die Overlay Dateien heissen und wie der Inhalt aussieht.



  • @abunille Guten morgen, und Danke nochmal für deine Hilfe.
    Also die Dateien heißen so:
    nes.cfg , nes_overlay.cfg , nes.png

    Inhalt nes.cfg
    input_overlay = "/recalbox/share/system/.config/retroarch/overlay/nes.cfg"
    Diese Datei liegt im /recalbox/share/system/.config/retroarch

    Inhalt nes_overlay.cfg
    overlays = "1"
    overlay0_overlay = "nes.png"
    overlay0_full_screen = "true"
    overlay0_descs = "0"

    Diese Datei liegt im /recalbox/share/system/.config/retroarch/overlay und auch die nes.pnp.

    Die Frage ist ob bei den Werten dieses Zeichen (" )sein muß oder nicht.Habe es auch ohne probiert.Sieht dann so aus .
    overlays = 1
    overlay0_overlay = nes.png
    overlay0_full_screen = true
    overlay0_descs = 0

    Noch eine Frage zu retroarch was und in welcher Reihenfolge muß dort was eingestellt werden?

    Ich bin so vorgegangen.
    Hotkey+B
    -settings
    -video
    -game ratio custom
    -settings/onscreen_display/onscreen_overlay
    hide_overlay_in_menu = on auf off
    -present overlay (doch dort wird nix angenommen nur angezeigt die cfg. Datei
    -save core

    Exit Retroarch und dann neu gestartet aber geht halt nüscht.


  • Team
    Moderator
    Translator

    @fluffydo

    Gerne,
    auf die schnelle der 1. Fehler:

    Inhalt nes.cfg
    input_overlay = "/recalbox/share/system/.config/retroarch/overlay/nes.cfg"
    Diese Datei liegt im /recalbox/share/system/.config/retroarch
    

    Der Pfad im Wiki heißt:
    /recalbox/share/system/configs/retroarch/overlays/
    configs nicht .config

    Ich schau mal weiter ;)



  • was auch noch intressant ist, wo genau kommen diese Dateien hin.Im GitHub kommen sie in /recalbox/share/system/config/retroarch/overlays
    da aber findet retroarch nix.Der Ordnerpfad laut retroarch ist /recalbox/share/system/.config/retroarch/overlay .


  • Team
    Moderator
    Translator

    @fluffydo

    Wir arbeiten jetzt erstmal mit den reinen Dateien und dessen Inhalt.
    Lass Retroarch bzw. deinen TV aus den Augen.

    Schau dir das Wiki nochmal an und korrigiere die Pfade deiner Dateien und Inhalte.

    Ich habe es gerade mit einer frischen Installation getestet und keine Probleme entdeckt.



  • @abunille ok ich fahre jetzt mal meine Box hoch und schaue wie der Pfad nun bei mir wirklich heißt.



  • @abunille so alles erledigt! Und wie weiter?


  • Team
    Moderator
    Translator

    @fluffydo

    Zeige mir mal bitte die aktualisierten Daten und Inhalte.



  • @abunille
    nes_overlay.cfg
    overlays = "1"

    overlay0_overlay = "nes.png"

    overlay0_full_screen = "true"

    overlay0_descs = "0"

    nes.cfg
    input_overlay = "/recalbox/share/system/configs/retroarch/overlays/nes.cfg"


  • Team
    Moderator
    Translator

    @fluffydo said in Consolen overlays Einfügen klappt nicht:

    nes.cfg
    input_overlay = "/recalbox/share/system/configs/retroarch/overlays/nes.cfg"

    In der nes.cfg muss der Verweis auf die nes_overlay.cfg sein
    input_overlay = "/recalbox/share/system/configs/retroarch/overlays/nes_overlay.cfg"



  • @abunille So also input_overlay = "/recalbox/share/system/configs/retroarch/overlays/nes_overlay.cfg"



Want to support us ?

Join us on :

320
Online

28900
Users

14666
Topics

110821
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.