Recalbox 7.0

[Bug][Correctif en cours]Recalbox v3.3.0 beta6 - Problème avec virtual gamepad



  • Bonjour à tous,   Je me permets de faire appel a vous pour savoir si comme moi d'autres ont des soucis a faire fonctionner virtual gamepad ? Je sais qu'il est sensé fonctionner de base dans la beta 3.3.0 mais rien n'y fait, j'ai testé via plusieurs smartphone et tablettes et ça ne fonctionne pas. Je suis tout a fait capable de pinger le Rpi etc donc j'ai cherché pour voir si virtual gamepad etait bien lancé sur le Rpi et la je ne le trouve pas, donc je me suis rendu dans /usr/node-virtual-gamepads/ et j'ai tenté de lancer manuellement main.js via la commande node main.js mais la commande me retourne illegal instruction. Du coup j'ai voulu retélécharger virtual gamepads via les instruction ci dessous mais sans succes car il ne reconnais pas la commande git : git clone https://github.com/miroof/node-virtual-gamepads cd node-virtual-gamepads npm install sudo node main.js Une âme charitable serait-il m'aider ? Merci d'avance !



  • Alors en effet, je te confirme que je le service est bien lancé automatiquement via un service à chaque démarrage de la 3.3.0. Tu ne pourra pas le réinstaller à la mano car recalbox n'intégre pas npm et les divers outils de compilation. On l'intègre au système au moment de la compilation du système via buildroot. Pour connaître ton ip, tu peux te rendre dans "options réseau" dans le menu de emulationstation. Ensuite prend chrome sur ton smartphone et tapes adresse_ip_recalbox:8080 et la manette du virtual gamepads devrait apparaître. Je te link la page wiki : https://github.com/digitalLumberjack/recalbox-os/wiki/Virtual-Gamepad-(FR)



  • Bonjour,   Merci de ta réponse, mon rpi a une IP fixe 192.168.1.50 Mais lorsque dans chrome sur Android j'essaie de me connecter sur cette IP ça ne fonctionne pas, j'ai essayé avec et sans préciser le port dans l'URL mais sans succès malheureusement. Y a t il un moyen de voir via ssh si le service virtual gamepad est bien lancé ?   Merci d'avance !



  • hummm vraiment bizarre cette histoire. Tu peux essayer les commandes top ou ps, tu obtiendra la liste des services qui sont exécutés, et tu devrais trouver un node main.js dans la liste.



  • Bonjour à tous, Tout d'abord félicitation et grand bravo pour votre travail ! Je me permet d'intervenir dans cette discussion car il se trouve que j'ai le même problème.  Je viens d'essayer la commande "top" de rockaddicted. Voici ce que cela me retourne : 308   248 root     S      99m  40%  21% retroarch -L /usr/lib/libretro/prboom_libretro.so --config /recalbox/configs/retroarch/retroarchcustom.cfg /r 175     2 root     SW<      0   0%   1% [kworker/0:1H] 38     2 root     SW<      0   0%   1% [VCHIQ-0] 345   340 root     R     2384   1%   0% top 48     2 root     SW       0   0%   0% [mmcqd/0] 39     2 root     SW<      0   0%   0% [VCHIQr-0] 203     2 root     SW       0   0%   0% [kworker/0:2] 147   145 root     S    78276  31%   0% {emulationstatio} /usr/bin emulationstation 236     1 root     S    23472   9%   0% smbd -D 240   236 root     S    23472   9%   0% smbd -D 223     1 root     S    14428   6%   0% /usr/sbin/ntpd -g 241     1 root     S    14396   6%   0% nmbd -D 248   147 root     S    10468   4%   0% python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc -p1index 0 -p1guid 0300000079000000060 161     1 root     S     4328   2%   0% /usr/sixad/official/sixad-bin 0 0 0 340   339 root     S     3204   1%   0% -sh 145     1 root     S     3028   1%   0% {S31emulationsta} /bin/sh /etc/init.d/S31emulationstation start 72     1 root     S     2944   1%   0% /sbin/udevd -d 137     1 dbus     S     2544   1%   0% dbus-daemon --system 339   227 root     S     2396   1%   0% /usr/sbin/dropbear -R 244     1 root     S     2308   1%   0% /sbin/getty 38400 tty2 1     0 root     S     2304   1%   0% init 62     1 root     S     2304   1%   0% /sbin/syslogd -n 65     1 root     S     2304   1%   0% /sbin/klogd -n 212     1 root     S     2304   1%   0% udhcpc -R -n -p /var/run/udhcpc.eth0.pid -i eth0 227     1 root     S     2152   1%   0% /usr/sbin/dropbear -R 16     2 root     SW       0   0%   0% [khubd] 6     2 root     SW       0   0%   0% [kworker/u2:0] 7     2 root     SW       0   0%   0% [rcu_preempt] 3     2 root     SW       0   0%   0% [ksoftirqd/0] 2     0 root     SW       0   0%   0% [kthreadd] 4     2 root     SW       0   0%   0% [kworker/0:0] 5     2 root     SW<      0   0%   0% [kworker/0:0H] 8     2 root     SW       0   0%   0% [rcu_bh] 9     2 root     SW       0   0%   0% [rcu_sched] 10     2 root     SW<      0   0%   0% [khelper] 11     2 root     SW       0   0%   0% [kdevtmpfs] 12     2 root     SW<      0   0%   0% [writeback]   Idem avec ps, pas de trace du programme. Je précise que ma config est un "vieux" raspberry pi B. Merci



  • Voici le resultat de la commande ps sur mon rpi :   1 root     init 2 root     [kthreadd] 3 root     [ksoftirqd/0] 4 root     [kworker/0:0] 5 root     [kworker/0:0H] 6 root     [kworker/u2:0] 7 root     [rcu_preempt] 8 root     [rcu_bh] 9 root     [rcu_sched] 10 root     [khelper] 11 root     [kdevtmpfs] 12 root     [writeback] 13 root     [bioset] 14 root     [crypto] 15 root     [kblockd] 16 root     [khubd] 18 root     [cfg80211] 19 root     [rpciod] 21 root     [khungtaskd] 22 root     [kswapd0] 23 root     [fsnotify_mark] 24 root     [nfsiod] 25 root     [cifsiod] 38 root     [VCHIQ-0] 39 root     [VCHIQr-0] 40 root     [VCHIQs-0] 41 root     [dwc_otg] 42 root     [DWC Notificatio] 43 root     [kpsmoused] 45 root     [krfcommd] 46 root     [deferwq] 47 root     [kworker/u2:2] 48 root     [mmcqd/0] 49 root     [jbd2/mmcblk0p6-] 50 root     [ext4-rsv-conver] 63 root     /sbin/syslogd -n 66 root     /sbin/klogd -n 73 root     /sbin/udevd -d 138 dbus     dbus-daemon --system 146 root     {S31emulationsta} /bin/sh /etc/init.d/S31emulationstation start 148 root     {emulationstatio} /usr/bin emulationstation 151 root     [VCHIQka-0] 162 root     /usr/sixad/official/sixad-bin 0 0 0 182 root     {kodilauncher.sh} /bin/bash /recalbox/scripts/kodilauncher.sh 183 root     /usr/lib/kodi/kodi.bin --standalone -fs -n 278 root     udhcpc -R -n -p /var/run/udhcpc.eth0.pid -i eth0 289 root     /usr/sbin/ntpd -g 293 root     /usr/sbin/dropbear -R 300 root     smbd -D 309 root     smbd -D 310 root     nmbd -D 313 root     /sbin/getty 38400 tty2 8461 root     /usr/sbin/dropbear -R 8462 root     -sh 8473 root     top 9264 root     [kworker/0:1] 9846 root     /usr/sbin/dropbear -R 9872 root     -sh 9902 root     [kworker/0:2] 9986 root     ps et ici le resultat de top : 148   146 root     S    81888  32%  41% {emulationstatio} /usr/bin emulationstation 10218  9872 root     R     2384   1%  15% top 9846   293 root     S     2396   1%  10% /usr/sbin/dropbear -R 39     2 root     SW<      0   0%   5% [VCHIQr-0] 10205     2 root     SW<      0   0%   0% [kworker/0:1H] 3     2 root     SW       0   0%   0% [ksoftirqd/0] 9902     2 root     SW       0   0%   0% [kworker/0:2] 16     2 root     SW       0   0%   0% [khubd] 4     2 root     SW       0   0%   0% [kworker/0:0] 49     2 root     SW       0   0%   0% [jbd2/mmcblk0p6-] 21     2 root     SW       0   0%   0% [khungtaskd] 2     0 root     SW       0   0%   0% [kthreadd] 5     2 root     SW<      0   0%   0% [kworker/0:0H] 8     2 root     SW       0   0%   0% [rcu_bh] 9     2 root     SW       0   0%   0% [rcu_sched] 10     2 root     SW<      0   0%   0% [khelper] 11     2 root     SW       0   0%   0% [kdevtmpfs] 12     2 root     SW<      0   0%   0% [writeback] 13     2 root     SW<      0   0%   0% [bioset] 14     2 root     SW<      0   0%   0% [crypto] 15     2 root     SW<      0   0%   0% [kblockd] 18     2 root     SW<      0   0%   0% [cfg80211] 19     2 root     SW<      0   0%   0% [rpciod] 22     2 root     SW       0   0%   0% [kswapd0] 23     2 root     SW       0   0%   0% [fsnotify_mark] 24     2 root     SW<      0   0%   0% [nfsiod] 25     2 root     SW<      0   0%   0% [cifsiod] 40     2 root     SW<      0   0%   0% [VCHIQs-0] 41     2 root     SW<      0   0%   0% [dwc_otg] 42     2 root     SW<      0   0%   0% [DWC Notificatio] 43     2 root     SW<      0   0%   0% [kpsmoused] 45     2 root     SW<      0   0%   0% [krfcommd] 46     2 root     SW<      0   0%   0% [deferwq] 47     2 root     SW       0   0%   0% [kworker/u2:2] 50     2 root     SW<      0   0%   0% [ext4-rsv-conver] 151     2 root     SW       0   0%   0% [VCHIQka-0] et pas de node main.js visible Si vous voulez que je fournisse d'autres informations dites le moi.



  • Techniquement le service Virtualgamepad doit être lancé via un script classique init.d. Il doit logiquement se trouver dans /etc/init.d/xxx, xxx = le script virtualgamepad, de mémoire je crois c'est S93Virtualgamepad ou un truc du genre. /etc/init.d/xxx status pour voir si il est lancé /etc/init.d/xxx start pour le démarrer etc etc.



  • Bonsoir MikaXII Merci pour ta réponse, malheureusement, cela ne semble rien changer. J'arrive bien à lancer la commande start mais le service n'apparait toujours pas après une commande ps. Comme on a le retour "illegal instruction" en lançant directement le main.js, j'ai fait une petite recherche et je suis tombé sur ce sujet : http://raspberrypi.stackexchange.com/questions/24059/node-js-v0-11-14-exits-with-illegal-instruction Alors je sais que la version sur recalbox est la v0.12.7, mais peut être que le problème vient de là quand même ???



  • Je viens de tester le virtualgamepad sur mon pc et en effet il y a eu une nouvelle version de nodejs. Il faut voir si ça n'a pas impacter la compile de la beta 6 au niveau du package nodejs dans buildroot. Ou alors la version npm de celui qui à compilé.



  • j'ai testé sous bêta 5 et 6 et idem pas de virtual gamepad fonctionnel.



  • C'est pendant la compilation des version beta 5-6, qu'il y a eu une maj du coté de nodejs, donc on vas partir à la recherche du problème et vous tenir au courant 🙂



  • Je vous tiens au courant comme promis, le problème a été trouvé c'est un package installer via npm qui n'est plus bon. Le souci sera résolu dans la prochaine release 😄



  • magnifique !   Merci à vous et bonne continuation dans la suite du développement de recalbox !



  • Bonsoir messieurs, je ne savais pas qu'il y avait une beta 6 de dispo, qu'apporte t elle au juste par rapport à la 5 ?



  • Bonsoir à tous, Super MikaXII ! Merci à toi et toute la team encore pour votre travail et bravo pour votre réactivité ! C'est vraiment un plaisir d'utiliser RecalBox 😄



  • Hello à tous, Je viens de mettre à jour vers la bêta 7, j'ai demandé sur FB et le bug devait être corrigé mais ce n'est pas le cas. Qqun a le même problème ou suis-je le seul ?



  • Malheureusement tu es le seul^^ enfin recensé. Une personne à tester hier et tout fonctionne normalement. Cependant pour savoir pourquoi ça ne fonctionne pas chez toi il me faut plusieurs info : - As tu fais une maj ou une reinstall ? - Te connect tu bien à <iprecalbox>:8080 - Si tu démarres via un node main.js ou /etc/init.d/S92Virtualgamepad start, qu'obtiens tu comme erreurs? (si erreurs il y a) - et pour finir peux tu me donner le contenu du dossier node_module ls node_modules qui est dans le même répertoire que le main.js



  • Etrange :s Voila mon parcours : J'ai installé la version 3.3.0 beta 5 que j'ai mis a jour vers la beta 6 puis hier j'ai mis la beta 7 ; sur aucune de ces 3 versions je n'ai su faire fonctionner virtual gamepads. je me connecte bien via chrome sous android sur l'ip de mon raspberry ( ip fixe donnée par mon routeur car j'ai bindé sa MAC à une IP ) 192.168.1.50:8080 et ça me met connexion refusée, j'ai essayé en ajoutant http://devant et aussi sans le port mais sans succès ( sans le port j'accède a l'interface web de kodi ) quand je lance manuellement node main.js j'ai l'erreur illegal instruction ( quand je fais node -v il me retourne la version v0.12.7 donc je ne pense pas que ce soit node le problème ) quand je lance "/etc/init.d/S92Virtualgamepad start" il n'y a pas d'erreur mais si je fait la même commande avec "<span style="line-height: 1.5;">/etc/init.d/S92Virtualgamepad</span><span style="line-height: 1.5;"> </span><span style="line-height: 1.5;">stop" il me renvoie "you need to specify whom to kill" comme si le service ne c’était pas lancé avec la commande start</span> Je suis au boulot actuellement donc je te listerai le contenu du dossier node_module plus tard dans la soirée.   Pour donner plus d'infos: j'ai un RPi B+ overclock via ES à 950Mhz Je suis capable de pinger le rpi depuis mon smartphone via terminal, je sais aussi me connecter et ssh dessus sans soucis j'ai accès à l'interface web de KODI en rentrant l'ip du raspberry j'ai aussi accès au partage samba via mon pc et mon smartphone j'ai déjà tenté de réinstaller recalboxos 3.3.0 beta 5 en re-téléchargeant l'archive pour être sur mais même soucis.



  • Bonsoir, voici ce que j'ai dans node_modules dossier : express/ History.md    Makefile      bin/          lib/          package.json LICENSE       Readme.md     index.js      node_modules/ test.js     ioctl/ LICENSE       binding.gyp   examples/     node_modules/ src/ README.md     build/        index.js      package.json   socket.io/ History.md    Makefile      index.js      node_modules/ LICENSE       Readme.md     lib/          package.json   struct/ LICENSE       README.md     index.js      package.json  samples/   voila j'ai donc 4 dossiers et je t'ai mis le contenu des dossiers.



  • J'ai aussi fait un ls -R afin de lister le contenu de tout les dossiers et sous dossiers ainsi que des fichiers.


Log in to reply
 

Want to support us ?

203
Online

79.1k
Users

20.4k
Topics

149.2k
Posts