4.1 bluetooth pairing persistency issue?



  • @substring I guess I did start the controller the right way (keep right shoulder button pressed while pressing START), it worked perfectly with the previous version(s) of recalbox.
    I created a support archive, will send it to you via private message since it contains my retroachievement login and password :(



  • Oh second post for return previous recalbox for resolve problem bluetooth pad... :(



  • Hi,
    I´ve also got a problem, connecting my PS3 Dualshock3 SIXAXIS-Controller to Recalbox running on a raspberry pi zero w.
    Each time i boot recalbox, i can`t pair it with the controller.
    After i reset the controller, using the button on the backside, the pairing works.
    If i connect the controller via usb-cable, wait a few seconds and disconnect the controller, it works also.

    Just after a reboot the pairing won`t work.



  • Okay, I made some progress.

    After messing-up quite a bit with diverse commands, I finally managed to pair and configure one of my 8bitdo (mostly through the GUI). But for some reason, as explained in my first post, I can pair my second 8bitdo but I cannot configure it - it is not detected on the 'configure a controller' screen?

    Extra detail, possibly useful:

    My /recalbox/share/system/udev/rules.d/99-8bitdo.rules was completely clogged-up with the same entry over and over. I created the file anew, now I just have my 2 gamepad mac addresses in there.

    I'm wondering whether it's due to line 508 in /recalbox/scripts/recalbox-config.sh ?

    But in anycase, what I did not find is how pads are being detected at the configure controller screen. I don't think I did anything special, so I may have been lucky with my first controller. @substring if you have details about this script I may be able to troubleshoot it?


  • Moderator
    Moderator
    Team

    @valvolt Hi,

    Which 8bitdo pad do you have exactly ?



  • @valvolt So let me explainthat mess with 8bitdo pads ...

    https://gitlab.com/recalbox/recalbox/blob/master/board/recalbox/fsoverlay/recalbox/scripts/recalbox-config.sh#L508 is made to handle those darn pads because they are not detected as gamepads but keyboards. The UDEV rule is here to force the pad as a "real gamepad" regarding the OS.

    But I admit it's made dirtily : we don't check the .rules file to decide if we should add the pad or not. quite easy to fix, never really took time to solve that.

    In your case, you should empty the file and leave a single rule. Or just totally remove the file, reset your 8bitdo pad, forget known bt devices in ES, reboot, and pair again.

    Regarding ES : it just lists devices that have the "joystick" attribute, hence the udev rule.



  • Some more progress...

    1- Huzzah for rolling updates ! I updated the box before following the steps you proposed, @Substring.

    2- I did the following: delete 99-8bitdo,rules, update box, forget controllers, reboot.

    When pairing first device ( @OyyoDams : SFC30), I could pair and configure via the GUI. I can go through the ES menus with the pad and start games, but the pad is not recognized by the emulator (at least the SNES one says something along the lines of 'SFC30 gamepad not configured'. For the record, the emulator also says that my X-Arcade is not configured but I can use it properly so maybe this is a false lead.

    When trying to pair my second device (SNES30), I saw it in the pair list but when selecting it, it said 'unable to pair'. However, after a reboot the pad was instantly paired when switched on. I could use it to go through the menus, I could configure it via the GUI, but as for the other one, it is not recognized (at least by the SNES emulator, maybe I should test other emulators and see if it's the same there [EDIT] Same thing for other emulators (GameBoy, Genesis) [/EDIT]).

    Bottomline: the pads are paired and configured, can be used for menu navigation but not for playing games.

    Hope this helps, looking forward to any further tips. My .rules files now has 3 times the SFC pad and 2 times the SNES pad...



  • @valvolt Are you starting them with the right combo ? If they are started as a keyboard, they won't work in most emulators



  • I start them with R+Start, exactly as I did on the previous version(s) of Recalbox, and as described here: https://github.com/recalbox/recalbox-os/wiki/8bitdo-on-recalbox-(EN).

    Just to make sure, I tried to use keyboard mode (mode 2) but unsurprisingly this failed as well. I also checked that using the stick in USB mode works perfectly.

    How can I check what retroarch sees? Where does it (and other emulators) read info about configured pads? What is weird is that several emulators fail, could there be a mishap upon the saving of the pad configuration (e.g. at the end of the configuration step) ?

    For info, I just configure up, down, left, right, A B X Y L1 R1 Start Select and Hotkey (on Select), leaving all the rest empty. This worked well in Recalbox 4.0.

    Alternatively, does anyone reading this successfully use a 8bitdo on 4.1 or am I the only one so far?


  • Moderator
    Moderator
    Team

    @oyyodams said in 4.1 bluetooth pairing persistency issue?:

    @valvolt Hi,

    Which 8bitdo pad do you have exactly ?



  • @valvolt I have the FC30 arcade stick, worked flawlessly.



  • @oyyodams quoting my post above ;) I have one SNES30 (the one looking like a US pad with purple buttons) and one SFC30 (the one looking like a JP / EU pad with colored buttons). These are 'classic' pads (regular SNES pads, not the Pro version with the sticks). Same problem with both pads. They both worked well before v 4.1 when started with R+Start.

    @Substring ok, so maybe that's a specific issue ?


  • Moderator
    Moderator
    Team

    @valvolt ok sorry for my post, I didn't see your reply. About ths SFC30, there is an advanced documentation here.

    I know you've already tried many things, but could you start the whole process again ?

    1. Upgrade to the latest 8bitdo firmware
    2. In ES, forget all your BT devices
    3. Factory reset your SFC30: START for 8 seconds
    4. Power it off if necessary, then turn it on. Hit Select for 3 seconds to enter pairing mode.
    5. In ES, try to associate it again


  • @OyyoDams Wow, I think that you nailed it !
    I finally managed to get the SFC30 working after a firmware upgrade (my version was 2.67, since your URL stops at 2.62 I looked around - and found version 3.0 here: http://download.8bitdo.com/Firmware/GamePad/)

    Everything worked like a charm: I could start the pad with Start (only), pair it, configure it and use it in a game.
    I'm now doing the same with the SNES30, a priori I can use the same firmware. There is no reason this should fail.

    So THANKS A LOT to both of you, @Substring and @OyyoDams for having taken the time to help me. I hope this post will help other users as well.

    Keep up the excellent work !


  • Moderator
    Moderator
    Team

    @valvolt hey thanks for your feedback, I'm very happy for you!

    Also thanks for the firmware link... 8bitdo have really good products but poor websites and documentations :(

    Happy gaming ;)



  • Hi all. I have been reading the post because I am having the same issue with a 8bitdo gamepad, in my case the zero one.

    Recalbox recognize it but it can not be paired. I followed this wiki link:

    https://github.com/recalbox/recalbox-os/wiki/8bitdo-on-recalbox-(EN)

    and all the directions in this post, but when I select the device, I always receive the same message, it can not be paired.

    @valvolt, the link you shared with the firmware, does it work for 8bitdo zero?

    Thank you guys


  • Moderator
    Moderator
    Team

    @pmroyo Hi, all firmwares seem to be there: http://download.8bitdo.com/Firmware/

    But be carefull, not sure which one can be used with this pad.


  • Moderator
    Team
    Moderator
    Translator

    @pmroyo @OyyoDams 8bitdo zero cannot be flashed, so you can’t upgrade the firmware.

    @pmroyo Don’t forget that you need to start you gamepad with the combo “START+R”, and to reboot the pairing record of it as stated on the wiki page you linked.



  • Thank you guys, I forgot about the firmware then.

    Talking about the process, I follow these steps:
    1- Remove all paired devices in recalbox
    2- Press select in the gamepad for 8 seconds to reset it
    3- Switch it on with Start+R
    4- Press select for 3 seconds to access pairing mode
    5- Then, search for new devices in recalbox

    I have tried also without step 4 , but the result is the same, recalbox find the gamepad but it can not be paired.
    As the main gamepad, I am using a Gamesir T1S with a wifi dongle, could it be interfering into the process?



  • @pmroyo did you try with the 'manual' way ?
    https://github.com/recalbox/recalbox-os/wiki/Connect-bluetooth-controller-manually-(EN)
    What works and what does not?



Want to support us ?

Join us on :

343
Online

42544
Users

17147
Topics

128943
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.