Dualboot DVI : Raspbian OK, Recalbox pas OK du tout



  • Bonjour à tous,
    J'ai réinstallé tout mon Raspy2 cette semaine avec les dernières versions de Noobs, Debian et Recalbox.
    Quand je boote sur Debian tout fonctionne à merveille, quand je boote sur Recalbox je n'ai pas d'image mais le son fonctionne par la sortie jack. L'image apparait parfois très furtivement mais disparait aussitot, je crois voir un pavé gris avec du texte en blanc qui présente des nouveautés mais ça va trop vite pour que je puisse lire quoi que ce soit.

    J'ai essayé quelques modifs de base sur config.txt mais je ne vois rien qui cloche, surtout que le boot sur Debian marche bien.
    Est ce qu'il y a des paramètres spécifiques à Recalbox à éditer ?

    Une idée lumineuse pour régler ça ?
    Merci par avance !


  • Moderator
    Team



  • Hello MikaXII, merci pour ta réponse rapide.
    J'ai lu le wiki, c'est d'ailleurs la première chose que j'ai faite, ainsi que tous les forums anglais que j'ai pu trouver sur le Raspi et Recalbox.

    Le wiki ne donne qu'une seule manip à faire, que j'ai effectuée, mais ça ne change rien, d'autant que tout fonctionne quand je boote sur Debian. Il n'y a pas un équivalent à config.txt à éditer mais qui soit spécifique aux paramètres de Recalbox ?



  • Bon j'ai refait l'install complete, j'essaie maintenant d'editer recalbox.conf à partir de mon mac qui est sur le même réseau wifi que le Raspi, j'ai activé le SSH depuis Raspbian mais impossible de me connecter et de trouver l'accès à ce satané fichier :/



  • J'ai passé le videomode à default, toujours le même souci : l'écran fonctionne quand je boote Raspbian, et écran noir à part quelques sautillements quand je boote sur Recalbox.

    Si ça marche pour un il devrait y avoir moyen de le faire marcher pour l'autre non ?



  • @wakazai normal que ca ne marche pas. J'ai dans les cartons de simplifier ca ... Tu peux me mettre ton /boot/config.txt ?



  • Salut @Substring, merci pour ton aide !
    J'ai testé 4 écrans DVI hier :

    • Un seul fonctionnait sur Raspbian et sur Recalbox
    • Deux fonctionnaient sur Raspbian mais pas sur Recalbox
    • Le dernier ne fonctionnait ni sur Raspbian ni sur Recalbox

    Voici mon config.txt. (EDIT = par contre le formatage automatique me remplace tous les # par des lignes en gras sur le forum, j'ai remplacé par des dièse)

    ♯ For more options and information see
    http://rpf.io/configtxt
    ♯ Some settings may impact device functionality. See link above for details

    ♯ uncomment if you get no picture on HDMI for a default "safe" mode
    ♯hdmi_safe=1

    ♯ uncomment this if your display has a black border of unused pixels visible
    ♯ and your display can output without overscan
    disable_overscan=1

    ♯ uncomment the following to adjust overscan. Use positive numbers if console
    ♯ goes off screen, and negative if there is too much border
    ♯overscan_left=16
    ♯overscan_right=16
    ♯overscan_top=16
    ♯overscan_bottom=16

    ♯ uncomment to force a console size. By default it will be display's size minus
    ♯ overscan.
    ♯framebuffer_width=1280
    ♯framebuffer_height=720

    ♯ uncomment if hdmi display is not detected and composite is being output
    ♯hdmi_force_hotplug=1

    ♯ uncomment to force a specific HDMI mode (this will force VGA)
    ♯hdmi_group=1
    ♯hdmi_mode=1

    ♯ uncomment to force a HDMI mode rather than DVI. This can make audio work in
    ♯ DMT (computer monitor) modes
    ♯hdmi_drive=2

    ♯ uncomment to increase signal to HDMI, if you have interference, blanking, or
    ♯ no display
    ♯config_hdmi_boost=4

    ♯ uncomment for composite PAL
    ♯sdtv_mode=2

    ♯uncomment to overclock the arm. 700 MHz is the default.
    ♯arm_freq=800

    ♯ Uncomment some or all of these to enable the optional hardware interfaces
    ♯dtparam=i2c_arm=on
    ♯dtparam=i2s=on
    ♯dtparam=spi=on

    ♯ Uncomment this to enable the lirc-rpi module
    ♯dtoverlay=lirc-rpi

    ♯ Additional overlays and parameters are documented /boot/overlays/README

    ♯ Enable audio (loads snd_bcm2835)
    dtparam=audio=on

    ♯ NOOBS Auto-generated Settings:
    hdmi_force_hotplug=1

    Merci !



  • When you do a dual boot raspbian/recalbox with a 16Go µsd card, the free space is allocated by defaut like this : 4,1go for raspbian and 3go for recalbox.



  • @wakazai Tu es sûr que c'est celui une fois Recalbox booté ?

    J'explique qq trucs :

    • hdmi_drive est en général l'option qui fout la grouille avec le DVI. Dans Recalbox elle est forcée à 2, mais je verrai avec le reste de la team pour commenter cette option pour 2 raisons : l'autodétection de l'audio marche mieux, et ca ne pénalise aucunement le DVI.
    • hdmi_force_hotplug lui est pratique à commenter pour gérer facilement de la bascule composite/HDMI

    Dans ton cas, je commenterais le tout dernier hdmi_force_hotplug mais je doute que ça aide ...



  • @Substring
    "Tu es sûr que c'est celui une fois Recalbox booté ?" --> je ne suis pas sûr de bien comprendre la question, mais c'est le fichier tel qu'il est sur la carte aujourd'hui que je viens de copier et que j'édite pour faire mes tests.

    J'ai dejà testé de commenter hdmi_force_hotplug merci pour le tuyau mais malheureusement mais ça n'a rien donné.
    Ca me rend fou de pouvoir booter sur Raspbian avec un affichage impeccable et de me taper un écran noir sur Recalbox.

    Est ce que Recalbox fait aussi appel au fichier config.txt pour les paramètres d'affichage ? Allez je garde la pêche et je ne désespère pas encore :)



  • @wakazai Justement, dis-toi que passé NOOBS, chaque OS a son propre config.txt, d'où ma question.



  • @Substring Huuuuuuu alors non je ne suis pas sûr du tout, c'est le config.txt qui est dans le dossier /root,
    mais si il y en a un autre caché ailleurs pour Recalbox je suis preneur !
    Si ça se trouve je n'édite pas le bon depuis le début...

    (--Trifouille dans la carte SD...--)

    Oh madre de dios, quand je branche ma carte SD sur un ordi j'ai aussi un volume boot0 qui monte, avec son fichier config.txt ! Ca ressemble à celui de Recalbox ?

    Je le colle ici :

    ♯ uncomment if you get no picture on HDMI for a default "safe" mode
    ♯hdmi_safe=1

    disable_overscan=1

    ♯ uncomment to force a specific HDMI mode (this will force VGA)
    ♯hdmi_group=1
    ♯hdmi_mode=1

    ♯ comment to get jack audio
    hdmi_drive=2

    config_hdmi_boost=0

    ♯ force hdmi while the tv can take time before sending the signal on the hdmi output
    hdmi_force_hotplug=1

    ♯ uncomment for composite PAL
    ♯sdtv_mode=2

    ♯ uncomment for lirc-rpi
    ♯dtoverlay=lirc-rpi

    ♯ if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it
    boot_delay=3

    ♯ uncomment if you don't want the rainbow at startup
    disable_splash=1

    ♯ Overclock
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512

    avoid_safe_mode=1

    kernel=zImage

    ♯ NOOBS Auto-generated Settings:
    hdmi_force_hotplug=1

    Je sens qu'on progresse ! :)



  • @wakazai c'st surement lui :) regarde le hdmi_drive=2 -> hop tu commentes



  • @Substring Voilà c'est fait, c'était bien ça !
    Sur un dual boot il faut donc editer le config.txt de chaque dossier racine (boot, boot0, boot1...)

    Merci pour ton aide ! Le topic peut passer en Solved ;)



  • @wakazai said in Dualboot DVI : Raspbian OK, Recalbox pas OK du tout:

    Le topic peut passer en Solved

    tu peux le faire comme un grand ;)



  • @substring said in Dualboot DVI : Raspbian OK, Recalbox pas OK du tout:

    @wakazai said in Dualboot DVI : Raspbian OK, Recalbox pas OK du tout:

    Le topic peut passer en Solved

    tu peux le faire comme un grand ;)

    Je trouvais pas comment faire :)
    Je crois que c'est bon, merci encore pour ton aide !



Want to support us ?

Join us on :

288
Online

29666
Users

14863
Topics

111974
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.