Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Amiga, Stand der Dinge?

  • Hallo zusammen,

    vielleicht nicht ganz richtig hier - aber vielleicht kann hier jemand helfen oder hat eine Idee:

    Ich hab mir heute einen "Amiga-Joystick" gebastelt - ich habe dafür den "DragonRise Inc. Generic USB Joystick"-Controller verbaut. Unter Windows wird der Sauber eingerichtet - Richtungen + Button 1, Button 2 werden passend erkannt. Auch das Einrichten unter ES klappt - Richtungen, Button 1, Button 2. Im Amiga-Emulator klappt es nicht ... Hier hab ich Button 1 (gerade kein 2-Button-Spiel zur hand) und links/rechts. Hoch/Runter fehlt. Ich hab in ES bei der Controller Config alle 3 Richtungseinstellmöglichkeiten probiert. In ES klappt hoch/runter dann auch ... aber Amiga 😞

    Jemand eine Idee was ich mal probieren könnte?

  • Banned

    @wulfman did you try with another emulator to see if up and down where working ? Like snes ?

  • @voljega said in Amiga, Stand der Dinge?:

    @wulfman did you try with another emulator to see if up and down where working ? Like snes ?

    SNES works

  • Banned

    @wulfman did you try with only game and is it 600/1200 or CD32 ?

  • i've tried some 600/1200-Games. Like Lotus 3, James Pond, Dynablaster. Only Left/Right und Fire 😐

  • Banned

    @wulfman strange... no issue on my side.

    I think we'll have to wait for next amiberry version which will handle controller better :s

  • Same Problem @ Amiberry https://github.com/midwan/amiberry/issues/114

    "Fixed with new control system :)" ... mhhh ... Your amiberry-version is oldern than this from October? Or is this something which i can do now?

  • Banned

    @wulfman there is a 2.5 beta version you can try it (but you will be missing one icon file and something else I don't remember, which you'll have to get somewhere).

    Personnaly I'm waiting for 2.5 final to update my version

  • 2.5beta doesn't allow to join Config-Menu ... Back2ES 😐 ... ok i will wait for 2.5 final 😐

  • Banned

    @wulfman yeah or you can try with another controller

  • not possible ;(

    My Case ist very small ... not enough space for an other controller (Xinmo has same format - but it has a fix USB-Port - not compatible with my case ;| )

  • my Controler with Dragonrise works now!

    I'd just asked Amiberry in Github. The controller problem is "fixed" by a new configuration option (Controllerconfiguration). Amiberry would like to have retroarch controller configs in the future. The "official" 2.5beta can't do that yet - but I found an older binary from a fork (HoraceAndTheSpider). The Fork is to be merged with Amiberry soon.

    Do you have any idea how to do it with the RetroArch configs?

  • Banned

    @wulfman it's just that the controller will now be handled properly 🙂

    I don't know how to do it yet but I followed the discussions on the subject and will integrate it once it is released.
    Try to find the generated retroarch file in recalbox and you suould be able to use that from the gui

    I would be interested if you could send me the fork binary, I could try to get an early start on this.

  • you are on facebook? "The Amiga RetroPie WHDLoad Group"? Then: https://www.facebook.com/groups/AmigaRetroPieWHDLoad/permalink/2062582597303082/ (Dom is HoraceAndTheSpider @ Github; Midwan is also in this group). Its an " Experimental Amiberry Binary" (rpi3 i think; "your" 2.1-Binary was for rpi2 - why not 3? You have an rpi2 or "compatibility"?) ... but you can compile your own from the Horace-Fork?! I haven't done any compiling by myself yet;) ... if the Menu "crash" to ES -> you need some icons @ data/ (controller(s?).png and quickstart.ico).

    Or "directly": http://www.ultimateamiga.co.uk/HostedProjects/RetroPieAmiga/downloads/ -> at the bottom "amiberry" is the binary.

    Here is the thread @ Github: https://github.com/midwan/amiberry/issues/114... there you can find "my" RetroArch-Config (post from Horace) - as example.

    I hope I have a little time to deal with this today. I have only tried ECS games so far... I don't know how AGA (1200) reacts yet. Isn't that supposed to work for CD32?

    WHDLoad should work (Horace is Admin from the WHDLoad-Group...) ... no experience with this (i like *.adf G ... mhhh .... G)

  • Banned

    @wulfman it should work on everything i guess, just need to try it, thanks for all the infos

  • Banned

    @wulfman said in Amiga, Stand der Dinge?:

    if the Menu "crash" to ES -> you need some icons @ data/ (controller(s?).png and quickstart.ico).

    Can you tell me where to find those two icon files ?

  • Banned

    @wulfman Thank you !

  • Question for your new install:
    Yesterday i've played with whdload (your old install) - bad 😞
    Saving isn't work. You copy a game to ram-disk -> Game make his saves on ramdisk. Finish. After restart Game: no saves. I see in the script that you copy back some savegame-files - but it doesn't work.
    What's your new solution (new install-script)? Will it work?

    And second WHDLoad: it is possible to give some parameter to whdload? 😞 Some game won't start because "custom1" is not set ... ok - i found: s:whdload.prefs ... but a solution is this not really. Game 1 needs custom1=1 to start - for next game custom1=1 means: activate cheats 😞

    An individual solution is needed here... for your old script I would have an idea for a workaround (you copy the .prefs to the ramdisk... in rom-dir I would put a gamename.whdload-File - start the game -> copy it all on ramdisk -> gamename.whdload is copied as whdload.prefs to ramdisk). Workaround.... better solution?)

    Last problem: if i quit a whdload-Game i will back to workbench - at this point: no menu/quit-key works (from .uae). Solution: reboot ... ;/

    PS: is there an "official" Thread (english) to talk about your script? 😉 We are here definitely off-topic 😉

  • Banned

    @wulfman I'll create a new thread about the new script tonight or tomorrow early morning and will answer your questions there

Log in to reply

Want to support us ?