Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Raspberry pi zero audio output pwm not work

  • I put this code "dtoverlay=pwm,pin=23,func=4" in config.txt but not work. 23 because gpio in raspberry zero is different i think. i use recalbox 4.0.1 and my programation level is 0

  • @ian57 do you have any suggestion ?

  • Developer
    Global moderator

    @Eron-Barbosa Please take a look at https://github.com/recalbox/recalbox-os/wiki/Analog-Audio-Pi-Zero-(EN), everything is explained. The right configuration is the following :


  • work, but i change pin 18 by pin 12, gpio 18 i use for control and maybe are on conflict

  • Hi guys!

    I'm completely crazy! I have been trying to fix the sound output for hours! I'm building a GameBoy Zero. I enabled the GPIO controller and tried to activate the PWM audio output.
    My GPIO18 is used by the Y button of the controller, so I changed the dtoverlay line to use the GPIO13.

    This is my current configuration:

    0_1488580279560_Screen Shot 2017-03-03 at 23.30.47.png

    I'm using earphones directly connected to the GND and GPIO13, but nothing sounds. I tried different combinations of pwm and pwm-2chan without results.

    My Recalbox version is 4.0.2

    Could you please give me some advice? Thanks!!!! 😄

  • This post is deleted!

  • @MartinCR I have the exact same issue, no sound through gpio 13, neither with or without filter and amplifier.

    I use "dtoverlay=pwm-2chan,pin=18,func=2,pin2=13,func2=4"

    Did you find out what was wrong

  • @svartholm Hi guys!

    yes, it's fixed, but I'm not sure about what's the solution. I think there's something broken in the 4.0.2 update. I read other thread in this forum about a similar problem with RPi3 and Recalbox 4.0.2. I decided to downgrade to the 4.0.0 version and disable the automatic updates and everything is working now!

    Let me know if it works for you!

  • @svartholm I changed my mind, I think the audio problem is present if you set the gpio and the pwm-2chan enabled at the same time. Everything was working until I decided to enable the gpio in the recalbox.conf file. Now I don't have sound 😞

  • Solved!
    I was using a GPIO controller, but the PWM doesn't work with the default mapping configuration of Recalbox. The solution is to set controllers.gpio.args=map=1 in the recalbox.conf file.
    Now the GPIO and the PWM Audio are working simultaneously.

    My PWM config is:

  • I was faced with the same problem with Recalbox 4.0.1.
    I have the same configuration as the but there was no sound at all. I have downgraded to Recalbox 4.0.0 and applied the configuration again and everything works like a charm.

Want to support us ?