Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Petit souci de format 4/3



  • Bonjour la communauté, tout d'abord un grand bravo à l'équipe, et merci pour ce merveilleux monde qui s'ouvre devant moi de l'emulation.
    Mais, je suis devant un petit problème:
    J'ai changé d'écran et passer d'un 16/9 full HD à un écran 4/3 dvi en 1600x 1200, et il se trouve que les jeux se qui se lancent en 4/3 n'occupent pas la totalité de l'écran. Il y a un cadre noir tout autour de l'image. Quand je passe l'affichage en 16/9, elle est donc "écrasée" mais les bandes sont seulement présente en haut et en bas, j'en conclue que ce n'est pas un problème écran.
    J'ai déjà modifié le fichier recalbox.conf et le config.txt, (group2, mode 51) mais rien n'y fait.
    Voilà ma config si quelqu'un pouvait m'éclairer?
    Un grand merci par avance
    ps : le resultat de la commande tvservice -m CEA, affiche 0 modes
    0_1486631921728_config.JPG


  • Staff
    Team
    Creator
    Moderator

    @Billax

    Essaie de modifier directement dans le config.txt?



  • Et bien ça ne change rien
    voilà mon config.txt :

    #hdmi_group=2
    #hdmi_mode=51



  • Bonjour,

    As tu essayé d'activer l'OVERSCAN dans les options de ES ?


  • Staff
    Team
    Creator
    Moderator

    @Billax si il y a des # devant, ça va pas...



  • si ES est en resolution native, le plus simple c'est de mettre global.videomode=defaultdans le recalbox.conf


  • Staff
    Moderator
    Team

    ya global.ratio=4/3 aussi



  • Bon j'ai enlevé les # dans config.txt, passé en mode default le global.videomode, et le global.ratio en 4/3 rien ne change, l'interface de ES est en plein écran sans problème, ce sont seulement les jeux.



  • @tong-man said in Petit souci de format 4/3:

    Bonjour,

    As tu essayé d'activer l'OVERSCAN dans les options de ES ?

    +1 pour moi ça avait fonctionné



  • Oui l'overscan est activé, je me trompe peut être mais ça n'impact que l'interface non ? alors qu'ici ce ne sont que mes emulateurs. C'est comme si il y avait un zoom a 90% le format 4/3 est juste mais l'image ne touche pas les bords de l'ecran.



  • Personne n'a d'autres petites soluces à me proposer ?



  • Salut,
    j'ai eu le même problème pendant longtemps et ai finalement trouvé la solution en configurant le menu de RetroArch (hotkey + B pendant un jeu lancé) : > Settings > Video > Aspect Ratio Index = 4:3
    J'ai fait cette manip pour toutes les plateformes qui le permettent (FBA libretro, snes, sega,....), puis j'ai configuré ES de cette manière : Menu principal (Start) > Options des jeux > Format jeux = Personnalisé.
    Et dans mon fichier de configuration (section H), l'entrée "Set game resolution for emulators" donne
    global.videomode=default

    Au passage, soluce trouvée grâce à @rockaddicted dans ce sujet. (merci !!)

    Par contre, curieusement la n64 s'affichait parfaitement avant, et s'affiche avec des bordures maintenant... mais c'est un autre sujet...



  • salut,

    bizarrement, un de mes écrans me faisait ce genre de problème : c'était un 16/10 résolution : 1600*900.
    et en mettant le mode : DMT 45 HDMI qu'il fallait.

    et bien en mettant le mode par défaut, c'est à dire CEA 4 HDMI (720p) et 16/9 dans les options de jeux, tout s'affichait nickel et en plein écran !!!

    Allez comprendre...

    Du coup essaye de ton côté pour voir.



  • @poumtaq merci je vais essayer ça, je suis preneur et @tong-man c'est pas impossible non plus puisque sur mon écran précédent (certes 16/9) tout passait sans soucis du 4/3 au 16/9 comme je voulais. Du coup je me demande aussi si il est possible de remettre le fichiers de .Conf par défaut ? Je suis sur rbpi 3
    EN tous cas merci pour ces infos, je reviens avec des nouvelles



  • Me revoilà, j'ai donc testé les paramètres vidéo de retroarch, et aspect ratio index est sur 4/3, mais en mettant "integer scale" sur off, l'image est en plein écran ! Mais même en sauvegardant cette config, au lancement il ne charge que celle par défaut et donc je reviens au point de départ. il y a t'il donc des vérifications à faire ? j'aimerais du coup remettre recalbox.conf par défaut et tester si ça ne vient pas de retroarch.
    Que puis je faire ?



  • @Billax Il y a une option "save on exit" à mettre sur "on" dans retroarch.



  • @poumtaq testé aussi mais à la sortie de RA je reviens au menu de l'emulateur et quand je relance le jeu, c'est la config de base, je testerai encore tout a l'heure, merci !



  • @Billax Dans ES : tu désactives le integer scale et tu forces le ratio à 4:3, pas besoin de passer par retroarch
    Sauf que tout n'est pas prévu pour fonctionner en 4:3 (aïe aïe aïe les shmups verticaux ...)



  • ...c'est sûr que de mon côté les shmups comme EspRade sont martyrisés c'est dommage...



  • @Susbtring, comment je désactive cette option dans ES ? du coup effectivement les shmups vont en prendre un coup mais c'est assez bizarre quand même ce souci, avant sur mon écran 16/9, en format auto tout s'adaptait comme il faut avec des bandes à gauche et à droite plus ou moins grande suivant le ratio du jeu, mais à chaque fois en hauteur l'image touchait les bords de l'écran. Ici en mode auto, 16/9, ou 4/3 il y a bien une différence de format mais il n'y a que le 16/9 qui touche les bords d'écran les autres parm. laisse une bande noir en haut et en bas (en plus de celle des côtés)...


Log in to reply
 

Want to support us ?

299
Online

77242
Users

19394
Topics

143836
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.