Duda control gpio y on/off a la vez



  • Buenas, tengo una duda tengo puesto el boton on/off pin 5 y 6 gpio, ahora tengo que activar los controles, 5 se usa de hotkey, yo no uso hot key ya que uso select, pero mi duda es, al activar el control gpio, que pasa con el interruptor que usa el 5 tambien? Gracias de antemano


  • Moderator
    Team
    Moderator
    Translator

    SI ya tenes la configuracion, por que no lo intentas y nos lo comentas? No se puede arruinar nada ;)

    Update: En realidad, el HK para el segundo jugador no se usa/necesita o sea que no es necesario añadas ese boton. El script de apagado deberia funcionar. Probablemente apagarias el sistema utilizando un HK P2 si tenes activado el de onoff.



  • Sii, estaba haciendo el cable por eso preguntaba para dejarlo ya bien hecho si alguien sabia por que lo estaba haciendo en un dupont de 20 20 para encajar solo una pieza al Gpio no botón a botón, esta tarde acabare el cable y probare, ya dire lo que sea por si alguien le interesa



  • si hiciste la prueba? podemos saber los resultados???



  • Yo te puedo decir que funciona perfectamente. Monte mi bartop con los mandos arcade conectados con gpio con dos joysticks, 6 botones por jugador, 2 botones de start, uno de hotkey y uno de encendido/apagado y funciona todo a la perfeccion. El hotkey 2 lo puedes evitar, no es necesario. Saludos



  • Pues al principio bien todo sin problema, no puse HK, y HK es select y listo, pero ahora si activo el 56 para apagado encendido si enciendo o apago la luz o los altavoces de la bartop parece que hace interferencia.... no se por que si encuentro solución lo comento .



  • Nada no hay forma e intentado de todo, si activo la linea 5 6 para push button cuando apago o enciendo los altavoce, me cierra el sistema, con la luz de la marquesina me pasa igual... si lo desactivo, todo va perfecto.


  • Banned

    This post is deleted!


  • si, va todo a una regleta de 4, una para luz uno para rp otro monitor y otro altavoces, y me pasa aunque use 2 regletas/enchufes diferentes, y si desactivo la función de on/off va todo bien... llevo todo el dia probando cosas y nada.


  • Moderator
    Team
    Moderator
    Translator

    @Fran-Rdg-Gnd yo tengo algo parecido:
    https://forum.recalbox.com/topic/3704/push-button-on-off-script-problems

    Que tipo de switch utilizas exactamente? Al parecer algunos pulsadores de mala calidad hacen contacto con solo mirarlos!



  • Estaba usando uno de estos chiquitajos sin swith ninada, acabo de comprar un interruptor on/off a ver si no pasa con eso, ahora comentare que tal, espero que funcione nunca me ha pasado esto y estaba quedandome loco ya, e probado hasta otra rp y nada...



  • Nada, me sigue pasando, no se que puede ser ni que mas probar.... e probado de todo y sigue pasando solo se soluciona si quito en on/off



  • a todo esto, e probado desconectando gpios, y solo dejando los pin 5/6 y sin interruptor y pasa igual


  • Moderator
    Team
    Moderator
    Translator

    @Fran-Rdg-Gnd entonces realmente tiene que ver con el script... Podes mencionarlo en el enlace que te pase en ingles?



  • claro, luego en casa lo pongo, que con el ingles tengo que tirar de traductor jaja, y si me da que sera fallo del script por que e probado distintas rp, distintos cables, y hasta como te digo... sin ni siquiera interruptor solo pinchando los pines 5 6 y activandolo ya pasa, aun desconectando todos los demás controles del gpio.



  • O bueno acabo de ver que eres traductor, lo posteo en español y lo traduces tu? Seguramente sea mejor ingles tu traduccion que la del traductor.


  • Moderator
    Team
    Moderator
    Translator

    @Fran-Rdg-Gnd no es que sea traductor, sino que he ayudado a traducir muchas cosas :) Podes escribirlo en español y yo despues lo traduzco. Simplemente intenta que sea lo mas preciso posible.



  • @paradadf post puesto en español en el post que pasaste.

    Por cierto postee en FC a ver si alguien daba solución a través de la cuenta de un colega ya que yo no tengo el placer de tener una, me pareció verte por el hilo, nadie me respondió una posible solución por hay tampoco, ni experiencias parecidas, solo era por informarte jeje.


  • Moderator
    Team
    Moderator
    Translator

    @Fran-Rdg-Gnd traducido ;)



Want to support us ?

Join us on :

240
Online

28857
Users

14652
Topics

110751
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.