Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

mortal kombat 3 ultimate rom will not show up in mame list in recalbox

  • i have tried a 0.78 rom version and 0.37b. neither will show up in the mame game list either under M or U. does this game/rom work at all?

  • @thanosazlin yes it is working... It is likely you don't ave the right version or it is not correctly named... Check the name of the zip in tge bestarcade list (see wiki if you don'tbknow what I mean)

  • thanks i really had a hard time trying to find what you mentioned on the recalbox wiki, i did find this link that listed 0.78 roms list of file names


    and it shows that i have the files with correct names, and the sizes of both files are 7,196KB(7mb) each.

  • nm :) i just found it sorry. so i read the bestacrade spreadsheet. it only lists 1 filename for umk3 which is odd as from what i was seeing both the 0.78 and 0.37b list multiple zip files for umk3. i guess i can try having only the 1 file that the bestacrade list states and see if that works.

  • man i just can't seem to get this to work. so i found this link


    that has list of what all .bin files need to be inside each .zip file. i check my mk3 zips and umk3 zips they all were correct all the .bin files inside matched what is listed in the link above, EXCEPT umk3r11.zip . my umk3r11.zip file only had 10 .bin files in it, so when i look closer at the files that are supposed to be inside umk3r11.zip per the link above they are the exact same files and sizes as umk3.zip . so i decided to copy umk3.zip and name the copy as umk3r11.zip to test my theory , but no go.

    i still cannot get UMK3 to show up in the list.

  • Staff

    The rom umk3.zip, according to this list is shown on ES as "Ultimate Mortal Kombat 3 (rev 1.2)", regardless of its content (without scraping).

  • @thanosazlin the multiple zip are just the parent and the clones you only need the parent... I strongly suggest you read the easy arcade wiki page really seriously and not one word every three phrases as you seem to struggle with how mame works in general and on recalbox too

  • yeah i know how roms work. so it's all my fault. i figured out what got me in the situation. so after i got my cabinet done and recalbox loaded (i started with retropie but switched to recalbox) , i hid all the duplicate rom names except for the main rom zip file name that runs the game, i did this for several. dummy me totally forgot there was MK3 ultimate that had all the extra fighters as opposed to just MK3 regular.

    so i need to figure out how i can un-hide the mk3u that i hide :) ? i backed up my current sd card, and deployed a new recalbox image and just put on mk3 zips and mk3u zips and it showed up fine.

    man i'm sorry guys for this... any config file i can go to that has like all the files i told recalbox to hide and then just remove mk3u from it ?

  • found this post, currently putting my saved .img file back down on my sd card will try it in the morning.


  • hmm i ssh in and stopped the emulation station service, then checked /recalbox/share/roms/mame/gamelist.xml in vi and searched for "hide" and there is no hide option for any game as mentioned in my previous post.

    how can i un-hide a game? is there another config file somewhere else.

  • Staff

    the tag name is hidden not hide

  • right sorry typo i meant hidden. the only thing showing up hidden is the bios files i set to hidden. umk3 is not set to hidden. i even tried putting in <hidden>false</hidden> in the meta section for umk3 for both umk3 zip files , but that didn't help. and yes i shutdown emulation service before editing. i just don't understand how it is hidden and not displaying in the gui, if there is not a hidden tag for umk3?

    here is my gamelist.xml file from mame dir.


  • Staff

    no idea... there is no reason why those roms shouldn't be displayed on ES, if they don't have hidden=true. In your place, I would delete the gamelist.xml and scrape again, properly. Do not copy thousand clones if you aren't planning to use them. Also, I doubt you have the correct romset, as you wrote about have been juggling with the contents of the roms. Get the correct right or you will still have problems.

  • ok i am trying but the scrap is only on game 11 after like 2 hours or so.. it is moving like a snail :). it is not my internet either. and i have a cat5 cable plugged into the pi Ethernet port from my router. it was going really slow and now i don't know but it might be stuck/hung on "working" status that is showing on the screen.

  • Staff

    Don't use the internal scraper. Look for the Universal XML Scraper here on the forum. And before scraping, take care of your roms. Get the correct romset and see that you find the games on ES XD

  • ok i got the universal it worked. thanks

Log in to reply

Want to support us ?

Join us on :





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.