Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Original N64 Controller/MayFlash/Adapter Joystick keine Funktion!

  • Staff

    Login and type in "mount -o remount,rw /boot"! (no reaction in PuTTY window)
    Is that right?

    yes it 's ok.

    edit cmdline.txt with notepad++ and winscp if you have windows 10
    you can use in ssh : nano /boot/cmdline.txt

    add line.

    cltr+x to save , Y and exit, reboot your raspberry

  • @acris

    I'm sorry to say, but it still doesn't work!
    Still no joystick feedback!

    An other idea to fix my problem?
    I hope so ;-)


  • Staff

    Very strange because mayflash saturn or snes, Nes work with usbhid.

    I need archive zip from recalbox-support.sh script : https://github.com/recalbox/recalbox-os/wiki/Recalbox-support-(EN)

    upload archive again and post your cmdline.txt.

  • @acris

    I heard that the nes and snes work great on recalbox!

    cmdline.text =
    dwc_otg.fiq_fix_enable=1 sdhci-bcm2708.sync_after_dma=0 dwc_otg.lpm_enable=0 console=tty3 loglevel=3 elevator=deadline vt.global_cursor_default=0 logo.nologo root=/dev/mmcblk0p7 rootwait fastboot noswap ro usbhid.quirks=0xe8f:0x3013:0x040

    archiev = http://www37.zippyshare.com/v/298NKtYy/file.html

    Thx for dont give up!


  • Staff

    as the dmesg command answer, the controller is well detected :

    [    2.328286] usb 1-1.4: new low-speed USB device number 5 using dwc_otg
    [    2.502000] usb 1-1.4: New USB device found, idVendor=0e8f, idProduct=3013
    [    2.502021] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [    2.502028] usb 1-1.4: Product: USB GamePad
    [    2.502034] usb 1-1.4: Manufacturer: HuiJia 
    [    2.614471] input: HuiJia  USB GamePad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:0E8F:3013.0004/input/input2
    [    2.614681] input: HuiJia  USB GamePad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:0E8F:3013.0004/input/input3
    [    2.614810] input: HuiJia  USB GamePad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:0E8F:3013.0004/input/input4
    [    2.614942] input: HuiJia  USB GamePad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:0E8F:3013.0004/input/input5
    [    2.615149] hid-generic 0003:0E8F:3013.0004: input,hidraw3: USB HID v1.10 Joystick [HuiJia  USB GamePad] on usb-3f980000.usb-1.4/input0

    so, you'll need to test it with the evtest or jstest under ssh connnection program, to check if the joystick is working or if it is juste a configuration problem

    # evtest 
    No device specified, trying to scan all of /dev/input/event*
    Available devices:
    /dev/input/event0:	DragonRise Inc.   Generic   USB  Joystick  
    Select the device event number [0-0]: 0

    for example

    But first if you have other usb devices connected to the Rpi ;) , recheck with only your gamepad connected.

    iManufacturer           1 Logitech
      iProduct                2 USB Receiver

  • @ian57


    No device specified, trying to scan all of /dev/input/event*
    Available devices:
    /dev/input/event0: Logitech USB Receiver
    /dev/input/event1: Logitech USB Receiver
    /dev/input/event2: HuiJia USB GamePad
    /dev/input/event3: HuiJia USB GamePad
    /dev/input/event4: HuiJia USB GamePad
    /dev/input/event5: HuiJia USB GamePad
    Select the device event number [0-5]:

    select: 2

    moving joystick up =

    Testing ... (interrupt to exit)
    Event: time 1479143920.295353, type 3 (EV_ABS), code 1 (ABS_Y), value 126
    Event: time 1479143920.295353, -------------- SYN_REPORT ------------
    Event: time 1479143920.311368, type 3 (EV_ABS), code 1 (ABS_Y), value 124
    Event: time 1479143920.311368, -------------- SYN_REPORT ------------
    Event: time 1479143920.327356, type 3 (EV_ABS), code 1 (ABS_Y), value 123
    Event: time 1479143920.327356, -------------- SYN_REPORT ------------
    Event: time 1479143920.343332, type 3 (EV_ABS), code 1 (ABS_Y), value 119
    Event: time 1479143920.343332, -------------- SYN_REPORT ------------
    Event: time 1479143920.359323, type 3 (EV_ABS), code 1 (ABS_Y), value 110
    Event: time 1479143920.359323, -------------- SYN_REPORT ------------
    Event: time 1479143920.375325, type 3 (EV_ABS), code 1 (ABS_Y), value 99
    Event: time 1479143920.375325, -------------- SYN_REPORT ------------
    Event: time 1479143920.391325, type 3 (EV_ABS), code 1 (ABS_Y), value 89
    Event: time 1479143920.391325, -------------- SYN_REPORT ------------
    Event: time 1479143920.407327, type 3 (EV_ABS), code 1 (ABS_Y), value 80
    Event: time 1479143920.407327, -------------- SYN_REPORT ------------
    Event: time 1479143920.423354, type 3 (EV_ABS), code 1 (ABS_Y), value 72
    Event: time 1479143920.423354, -------------- SYN_REPORT ------------
    Event: time 1479143920.439340, type 3 (EV_ABS), code 1 (ABS_Y), value 63
    Event: time 1479143920.439340, -------------- SYN_REPORT ------------
    Event: time 1479143920.455342, type 3 (EV_ABS), code 1 (ABS_Y), value 59
    Event: time 1479143920.455342, -------------- SYN_REPORT ------------
    Event: time 1479143920.471341, type 3 (EV_ABS), code 1 (ABS_Y), value 57
    Event: time 1479143920.471341, -------------- SYN_REPORT ------------
    Event: time 1479143920.487346, type 3 (EV_ABS), code 0 (ABS_X), value 129
    Event: time 1479143920.487346, type 3 (EV_ABS), code 1 (ABS_Y), value 55
    Event: time 1479143920.487346, -------------- SYN_REPORT ------------
    Event: time 1479143920.583379, type 3 (EV_ABS), code 1 (ABS_Y), value 59
    Event: time 1479143920.583379, -------------- SYN_REPORT ------------
    Event: time 1479143920.599411, type 3 (EV_ABS), code 0 (ABS_X), value 127

    If i hold the joystick it stops on this point

    so i think the has detected teh joystick!
    but i'am a noob un raspberry and linux

    hope you cam help me to solve my problem

  • Staff

    Hello @JumpingJack88

    Do you map your controller in Emulationstation Menu > Options gamepad ?
    You need to map, D-pad on D-pad and Analogy Control stick on joystick.

    text alternatif

  • @acris

    yes i tried to..... but he dosn't accept any movement of the joystick!

    don't be mad for saying that but,
    i know the difference between D-Pad and Joystick ;-)
    Did you find something wrong in my archive?
    do you know if there's an option too konfigurate the controller directly in system (blackscreen) of Recalbox?

    thanks for all of your help

    I hope you will find something to fix my problem

  • Staff

    @Substring do you have an idea ?

  • evtest shows 2 axis. If they don't work, might require another qurik ...

    @JumpingJack88 you should try running evtest for each huija controller and see if one gets answers from the stick

  • @Substring

    what does "quirk" mean?
    I'm sorry but i dont now this word :-(
    I have only one huija controller!
    I thought it was normal that he shows me one of each free usbport!
    There are only two devices pluged, my Logitech Keybord and a MayFlash-adapter with one Original N64 Controller!

  • Staff

    Hello @JumpingJack88
    quick is a word for usbhid quick -> (usbhid.quirks=0xe8f:0x3013:0x040) .
    This technic seems not to work with your mayflash controller.

    But try to edit /recalbox/share/system/recalbox.conf

    And change inputdriver

    ## Set retroarch input driver (auto, udev, sdl2)
    ## If you don't have issues with your controllers, let auto

    save and reboot

  • @acris

    thanks i'll try as soon as i can

Want to support us ?





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.