Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Network initialising too late



  • even when using a network cable there seems to be a problem with the network to be initialised too late. mounting a cifs share only works when adding "mount -a" to /etc/init.d/S99myscript (for example). but then it's too late -> emulationstation won't start and an error message (no roms found). is it possible to make the network working even before /etc/fstab is "started"? so there'd be no need for an additional script. that's my order now and it seems to be working (i changed S13, S15 and S19) S01logging S02hotplug S02serial S03cleanrun S10udev S11removeeth1 S13network S15networkrestart S19myscript (just "mount -a") S20urandom S29recalboxsystem S30dbus S31emulationstation S31sixad S49ntp S50dropbear S50kodi S60nfs S91smb rcK rcS


  • Staff
    Team

    Yes that's a good solution. I will not start the network before emulationstation on recalbox by default as it would add many seconds to boot time. But your solution is ok. Be careful though, if you make an update, the files you renamed will reappear with their original names.



  • oh okay, that's why... thanks. but honestly i wouldn't care for a longer boottime - its a raspberry pi, so most people can and will run it 24/7 anyway because thats one of the main benefits of the low power consumption (especially because recalbox is a mediacenter as well and might be used everyday)



  • Hi there, I've the same problem as you, I want to mount my NAS after network is UP... But i've try with argument "_netdev", and doesn't work after network is up... :( Have you try to modify any Script (S..) and have you some results ? Cheers,



Want to support us ?

214
Online

61435
Users

18626
Topics

139995
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.