Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Changement dé résolution


  • CRT Maniac

    Pour moi, un adaptateur HDMI vers DVI-D ou DVI-D vers HDMI ne peu pas poser de probleme. Ce sont les même signaux. Ce n'est pas un convertisseur mais bien un adaptateur physique. Sans entrer dans les details, les 2 différences entre le HDMI et le DVI-D c'est le format physique du connecteur et l'absence de son dans le DVI-D. Si tu forces le 1600x1200, ça devrait fonctionner. Après, t'es pas a l’abri d'une particularité qui empercherait cette résolution.

    J’ai mide le mode 51 dans recalbox.conf

    Ce paramètre est utilisé pour les émulateurs, pas pour EmulationStation, Si tu veux EmulationStatiuon en 1600x1200, Essais de modifier le fichier "/boot/config.txt" et mettre : hdmi_group=2 hdmi_mode=51 hdmi_drive=2 hdmi_force_hotplug=1 config_hdmi_boost=4 Si tu vois plus le Boot de Noobs, appuies sur "Shift" au démarrage pour avoir le mode vidéo de base et remodifier "/boot/config.txt".



  • Pour le moment, je n'ai aucun changement. voici ce que j'ai modifié dans le config.txt : #hdmi_mode=51 1600x1200 @60Hz et dans la partie global emulator configuration de recalbox.conf: global.videomode=DMT 51 HDMI Dites moi si je me suis trompé quelque part.



  • @ Ely Jun,   essaie  : hdmi_mode=51 dans le fichier config.txt le # désactive la ligne



  • Toujours la même résolution. Par contre quand je lance un jeux, il me dit, signal déphasé, impossible d'afficher ce mode vidéo, changez l'entrée d'affichage de l'ordinateur à 1600x1200 @ 60Hz Et quand je veux revenir au menu, écran noir (la recalbox tourne encore j'entend le son)



  • tu trouveras peut-être une réponse sur ce site. https://www.raspberrypi.org/documentation/configuration/config-txt.md



  • Bonne nouvelle, la résolution est maintenant bonne. J'ai fais mon noob, je n'avais pas enlevé le # devant hdmi_group. La mauvaise nouvelle c'est que mon signal est maintenant déphasé lorsque je lance un jeu. Même message lorsque je reviens au menu.


  • CRT Maniac

    T'as du 1600x1200 sous Emulation Station ? Si c'est le cas, il faut trouver comment lancer RetroArch sans toucher a la résolution.



  • Oui, le menu de recalbox est impeccable maintenant =) J'ai testé de modifier recalbox.conf avec différents mode mais ça ne marche pas. Je n'y connais actuellement rien à RetroArch par contre.



  • Autre piste à explorer : le réglage du moniteur. En faisant des recherches sur internet "signal déphasé ecran DEll", voici ce qu'on trouve: http://www.lesnumeriques.com/legrandforum/avis/Ecrans-TV-Videoprojecteurs/divers/installation-signal-dephase-sujet_18767_1.htm


  • CRT Maniac

    Essai quelque chose, pour voir : - Quitte Emulation Station (il faut que ES soit en 1600x1200). F4 - Ouvre la "fenêtre" du Shell : Alt+F2 - Log toi root recalboxroot - Lance RetroArch : "retroarch + ENTER" - Dans RetroArch, charge un Core et charge un jeu. Si le jeux se lance, regarde dans les paramètres de ton moniteur, si t'es toujours en 1600x1200. Si c'est le cas...bin...c'est deja que c'est possible ;) Le probleme de déphasage dépend du moniteur et de la version du moniteur. Après il y a des fonctions de fou pour configurer un écran sous RPi mais on va eviter d'entrer la dedans... Sur le lien plus haut de @Mathi68, c'est la partie : HDMI mode options (Mais c'est HARD !!).



  • Alors, je suis sur le menu recalbox, quand je fais F4 j'ai le menu de configuration de manette qui s'ouvre.


  • CRT Maniac

    Je t'encourage a chercher un peu comment ouvrir une "console" sous Recalbox. Je connais pas la V4. C'est quoi le menu Recalbox pour toi ? Faut être dans aucun menu, juste sur l’écran principal.



  • Oui, il faut qu'on utilise les mêmes termes... Alors le menu recalbox pour moi c'est la ou j'ai le choix de la console pour ensuite lancer mes jeux. Et l'écran principal c'est la ou on peut modifier le config.text ? le wiki m'indique exactement la même chose que toi mais chez moi ça ne marche pas. Je peux le faire en SSH ou pas?


  • CRT Maniac

    Oups ;) L'écran principal de Recalbox ;) Pas l'écran principal du boot, soit Noobs, désolé. https://github.com/recalbox/recalbox-os/wiki/acc%C3%A8s-root-sur-Terminal--%28FR%29 A mince, t'as déjà lu le Wiki. En SSH, pas sur que cela fonctionne car tu ne quitteras pas EmulationStation. Tu dois pouvoir quitter EmulationStation, c'est obligé, étrange ton histoire...


  • Staff
    Moderator
    Team

    Pour tuer le processus emulationstation il suffit en ssh de taper : killall emulationstation



  • J'ai fait ce que tu m'a dit Acris, j'arrive sur l'écran noir avec le logo recalbox et le numéro de la build. J'ai donc essayé ce que m'a dit ironic, mais rien n'y fait. Ce que j'écris s'affiche effectivement en haut à gauche de l'écran mais ça ne ressemble pas au terminal (quand je fais alt + F2, j'ai ça qui apparaît : ^@) Edit: j'ai lancé retroarch via putty au final, je vais tester donc ce que ironic m'a conseillé. Je fais donc Load Core mais il m'indique no items. J'ai l'impression que rien n'est normal ah ah



  • Bon, j'ai essayé de modifier plein de choses, je suis aussi allé dans les réglages caché de l'écran (qui n'a pas vraiment aidé mais au moins je sais que ça existe !). J'ai finit par remettre tout les videomode en default et laissé hdmi_mode=51 1600x1200 @ 60Hz. Emulation station tourne avec la bonne résolution du coup. Les jeux ce lancent et je peux revenir au menu, mais j'ai la N64 qui ne m'affiche qu'un tout petit carré en bas à gauche de l'écran. Je sais que la 64 peut poser problème mais y a t il un moyen de remettre l'image en plein écran? (aucune modification possible sur l'écran quand j'ai cette résolution la et au mieux c'est un zoom, je ne peux pas replacer l'image par rapport à l'écran) Encore merci à tous de m'aider en tout cas !



  • Dans le fichier recalbox.conf est inscrit : ## N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution) ## So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI). ## If your screen is not compatible with one of these video modes, please check the recalbox's wiki. donc peut-être avec cette ligne,l'image sera à nouveau centrée. n64.videomode=DMT 4 HDMI



  • Dans le fichier recalbox.conf est inscrit : ## N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution) ## So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI). ## If your screen is not compatible with one of these video modes, please check the recalbox's wiki. donc peut-être avec cette ligne,l'image sera à nouveau centrée. n64.videomode=DMT 4 HDMI



  • Oui oui j'ai vu, mais ça ne marche pas quand je fais ce mode l (DMT 4 HDMI) J'ai un écran noir avec une bande rose sur la partie gauche (comme si l'image ne se centrait pas) et revenir au menu recalbox me refait le signal déphasé. Je deviens fou ah ah


Log in to reply
 

Want to support us ?

217
Online

59455
Users

18499
Topics

139118
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.