Video Snaps transition effects: turn them off



  • Hello,
    is it possible to turn off the video snaps transition effect?

    Another issue I'd like to point out is, if you set the video snap start delay to zero and scroll very quickly throughout your game list, Emulationstation loads again and you are sent back to Main Screen.

    Regards,

    John



  • Not sure about being able to switch them off, but if you change the delay to something like 10 or 20 seconds, its effectively the same thing - they will never get a chance to play.

    emulationstation.videosnaps.delay=10000


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @clkgames I think you already know, but, the options that can be changed are in the recalbox.conf file (you must remove the semicolon from the beginning of the line for the configuration to work):

    ## Videosnaps
    ### Delay before videosnaps start, in millisecond. Default: 2s
    ;emulationstation.videosnaps.delay=2000
    ### Video loop times. 0 = no video. 1 or more = the video loops x times before fading out
    ;emulationstation.videosnaps.loop=1
    ### Enable videosnap sound/music
    ;emulationstation.videosnaps.sound=1
    

    Another issue I'd like to point out is, if you set the video snap start delay to zero and scroll very quickly throughout your game list, Emulationstation loads again and you are sent back to Main Screen.

    I wouldn't call it an issue, it happens due to a hardware limitation, you are overloading the system, and forcing it to restart the Emulationstation, if it didn't, you would have to shut down forcibly (and manually).

    The videos take up more storage space, and are heavier for the system to play. It is understood that whoever uses the videos uses it so that they can see an example of the game, that is, they will not scroll very quickly.
    Considering that the problem is hardware limitation (and that, I believe that it is not feasible to change the hardware because of this detail), and that, you want to use snap videos, but sometimes you want to go quickly to a specific title, I recommend that you use shortcuts:

    In the console selection list:

    In the games list:

    • L or R: page up / page down
    • Start-> JUMP TO LETTER


  • @RustyMG said in Video Snaps transition effects: turn them off:

    Not sure about being able to switch them off, but if you change the delay to something like 10 or 20 seconds, its effectively the same thing - they will never get a chance to play.

    emulationstation.videosnaps.delay=10000

    But I do want to play the video snaps, I was just wondering if it's possible to turn off the transition effect (fade in, whirling etc)

    @Zing thanks, yeah I was aware of the video snap options. BTW, does enabling emulationstation.videosnaps.sound=1 change anything on version 7.1.1?

    As for the "issue" thing; my apologies, wrong choice of words. It is clearly a hardware limitation as I am running Recalbox on a RPI4 with 2Gb of RAM.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @clkgames

    RPI4 with 2Gb of RAM

    An Rpi4 with 2Gb of RAM is enough to run practically all possible games in Recalbox, it is the most cost-effective Hardware today, but video snaps overload the system, it is definitely not worth changing hardware, it is better to configure the system otherwise, or, use the shortcuts I mentioned.



  • Oh. So, it does mean the ES reboot issue will never be fixed on RPI4 ? 😥


  • Theme moderator
    Themer

    I haven't encountered this issue on RPI3 (less ram).
    So i tough it was an optimisation problem with RPI4, no?


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @airdream Did you set the video snap start delay to zero?
    If you have the same configuration and it doesn't happen in Rpi3, then I'm wrong (and you're right).
    Can you please test with the delay set to zero?



  • @Zing as for videosnap sounds: turns out setting it to either 0 or 1 makes no difference as no sound is played at all during videosnap playback.

    ### Enable videosnap sound/music
    ;emulationstation.videosnaps.sound=1
    

  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @clkgames

    (you must remove the semicolon from the beginning of the line for the configuration to work)



  • @Zing sorry about that example, that line does not reflect how my recalbox.conf looks like, which is :

    ## Videosnaps
    ### Delay before videosnaps start, in millisecond. Default: 2s
    emulationstation.videosnaps.delay=1000
    ### Video loop times. 0 = no video. 1 or more = the video loops x times before fading out
    emulationstation.videosnaps.loop=100
    ### Enable videosnap sound/music
    emulationstation.videosnaps.sound=1
    

    Again no matter if you set it to 0 or 1, no difference - no sound in either way.

    John


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @clkgames I don't use videosnaps, and I can't test it now, does anyone else have this problem?

    I saw that it was previously reported:
    https://forum.recalbox.com/topic/20111/sound-and-videosnaps

    But I saw no other report than that.



  • I also have this problem, deleted the dot and comma the sound doesn't start


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    Please wait for the next version, there will be many improvements and maybe this is one of them.



  • @Zing thanks!



Want to support us ?

258
Online

82.0k
Users

22.5k
Topics

163.0k
Posts