Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[SOFT] Universal XML Scraper - Scrappez vos roms depuis Windows (Scrape your roms from Windows)



  • Oui, effectivement, le format zip est obligatoire pour fonctionner avec le site Screenscraper (qui contient les base de données en fr).
    Concernant le fait de "Re-zipper" tes roms, je ne t'y encourage pas, c'est long de tous rezipper, et sans garantie (si le réglage de ton zip n'est pas identique au zip d'origine, il y aura des différences de Hash et tes jeux ne seront pas trouvés.)
    Le plus simple, si tu as une connexion internet avec un débit suffisant, est de télécharger un romset tous fait (tu en trouves facilement sur internet, genre les set "no-intro" qui sont une référence... Google est ton ami 😉 )

    Tu pourras ensuite nettoyer facilement ton romset avec Universal ROM Cleaner 
    (pour retirer les roms qui ne te plaise pas, genre : les roms en japonais ou en Allemand, les roms de sample, les betas, les prototypes,...)
    Il ne te restera plus qu'à lancer le scraper sur ton set nettoyé pour avoir ton fichier XML 😉

    Pour information, hormis pour la N64, tu peux avoir toutes tes roms en zip. ça fonctionne très bien (même sur un PI1 pour ce que j'avais testé;). En plus, tu gagnes de la place 😉



  • Ok merci de ta réponse rapide et complète. pour les romset c'est pas un souci j'en ai déjà ; en revanche mes fichiers zip sont constitués de toutes les versions disponibles d'un même jeu (1 zip pour un jeu avec x versions dedans). Universal ROM Cleaner gère les zip comme ceux là ou faut il que je trouve des fichiers 1 zip pour 1 jeu pour 1 version Edit : j'ai trouvé ma réponse en téléchargeant un romset no-intro 😉 Je teste tt ça et reviendrai faire part de mon résultat ; en tout cas déjà un énorme merci pour tes ptis softs qui ont l'air bien sympa



  • salut je reviens avec ma part d'échecs... j'ai réussi à scrapper mes jeux, récupérer les images et créer une gamelist qui reprend le tout ; le seul souci est que cette gamelist n'est pas reprise par recalbox pour la plupart de mes sets. Pour mon set game gear la gamelist liste est prise en compte, le descriptif des jeux y est mais je n'est pas la jaquette du jeux alors que les images sont bien récupérées. Je dois sûrement faire quelque chose de mal mais là je vois plus quoi... Je passe par Windows pour effectuer la tâche est-ce la bonne procédure ? ou faut il faire quelque chose depuis la recalbox ? D'avance merci de votre aide



  • Non non, le logiciel est bien uniquement sous windows 😉 donc de ce coté la tout est correct.
    Voici des pistes : as tu bien fait un "Kill Emulationstation" dans le menu "SSH" AVANT de faire le scrape (sinon, emulationstation ne prend pas en compte ton nouveau fichier xml et remet l'ancien).
    Une fois le scrape terminé, tu peux faire un "Reboot", toujours depuis le menu SSH.

    (Attention, si tu as changé les identifiants de connexion en SSH, on ne sait jamais, tu peux vérifier directement dans le fichier config)

    Pour les images, il faut vérifier la concordance des chemins. Tu en as 2 dans le menu "configuration": Le chemin ou, depuis windows, les images vont être téléchargées. Normalement c'est quelque chose comme :

    \RECALBOX\User data\roms\nes\downloaded-images\

    Le chemin ou la recalbox (et emulationstation) vont aller chercher les images en local. Normalement c'est quelque chose comme ça :

    ./downloaded-images/

    Vérifie bien aussi que tes chemins se terminent par \ ou / en fonction 😉
    Sinon, quand tu regardes dans le répertoire de tes Roms, tu as bien un répertoire avec à l’intérieur tes images ?
    Peux tu me mettre la fin de ton fichier config ?
    (celui qui s'appel [LAST_USE]) Histoire que je vérifie tes chemins 😉



  • merci de ton retour tu trouveras ci-dessous le log j'essaie de refaire un test en suivant à la lettre tes indications en parallèle Nouvel essai : tjrs pareil pour ma gamelist Game Gear ci dessous la fin du fichier config : [LAST_USE] $PathRom  =\RECALBOX\User data\roms\gamegear\ $PathRomSub  =\RECALBOX\User data\roms\gamegear\ $PathNew  =\RECALBOX\User data\roms\gamegear\gamelist.xml $PathImage  =\RECALBOX\User data\roms\gamegear\downloaded_images\ $PathImageSub  =./downloaded_images/ $No_Profil  =1 $user_lang  =040C $HauteurImage  = $LargeurImage  =



  • Les "sub" sont incorrect.... dans chemin du fichier XML met : ./ Et dans chemin des images dans le fichier XML met : ./downloaded-images/ ça devrait mieux fonctionner 😉



  • coucou c'est le boulet 😞 je pense que mon problème vient du fait qu'Emulstation n'est pas kill lorsque j'active la fonction avant de lancer le scrap car ma gamelist.xml me semble correcte avec descriptif des jeux en français, chemin pour les roms, images etc... corrects. Le fait de killer doit il avoir un impact sur l'écran de la recalbox ; car moi après avoir activer le kill rien ne bouge sur l'écran de la recalbox je suis toujours sur l'écran de choix des systèmes. Les gamelists de ma recalbox ne correspondent pas aux gamelist que j'ai créé avec ton logiciel.



  • Effectivement, la commande Kill All Emulationstation est censé t'afficher un écran noir sur la recalbox. En toute logique, le menu SSH de Universal  XML Scraper te propose la commande et la lance via un logiciel tier (plink) mais c'est aussi possible que ça ne fonctionne pas (la première fois, il peut aussi afficher un message te demandant si tu valide la clef SSH auquel il faut répondre "oui"). Pour être sur tu peux utiliser cette procédure "manuel" : Accès via WINSCP ou celle-ci : Accès via terminal Mais il y a de forte chance que ce soit ça qui bloque 😉



  • Screech bonjour, J'ai enfin réussi 🙂 j'avais deux problèmes majeurs : 1) le kill d'emulationstation ne marchait pas chez moi par le logiciel mais après l'avoir fait de façon manuelle tout est presque rentré dans l'ordre. les gamelists étaient ok mais pas d'images rattachées 2) le chemin d'accès du dossier images était erroné : par défaut celui qui est indiqué dans ton logiciel est downloaded-images (tiret 6) moi j'avais créé des dossiers downloaded_images (underscore 😎 comme celui que le scrappeur integré avait créé dans mon dossier neogeo Après plusieurs jours d'arrachage de cheveux tout est enfin ok. En tout cas pour ta patience et ton investissement, l'utilisateur lamba que je suis te remercie grandement le bon côté de mes galères c'est que j'aurais appris quelques petits trucs qui me servent à la compréhension générale de la chose



  • bonjour, un nouveau petit problème 🙂 rien n'est trouvé au niveau de mes roms GBA Est-ce normal ou cela vient de mon romset ?



  • C'est effectivement bizarre.. Surtout si ça a marché pour d'autre système. Pourrais tu me donner 1 ou 2 crc32 qui a quand même du se générer dans le fichier XML pour voir s'il existe ou non dans la base de données de screenscraper ? Si ce n'est pas le cas, effectivement, il y a peut être un pb avec ton romset. Sinon, faudrait voir la config (surtout au niveau des chemins :S )



  • Bonjour je comprend pas j'ai été sur le site screenscraper.fr et quand je navigue dessus dans les traductions tout est à 0% ???



  • @Cannasteve Le site screenscraper est toujours en cours de population d'information. Il n'est aujourd'hui pas encore complet. De nombreux bénévoles travaillent dessus sans relâche pour le compléter le plus vite possible. Tu peux aussi participer, il te suffit de créer un compte pour toi aussi alimenter la base de données avec tes connaissances ou, comme moi utiliser le copier/coller pour augmenter la masse d'informations nécessaire au scraper. Pour info voici les stats "actuelles" de Screenscraper :

    • SYSTÈMES : 103
    • JEUX : 70067
    • ROMS : 85788
    • TRUCS & ASTUCES : 4986
    • WHEELS : 11230
    • WHEELS HD : 110
    • SCREENSHOTS : 22461
    • BOITIERS : 5957
    • SUPPORTS : 1460
    • VIDÉOS : 15255
    • THÈMES : 1587
    • MANUELS : 2708

    Plus on sera nombreux à participer, plus cette base sera vite complète 😉 Rejoignez nous... (Oui oui c'est de la pub à peine déguisé 😉 mais c'est aussi pour le bien de recalbox et de ses utilisateur 😉 ) (En plus, je viens de regarder ta copie d'écran et je pense qu'il y a un bug chez toi, ou sur le site, voila ce que j'ai moi pour la supernes par exemple) Heberger image



  • Bonjour, Chez moi rien ne se passe, juste le fichier qui se créé et reste à 0 ko. Une idée ? Merci



  • Merci j'ai testé et finalement le scrapping fonctionne en étant sous windows, par contre je voulais directement pointer les dossier de recalbox dans la configuration UXMLS mais moi je n'ai pas de dossier \RECALBOX\Userdata\roms j'ai que \RECALBOX\roms... de plus je vois des dossiers  gamelist et les downloaded images qui sont dans le dossier /root/.emulationstation  sous Winscp je sais pas si ça joue du coup? Désolé si mes questions peuvent paraitre bête maisje me sens paumé, je connais qu'Hypersin et Rocketlauncher 😛 Au final j'ai tout mis dans le dossier roms du système concerné et je test.



  • Salut, Tout d'abord merci pour le soft, cela à l'air très bien. Malheureusement, il ne me télécharge aucunes images, quelque soit le dossier que je crée et que je lui indique. Il me crée seulement un gamelist, sans infos mais avec le nom des roms. Je possède des romsets connus et j'utilise un disque dur ntfs. Est-ce cela mon problème? Pour ceux, que ca fonctionne, ca vaut le coup? Combien d'émulateurs scrappe t'il complétement? Sachant que j'ai tout scrappé en Anglais. Et que ca ne me dérange pas forcément d'y rester. Merci d'avance.   PS: Cela à l'air simple à utiliser mais je me demande si ca vaut pas le coup d'avoir un tuto complet avec dépannage, infos etc. pour justement éviter ces questions 🙂



  • j'ai réessayer en mettant le fichier xml généré dans: /root/.emulationstation/gamelists/nom du systeme et remplacer celui d'origine mais ca ne marche pas je ne vois pas la description des jeux ni les images d'ailleurs, en parlant des images après le scrapping je les trouve nulle part. Je vois que dans le xml c'est une url de screenzone. J'ai ensuite éditer le XML pour le path des roms en mettant ./ au lieu de \RECALBOX\roms\nom du systeme\ mais rien n'y fait.



  • @Cannasteve C'est bizarre, la seule erreur que je vois, c'est le chemin de substitution des images dans le fichier XML que tu as laissé à vide. En toutes logiques, il faut que tu y mette un chemin correspondant. Par exemple, si tu indique

    \RECALBOX\roms\mastersystem\downloaded-images\

    dans le chemins des images à télécharger, il faut que tu mette dans le chemin des images dans le fichier XML :

    ./downloaded-images/

    Par contre, je vois que tu utilise le profil de la V3 ? (tu devrais passer sur la V4 😉 elle est tellement mieux ^^) @borninthe80s la flèche centrale passe bien en vert ? tu clique dessus et ensuite elle clignote jaune/orange après avoir choisi ton système ? Quand tu dis qu'il reste à zéro, c'est parce que quand tu sélectionne le fichier dans le menu config, il le "pré-créer" à zéro. Si le scrape t'indique 0/XXX Roms trouvées, c'est autre chose 😉 peux tu me mettre la fin de ton fichier config (la partie [LAST_USE]) pour vérifier la config des chemins ? @daveheart s'il ne télécharge aucune images, cela peut venir de plusieurs choses :

    • Les chemins sont ils correct ? (pareil peux tu me mettre la partie [LAST_USE] de ton fichier config que je vérifie tes chemins ?)
    • As tu précisé une taille pour les images ? (à priori, si tu ne précise qu'une taille, genre la largeur maximum, cela ne fonctionne pas. Il faut préciser les 2, j'ai remonté l'anomalie au site screenscraper)
    • Quel System as tu testé ? certains sont vraiment incomplet, au point qu'il n'y a pas bcp d'images, mais ils sont rares...

    Concernant le nombre de roms scrapé en FR, aujourd'hui, screenscraper n'est pas encore complet. Comme je le disais à Cannasteve il est tous jeune (il a ouvert en janvier) et de nombreux contributeur l'alimente tous les jours pour le rendre le plus complet possible le plus vite possible 😉 Mais certains systèmes sont déjà "plein" ou presque (genre les CPS 1,2 et 3 (à 100%), la GBA (à 95%) la Game Gear (à 75%, je bosse dessus ^^) La megadrive (à 88%), La NEOGEO (à 99%), etc...) Il faut par contre, t'assurer de la source de tes ROMs (les set no-intro sont tous référencé par exemple) Attention aussi à une chose, il te créer toujours un fichier gamlist.xml de zéro, fait donc gaffe à pas supprimer ceux que tu as déjà scrapé au cas ou 😉 (c'est prévu pour la suite, de faire une version "Append/Update", mais ce n'est pas encore le cas 😉 ) Ah oui, dernier détails, assurez vous bien d'avoir la dernière version 😉 Version 1.0.0.5 (des petits bug découvert à droite à gauche son corrigé régulièrement 😉 )



  • Non la flèche ne change pas de couleur, et il ne se passe rien.



  • Merci screech pour les infos et les astuces.  Je continue mes tests, je te tiens au jus dès que je trouve le pourquoi du comment. 🙂



Want to support us ?

224
Online

77.2k
Users

19.4k
Topics

144.0k
Posts