Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[SOFT] Universal XML Scraper - Scrappez vos roms depuis Windows (Scrape your roms from Windows)



  • @David je viens de refaire des tests, ça fonctionne (Nes y compris).
    Vérifie les éléments suivant :

    • Si tu fait une modif dans le fichier config, pense bien a redémarrer le soft.
    • Tu choisis bien le profil que tu as modifié ?

    Au pire, envois moi ton fichier config, je ferais la modif et te le renverrais ;)



  • Plop alors j'ai testé les boite 3D et pareille, ça me met les Screen ... Par contre si je met ceci : $ELEMENT_11 = 'image|value|medias/media_boxs/media_boxs3d/media_box3d_fr|path:image' $ELEMENT_12 = 'image|value|medias/media_boxs/media_boxs3d/media_box3d_eu|path:image' $ELEMENT_13 = 'image|value|medias/media_boxs/media_boxs3d/media_box3d_us|path:image' $ELEMENT_14 = 'image|value|medias/media_boxs/media_boxs3d/media_box3d_jp|path:image' $ELEMENT_15 = 'image|value|medias/media_boxs/media_boxs3d/media_box3d_fr|path:image' Ça marche mais certaines images ne se téléchargent pas complétement, jamais eu ce problème sur les 2D.



  • Chez moi ça fonctionne je viens de tester



  • @Luckiest tu as bien téléchargé la dernière version ?
    Parce que j'ai eu une version qui faisait ça.
    En fait au moment de télécharger une nouvelle image, le soft vérifie si elle existe déjà.
    Si c'est le cas il ne la retelecharge pas (en gros si tu as un box3D_fr, il ne téléchargera pas par dessus une box3D_eu, etc...)

    En fait, sur une ancienne version, (la 1.0.0.1 il me semble) si l'image n’était pas finit de téléchargé, il considérait que le fichier n'existait pas et retelecharger la nouvelle (du coup avec le screenshot en dernier, il téléchargeait plusieurs box pour finir par les écraser par le screenshot :S)
    Du coup, maintenant je créer un fichier à blanc avant de lancer le dl... et çà sa marche sur la 1.0.0.2 ;)



  • Euh ... oui, tu va plus vite que mes tests lol ^^ Je testerai la 1.0.0.2 ce soir, désolé !!!



  • Bonjour à tous ! Félicitations à Screech pour le logiciel c'est super ! Meme si pour moi ça ne marche pas je pige pas pourquoi... je pense avoir tout bien paramétrer (profil v4, chemins.. etc) j'ai la fleche verte je choisis le système mais il ne scrape rien j'ai une fenetre "scrape terminé, nombre de roms 0/-1" J'ai fait, refait et rerefait les manips mais rien... J'ai oublié quelque chose d'évident ? Merci d'avance pour votre aide !



  • Peux tu poster ton fichier config ini (ou au moin la fin, la partie [LAST_USE] ) histoire que je verifie tes chemins. sinon, tu as un fichier logs.txt maintenant qui pourra m'aider à determiner pourquoi il ne trouve aucune Rom ;)



  • voila le fichier Ini et le fichier log ! Merci !


  • Staff
    Moderator
    Team

    Salut tu as mis une taille pour les images non ?

    $HauteurImage=500
    $LargeurImage=500
    

    c'est surement ça le problème peut être ?



  • En fait j'en ai mis une quand j'ai vu que ça marchait pas ;)



  • @n0arc tes roms sont bien en zip ?
    Parce que le scraper ne trouve rien dans ton répertoire NES.
    Le site screenscraper qui fournit les informations et les images ne peut reconnaître tes roms que si elles sont zippées (ou 7zippées) et qu’elles proviennent d’un set connu (No-Intro, FullSet, Tosec, retrobution,…).
    A priori, (hormis pour la N64) le fait que les roms soient zippées ne pose aucun problème à Recalbox.

    (Attention aussi, si tu rezipe une rom dézipé, il est possible que cela change le Hash en fonction des paramètres de compression.)



  • Plop tous le monde, Bon c'est nikel Screech,  sauf pour les 3D mais bon au final je préfère "screenshot" pour lequel aucun probleme. En fait, dés que je passe par les 3D j'ai pas mal d'erreur sur les fichiers ".png". Dans l’aperçu windows, elle ne sont pas complète (environ 20-30%), et quand je veux ouvrir l'image il m'indique fichier corrompu ... c'est bizarre ... Voili, voilou Luckiest



  • Je vais refaire des tests ;) je vous tiens au courant (les boîtiers sont "plus gros" que les screenshots en règles générale. Du coup ça pose peut être des problèmes...)



  • Salut Screech je viens te remonter un problème qui m'arrive (pour une fois) :))))) Alors je viens de remarquer que lorsque je lance une gamelist en mettant screenshoot en première ligne tout es impeccable et fonctionnelle par contre lorsque par exemple je change la ligne pour vouloir mette  boîtier 2d la tout le cycle se passe bien elles sont bien dans le.dossier images  mais invisible sur ma gamelist? C'est comme si pour ma part ma gamelist accepté juste les screenshoot A voir si pour d autres c est pareil


  • Staff
    Moderator
    Team

    J essaie de faire fonctionner le soft , beau boulot Screech. Cependant quelques remarques : - ça serait bien davoir un scrap qui scranne tous les dossiers sans devoir chercher les dossiers un à un. - Je m attendais apres avoir séléctionner le profil que la fenetre de configuration s ouvre puis qu on doit configurer les chemins des différents répertoires. - le fichier log ça serait bien d'avoir une séparation entre les trouver et les non trouvés car ce qui nous intéresse le plus ce sont celle qui n ont pas été trouvé.



  • Effectivement elles ne sont pas zippées... quel c** ! Merci de ton aide !   Edit: effectivement le hash change si je les rezippe.... j'ai pas envie de tout retélécharger donc je vais scraper autrement !



  • salut à tous, J'essaie de faire fonctionner le soft, mais il ne reconnait aucune rom... J'ai parcouru le topic, et j'ai bien vérifié : - que mes roms sont en .zip - qu'elles viennent d'une source a priori connue (ici, no-intro, version 2016-01-03... et les md5 des zip correspondent à la db de screenscraper) Voilà le débug du log du scraping des jeux snes :

    Universal XML Scraper [BETA 1.0.0.2] Démarrage le 13/03/16 - 20:51:00 [20:51:00] - Langue Séléctionnée : 040c [20:51:00] - Récupération des Profil [20:51:29] - Modification de la config : [20:51:29] - PathRom : \RECALBOX\User data\roms\snes [20:51:29] - PathRomSub : ./ [20:51:29] - PathNew : \RECALBOX\User data\roms\snes\gamelist.xml [20:51:29] - PathImage : \recalbox\User data\roms\snes\img [20:51:29] - PathImageSub : \recalbox\User data\roms\snes\img [20:51:29] - HauteurImage : 500 [20:51:29] - LargeurImage : 500 [20:51:58] - Modification de la config : [20:51:58] - PathRom : \RECALBOX\User data\roms\snes [20:51:58] - PathRomSub : ./ [20:51:58] - PathNew : \RECALBOX\User data\roms\snes\gamelist.xml [20:51:58] - PathImage : \recalbox\User data\roms\snes\img [20:51:58] - PathImageSub : \recalbox\User data\roms\snes\img [20:51:58] - HauteurImage : [20:51:58] - LargeurImage : [20:52:00] - Récupération des informations des systemes [20:52:09] - Systeme séléctionné : Super Nintendo [20:52:09] - Nombre de roms trouvées : 555 [20:52:09] - Calcul des Hash [20:52:18] - Fin de Calcul des Hash en : 8.82s [20:52:18] - Récupération des Profil [20:52:18] - Récupération des champs du profil [20:52:18] - Récupération des informations de la Rom n° 1 [20:52:19] - Fin de l'écriture des informations de la Rom n° 1 en 0.942s [20:52:19] - ()Rom non trouvé : carrier aces (europe).zip [20:52:19] - Récupération des informations de la Rom n° 2 [20:52:20] - Fin de l'écriture des informations de la Rom n° 2 en 0.745s [20:52:20] - ()Rom non trouvé : pirates of dark water, the (europe).zip

    des idées ? (PS : RPi2 & version v4.0.0-beta2 ) edit : ajout d'un screen d'un check md5 sur la 1ere rom de la liste (visible dans le log)



  • Le seul truc que je vois d'anormal :
    [20:51:58] – PathRom : \RECALBOX\User data\roms\snes
    [20:51:58] – PathRomSub : ./ [20:51:58] – PathNew : \RECALBOX\User data\roms\snes\gamelist.xml
    [20:51:58] – PathImage : \recalbox\User data\roms\snes\img
    [20:51:58] – PathImageSub : \recalbox\User data\roms\snes\img

    Il manque les "" de fin de répertoire pour le PathRom et le PathImage et je te conseil de ne mettre que "./img/" dans le PathImageSub sinon la recalbox risque de ne pas trouver tes images.

    Je vais essayer de faire une correction pour les \ de fin de répertoire, à priori, ça provoque quand même pas mal de retour ;) faut que je trouve un truc ;)



  • Merci pour ta réponse rapide, je teste ça ce soir :) Ah et petit commentaire : mettre tes 2 softs (le scraper et le cleaner) dans le même dossier ça fait n'importe quoi (même noms de fichiers/dossiers), donc si jamais c'est possible techniquement (et que tu as le temps bien sûr), ça serait peut-être pas mal de changer les noms ;)



  • Effectivement ;) surtout que le but, à terme est de créer une collection de soft ;) Je vais voir ça pour avoir des noms uniques ;) (Mais la je suis en train de me battre avec GITHUB pour comprendre comme ça marche :S)



Want to support us ?

239
Online

61605
Users

18634
Topics

140018
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.