Refresh rate issue on NUC with Recalbox 7.1.1

  • Hello,

    I already had the same issue with Recalbox 7.0, but it was fixed with the 7.1 version (I didn't really search for a fix at this time). The issue comes back with the 7.1.1 version.

    When I play with emulators (Snes, Genesis, PC engine...): I have sound glitches and the command don't respond correctly... I discovered that the vertical refresh rate is set to 60Hz, but the reported display refresh rate is set to 50hz.


    With the previous version I have this and all is working perfectly:


    I try to find a fix and discovered that it's related to the screen detection, but I did not find the way to set the it correctly.

    The xandr report give me this:

    Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
    DP1 disconnected primary (normal left inverted right x axis y axis)
    HDMI1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 820mm x 460mm
       1920x1080     50.00*+  60.00    59.94    24.00    23.98
       1920x1080i    60.00    50.00    59.94
       1600x1200     60.00
       2880x576      50.00
       2880x576i     50.00
       1400x1050     59.95
       2880x480      60.00    59.94
       2880x480i     60.00    59.94
       1280x1024     60.02
       1280x720      60.00    50.00    59.94
       1440x576      50.00
       1024x768      75.03    70.07    60.00
       1440x480      60.00    59.94
       800x600       72.19    75.00    60.32    56.25
       720x576       50.00
       720x576i      50.00
       720x480       60.00    59.94
       720x480i      60.00    59.94
       640x480       75.00    72.81    60.00    59.94
       720x400       70.08
    HDMI2 disconnected (normal left inverted right x axis y axis)
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)

    And if I run the following command, the settings are ok:

    xrandr -r 60

    I tried to add this setting in the recalbox.conf with no success:

    global.videomode = CEA 16 HDMI

    If anybody can help me to fix this 🙂

    My system:

    • Recalbox 7.1.1 X64
    • PC/NUC Model : CORE I3-4010U HD 4400 4Go (NUC D34010WYK)
    • USB Key SanDisk UltraFit

    Thanks for your help.

  • Try to edit /etc/X11/xinit/xinitrc file and in a new line, add your xrandr command.

  • I have updated the xinitrc file but it does not fix the issue.

    I also changed the /usr/bin/ call by removing the '&' to be sure that the script has ended when the new xrandr command starts.

  • I move the xrand line from the end of the file to the next line after the externalscreen script call and now it works 🙂

    #/usr/bin/ &
    xrandr -r 60

    Thank you for your help 🙂

Want to support us ?