7.0.1 Toujours problème avec Nespi4case ventilateur ne s'éteint pas



  • @shamael_1 said in 7.0.1 Toujours problème avec Nespi4case ventilateur ne s'éteint pas:

    @Zeke le fait que ce ne tienne qu'un reboot sonne comme des modifications faites via le script sur une partiton read only. Par contre les scripts existent de base et en fait mis à part pour test (ce que j'avais fais plus haut) ils ne sont pas nécessaire.

    Je résume pour être sur du statu actuel:

    • recalbox.conf: tu as bien décommenté la ligne ci-dessous, c'est cénsé être auto mais soit
    system.power.switch=PIN356ONOFFRESET
    

    A ce stade tu peux éteindre et reset avec les boutons en facade normalement. Les scripts appelés sont dans /opt/RetroFlag

    • config.txt: si le fan continue à tourner la modif suivante à permi de contourner le soucis pour certains d'entres-nous:
    mount -o remount,rw /boot
    echo "# Overlay setup for proper powercut, needed for Retroflag cases" >> /boot/config.txt
    echo "dtoverlay=gpio-poweroff,gpiopin=4,active_low=1,input=1" >> /boot/config.txt
    shutdown -r now
    

    Cette manip est permanente et résoud le problème de manière définitive pour moi en tous les cas.

    Ces deux étapes ont été appliquée pour ton cas?

    Salut !
    Pour suivis : la méthode de @shamael_1 ci-dessus a parfaitement fonctionnée dans mon cas.
    Mon cas de figure initial : bouton ON/OFF fonctionnel dès l'installation, mais le ventilo continuait de tourner après usage de ce dernier. Pas de ligne décommenté dans le recalbox.conf au sujet de "system.power.switch", donc j'ai décommenté celle indiquée. Après le reboot du "shutdown -r now" tout semble OK 🙂 (et après plusieurs reboot, ça semble bien persistant ^^).
    Merci à vous !



  • Petit retour sur mon expérience personnelle :

    J'avais le même soucis sur mon boitier a savoir, LED qui a un comportement aléatoire et ventilateur qui continu de tourner à l'arrêt de la machine.

    Mettre le switch interne safe shutdown sur OFF a réglé le problème dans mon cas.

    Est ce qu'il s'agit d'une inversion du switch ? j'ai cru comprendre qu'il fallait le mettre sur ON normalement.



  • Bonjour.
    Avez vous trouvé une solution ?.
    Je n'y pipe rien a linux lol.

    Une fois que j' allume le Nespi Case (Bouton power enfoncé) lorsque je sélectionne "quitter" dans le menu Recalbox, l'OS s' éteint, il me suffit ensuite d' appuyer sur le bouton power du NESPI pour le remettre en position et le ventilateur s' éteint.

    Par contre, si j' éteint directement par le bouton Power, l' OS s' éteint mais pas le ventilo. Il me faut dans ce cas la rappuyer sur le bouton Power et le ventilo s' éteint.

    C' est le fonctionnement normal ou alors il faut que tout s' éteingne (OS et ventilo) si l' on appui sur le bouton Power ?
    Merci.



  • @SimonC Attention, en faisant cela, je pense que ton OS s' arrête brutalement comme si tu arrêtais ton ordi brutalement ton PC. Cela risque de corrompre ton OS Recalbox.



  • This post is deleted!


  • @Alexandre-M C'est le comportement qu'on cherche à éviter dans ce topic. Appuyer sur le bouton power doit lancer un script qui éteint RB, Linux, et enfin l'alimentation du RPI et du ventilo.

    Je t'invite à suivre ma procédure plus haut il suffit de se connecter en SSH et de faire copy/past de chaque ligne avec la touche entrée pour exécution à chaque fois
    Se connecter en SSH: lance une invite de commande et tape "ssh root@recalbox.local". Le mot de passe est dans la doc.

    Si ça ne te parle pas, continue à éteindre RB via le menu et ca ira très bien. Ce topic est surtout pour obtenir ce que le nespi5case permet normalement: utiliser les 2 boutons en facade sans autre action



  • @Alexandre-M une piste potentielle (au cas ou, je n'ai pas de nespicase...): j'ai remarqué qu'avec l'alim officielle du PI3 + un HDMI branché, en ne coupant qu'un des fils 220V (sans doute le neutre), il restait une tension résiduelle sur le PI. Je pense qu'elle est crée par la mise au potentiel de la masse mécanique de mon ampli.
    Dans mon cas, elle est suffisante pour relancer la LED que j'ai installée en face avant pendant quelques secondes, le temps que le PI démarre, vide la capa, et ça recommence. Si votre ventilo ne tire pas trop de courant, il est possible que ce comportement permette son alimentation en permanence....

    J'ai résolu (temporairement) le problème en inversant la prise 220V (de cette façon, la phase est coupée, et la tension résiduelle est trop faible pour alimenter quoi que ce soit).
    Tentez donc d'inverser les pôle de votre prise 220V dans la prise murale, juste pour voir... Aucune garantie, mais qui ne tente rien...



  • @shamael_1
    Bonjour.
    Je reviens aux nouvelles pour faire un retour d' expérience:

    1. Lorsque j' éteignais le NESPI par le menu recalbox, l' OS s'éteignait mais pas le ventilateur. Il suffisait alors que je repousse l' inter en position off et le ventilateur s' éteignait (normal).

    2. Si j' éteignais le NESPI directement avec l' inter, l' OS s' éteignait mais pas le ventilateur. Pour l' éteindre, il fallait que je rallume le NESPI et dés la première lumière rouge je rappuyais sur le bouton power.

    J' avais au préalable fait la manip donnée dans le manuel du NESPI qui n' avait rien donnée.
    J' ai donc tenté en premier de modifier le fichier "recalbox.conf" par la ligne :

    system.power.switch=PIN356ONOFFRESET 
    

    mais cela n' a rien changé.
    J' ai donc fait la manip en rajoutant les trois lignes :

    mount -o remount,rw /boot
    echo "# Overlay setup for proper powercut, needed for Retroflag cases" >> /boot/config.txt
    echo "dtoverlay=gpio-poweroff,gpiopin=4,active_low=1,input=1" >> /boot/config.txt
    shutdown -r now
    

    en passant par SSH et pas comme moi qui a voulu tenter en passant directement par une distri Linux et la *ça fonctionne parfaitement avec l' inter ON/OFF et comme avant lorsque je passe par le menu recalbox.

    Un grand merci a toi et bien sur aux autres qui m'ont aiguillés.

    PS: Faudra juste que je pense à refaire la manip à chaque fois que je réinstallerai une nouvelle version.


  • Staff
    Global moderator
    Team

    Normalement le problème est réglé pr ceux qui refont une installation propre.



  • La 7.1 n'a pas réglé le problème chez moi, même après une installation fraiche.

    Switch "safe" du boitier sur on, j'éteins la recalbox en appuyant sur le bouton power, le ventilateur continue de tourner


  • Staff
    Global moderator
    Team

    @SimonC said in 7.0.1 Toujours problème avec Nespi4case ventilateur ne s'éteint pas:

    La 7.1 n'a pas réglé le problème chez moi, même après une installation fraiche.

    Switch "safe" du boitier sur on, j'éteins la recalbox en appuyant sur le bouton power, le ventilateur continue de tourner

    et si tu met le switch sur off ? pareil ? si tu es sur support amovible tu as aussi réinitialiser le dossier recalbox ?
    si non tu utilises d'anciens fichiers systemes- A faire.



  • Je viens de ressortir mon boitier nespi4case et c'est pareil
    Le ventilo ne s'arrête pas lorsque j'éteint le boitier avec le bouton on/off

    Réinstallation refaite avec carte sd neuve.

    Cette mise à jour a-t-elle été testée avec le nespi4case?



  • Je précise,avec ou sans le ; décommenté c'est pareil.



  • @acris
    Testé sur la carte micro SD après réinstallation fraiche de la 7.1

    J'obtiens le comportement voulu en exécutant les 4 lignes dans SSH (merci shamael pour les explications, c'est pas du tout user friendly comme manip, surtout la partie ou tu dois taper le password et que rien ne s'affiche à l'écran...)



  • @acris Alors dans ce cas la c' est top.
    Merci à l' équipe.
    Je me garde la manip sous le coude au cas ou un jour, je puisse en avoir besoin.


  • Staff
    Global moderator
    Team

    normalement les manipulations pour ce boitier ne devrait pas être fait, ce boitier est géré par recalbox.



  • @acris Et il l'est. De base les logs montrent sa détection et les scripts sont bien intégrés. Les boutons en façade sont d'ailleurs fonctionnels, ce qui n'est pas le cas sans les scripts. La seul différence est la coupure de l'alim du fan via une ligne en plus. Différence trouvée via un autre script que j'avais tenté plus haut.
    La version 7.1 mentionne une meilleure détection dans le change log mais pour mon cas et ceux qui qui la modif à marché la détection n'a jamais été le soucis en d'autres termes 🙂


  • Staff
    Global moderator
    Team

    tu as cette ligne ? désolé migraine pas le courage de tout relire.
    on va faire l intégration si jamais de ce qui est manquant pour la post 7.1.1

    c'est cette ligne @shamael_1 ?

    mount -o remount,rw /boot
    echo "# Overlay setup for proper powercut, needed for Retroflag cases" >> /boot/config.txt
    echo "dtoverlay=gpio-poweroff,gpiopin=4,active_low=1,input=1" >> /boot/config.txt
    shutdown -r now
    

    J'ai remonté l information.
    je t'encourage à ouvrir une issue sur https://gitlab.com/groups/recalbox/-/issues



  • @acris C'est exactement ca oui, je check pour la partie issue

    Egalement dans la partie shutdown on remarque que les disques externes ne sont pas démonter proprement. Un fsck le signal sauf à faire le shutdown en SSH.

    Je viens de mettre à jour en 7.1 et par contre j'ai l'impression que le shutdown s'est fait sans script mais d'un coup. Je vais retester. D'habitude j'ai le temp de voir la partie poweroff



  • @shamael_1 je me corrige, pas de soucis pour la partie shutdown qui est bien executée avec un logo Recalbox en prime.



Want to support us ?

324
Online

82.0k
Users

22.5k
Topics

163.0k
Posts