v7.0 Audio problem "audio.device=Default output"



  • Hello,

    Since version 7.0, I have a problem with the sound from a raspberry pi 3 jack.

    On each reboot, the audio settings of 'recalbox.conf' changes.
    the line:

    audio.device=jack
    

    by

    audio.device=Default output
    

    At this point the audio dont works and I am forced to replace by hand "Default output" by "jack".

    According to the log something is wrong with 'amixer' and access :

    [        7.23] starting new log
    [        7.24] converting dos to unix carriage return characters
    [        7.30] setting keyboard layout to fr
    [        7.30] setting audio volume to 90
    [        7.31] setting timezone to Europe/Paris
    [        7.31] setting hostname to RECALBOX
    [        7.33] enabling mk_arcade_joystick_rpi
    [        7.35] ---- recalbox-config.sh ----
    [        7.36] ---- recalbox-config.sh ----
    [        7.38] setting audio volume : 90
    [        7.38] rmmod: can't unload module 'mk_arcade_joystick_rpi': No such file or directory
    [        7.33] Simple mixer control 'PCM',0
    [        7.33]   Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    [        7.33]   Playback channels: Mono
    [        7.33]   Limits: Playback -10239 - 400
    [        7.33]   Mono: Playback -662 [90%] [-6.62dB] [on]
    [        7.39]
    [        7.40] : loading module mk_arcade_joystick_rpi args = map=1,2  
    [        7.46] Setting volume for numid=3
    [        7.48] Setting volume for numid=2
    [        7.49] Setting volume for numid=1
    [        7.51] Setting volume for numid=5
    [        7.33] amixer: Control default element write error: Operation not permitted
    [        7.33] 
    [        7.52] Setting volume for numid=4
    [        7.55] Force unmute on HDMI
    [        7.33] amixer: Control default element write error: Operation not permitted
    [        7.33] 
    [        7.56] Force unmute on HDMI
    [        7.58] Restoring audio configuration
    [        7.60] setting audio to Default output
    [        7.62] ---- recalbox-config.sh ----
    [        7.64] Unknown audio format : Default
    [       15.66] starting xarcade2jstick
    [       16.25] xarcade2jstick : no official stick found, looking for keyboard encoder now ...
    [       17.79] starting emulationstation with lang = fr_FR
    [       17.84] emulationstation-starter started
    [       17.85] started emulationstation (pid=917)
    [       17.91] S32mini TFT : Reading system.secondminitft.enabled => 0
    [       17.94] S32miniTFT not enabled
    [       17.97] ---- recalbox-config.sh ----
    [       19.17] Starting S92switch
    [       19.17] script /recalbox/scripts/powerswitch.sh [ STARTED ]
    [       19.29] Starting S94manager
    [       19.30] ... Starting manager v2
    [       65.04] ---- recalbox-config.sh ----
    [       65.11] recalbox.conf saved to /boot partition
    [      184.20] Stopping S94manager
    [      184.34] Stopping S92switch
    [      184.35] script /recalbox/scripts/powerswitch.sh already stopped !
    [      184.36] emulationstation exited code 0
    [      184.37] emulationstation-starter ended
    [      184.66] S32mini TFT : Reading system.secondminitft.enabled => 0
    [      184.68] S32miniTFT not enabled
    [      184.79] Stopping Emulationstation
    [      185.01] Stopping S13fbcp
    [      185.10] recalbox.conf saved to /boot partition
    

    Best regards


  • Staff
    Developer
    Global moderator
    Creator
    Team

    @ElFilipe This bug has been reported an is fixed on 7.01 with comes tomorrow... be patient 😄 until there



  • @ian57 Merci beaucoup !



  • @ian57 hello there 😉
    i am using latest version 7.0.1...And still the issue with audio.device=Default output
    Do you have any clues ?



  • @leroms77 said in v7.0 Audio problem "audio.device=Default output":

    @ian57 hello there 😉
    i am using latest version 7.0.1...And still the issue with audio.device=Default output
    Do you have any clues ?

    PS: I have used recalbox-config.sh audio and it worked 🙂



Want to support us ?

152
Online

80.3k
Users

21.5k
Topics

157.3k
Posts