Mando NES30 PRO de 8BITDO.



  • @sad1942 probare esto que me dices ahora mismo de verdad que eres un crack y me ha servido de mucho 🙂 si descubro algo de los joystick analogicos te comento 🙂 Muchas gracias de nuevo por el tiempo



  • Desde donde has modificado el fichero?, ami no me guarda los cambios, Estoy probando directamente desde el pc en bloc de notas, es asi como lo has hecho tu?

    Un saludo



  • Yo le he hecho con el wordpad.
    Yo lo he hecho en red guardando los cambios directamente en recalbox, quizás a ti no te los guarda porque a lo mejor tienes protección contra escritura o no lo haces como administrador.
    prueba a hacer una copia del fichero en el escritorio y lo modificas en el pc, después borras el fichero en recalbox y copias el que tienes en el escritorio.
    A ver si así te deja modificarlo.



  • lo tengo ya modificado y noto que recalbox me deja de reconocer los botones cuando lo borro y que vuelve a reconocerme cuando meto los datos nuevos pero nada sigue sin funcionar... en cuanto lo meto directamente en un juego me lo desconecta...



  • Tu mando es el NES30 PRO?
    Tienes que borrar todos los mandos de la memoria de Emulation Station, luego tienes que volver a emparejar el mando por bluetooth y después tienes que modificar el fichero.
    Hazlo en ese orden a ver.



  • en ese orden exacto hice
    primero borre todo lo del fichero dejandolo vacio.

    Seguido vincule mi mando por bluetooth (sin configurarlo)

    Y por ultimo meti la configuracion con los botones que me has pasado y funciona perfecto en menu y todo pero en el juego nada tengo que apagar y encender... no ha cambiado nada..



  • No hace falta que borres todo lo del fichero, simplemente modificar la parte relacionada con ese mando.
    Recuerda que primero tienes que desvincular todos los mandos.
    De todas maneras te podría enviar una copia de mi fichero, pero no se como.



  • Si nose, creo que con lo que me has mandado esta bien, acabo de ver que mi mando en NES30 PRO 2 pero vamos no creo que sea un problema para configurar esto porque me funciona y el numero de botones es el mismo y todo...



  • Nada por mas que he intentado no soy capaz de no tener que apagar y encender los mandos para poder jugar... nose si al ser la version 2 me puede dar otro problema diferente o lo que sea, y el tema de los joystick analogicos en psx tambien imposible me funciona fatal retroarch para cambiar controles..

    Gracias de todas formas pero sigo igual jajajaja estoy por rendirme ya xD



  • Sin título.png

    Prueba desde el principio y cuando tengas emparejado tu mando por bluetooth deja lo que está en el circulo rojo y modifica solo lo que está debajo.
    los datos del circulo rojo son los de tu mando, eso no lo tienes que modificar



  • si no mándame una pantallazo de tu confuguración



  • @sad1942 ahora mismo tengo esto en mi archivo de configuracion En el que tengo solo el teclado inalambrico y el mando.

    <?xml version="1.0"?>
    <inputList>
    <inputConfig type="keyboard" deviceName="Keyboard" deviceGUID="-1" deviceNbAxes="0" deviceNbHats="0" deviceNbButtons="120">
    <input name="a" type="key" id="115" value="1" code="168" />
    <input name="b" type="key" id="97" value="1" code="168" />
    <input name="down" type="key" id="1073741905" value="1" code="168" />
    <input name="hotkey" type="key" id="32" value="1" code="168" />
    <input name="left" type="key" id="1073741904" value="1" code="168" />
    <input name="pagedown" type="key" id="1073741902" value="1" code="168" />
    <input name="pageup" type="key" id="1073741899" value="1" code="168" />
    <input name="right" type="key" id="1073741903" value="1" code="168" />
    <input name="select" type="key" id="32" value="1" code="168" />
    <input name="start" type="key" id="13" value="1" code="168" />
    <input name="up" type="key" id="1073741906" value="1" code="168" />
    </inputConfig>
    <inputConfig type="joystick" deviceName="8BitDo N30 Pro 2" deviceGUID="05000000c82d00006528000000010000" deviceNbAxes="6" deviceNbHats="1" deviceNbButtons="16">
    <input name="a" type="button" id="0" value="1" code="304" />
    <input name="b" type="button" id="1" value="1" code="305" />
    <input name="down" type="hat" id="0" value="4" code="16" />
    <input name="hotkey" type="button" id="2" value="1" code="306" />
    <input name="joystick1left" type="axis" id="0" value="-1" code="0" />
    <input name="joystick1up" type="axis" id="1" value="-1" code="1" />
    <input name="joystick2left" type="axis" id="2" value="-1" code="2" />
    <input name="joystick2up" type="axis" id="3" value="-1" code="5" />
    <input name="l2" type="axis" id="5" value="-1" code="10" />
    <input name="l3" type="axis" id="0" value="1" code="0" />
    <input name="left" type="hat" id="0" value="8" code="16" />
    <input name="pagedown" type="button" id="7" value="1" code="311" />
    <input name="pageup" type="button" id="6" value="1" code="310" />
    <input name="r2" type="axis" id="4" value="-1" code="9" />
    <input name="r3" type="button" id="14" value="1" code="318" />
    <input name="right" type="hat" id="0" value="2" code="16" />
    <input name="select" type="button" id="10" value="1" code="314" />
    <input name="start" type="button" id="11" value="1" code="315" />
    <input name="up" type="hat" id="0" value="1" code="16" />
    <input name="x" type="button" id="3" value="1" code="307" />
    <input name="y" type="button" id="4" value="1" code="308" />
    </inputConfig>
    </inputList>



  • Ok.
    Prueba esto.
    Borra todo lo de tu fichero es_input.cfg y copia esto que te mando.

    <?xml version="1.0"?>
    <inputList>
    <!-- Keyboard -->
    <inputConfig type="keyboard" deviceName="Keyboard" deviceGUID="-1" deviceNbAxes="0" deviceNbHats="0" deviceNbButtons="120">
    <input name="a" type="key" id="115" value="1" code="168" />
    <input name="b" type="key" id="97" value="1" code="168" />
    <input name="down" type="key" id="1073741905" value="1" code="168" />
    <input name="hotkey" type="key" id="32" value="1" code="168" />
    <input name="left" type="key" id="1073741904" value="1" code="168" />
    <input name="pagedown" type="key" id="1073741902" value="1" code="168" />
    <input name="pageup" type="key" id="1073741899" value="1" code="168" />
    <input name="right" type="key" id="1073741903" value="1" code="168" />
    <input name="select" type="key" id="32" value="1" code="168" />
    <input name="start" type="key" id="13" value="1" code="168" />
    <input name="up" type="key" id="1073741906" value="1" code="168" />
    </inputConfig>
    <!-- Nes30 Pro 2 BT -->
    <inputConfig type="joystick" deviceName="8BitDo N30 Pro 2" deviceGUID="05000000c82d00006528000000010000" deviceNbAxes="6" deviceNbHats="1" deviceNbButtons="16">
    <input name="a" type="button" id="0" value="1" code="304" />
    <input name="b" type="button" id="1" value="1" code="305" />
    <input name="down" type="hat" id="0" value="4" code="16" />
    <input name="hotkey" type="button" id="10" value="1" code="314" />
    <input name="joystick1left" type="axis" id="0" value="-1" code="0" />
    <input name="joystick1up" type="axis" id="1" value="-1" code="1" />
    <input name="joystick2left" type="axis" id="2" value="-1" code="2" />
    <input name="joystick2up" type="axis" id="3" value="-1" code="5" />
    <input name="l2" type="button" id="8" value="1" code="312" />
    <input name="l3" type="button" id="13" value="1" code="317" />
    <input name="left" type="hat" id="0" value="8" code="16" />
    <input name="pagedown" type="button" id="7" value="1" code="311" />
    <input name="pageup" type="button" id="6" value="1" code="310" />
    <input name="r2" type="button" id="9" value="1" code="313" />
    <input name="r3" type="button" id="14" value="1" code="318" />
    <input name="right" type="hat" id="0" value="2" code="16" />
    <input name="select" type="button" id="10" value="1" code="314" />
    <input name="start" type="button" id="11" value="1" code="315" />
    <input name="up" type="hat" id="0" value="1" code="16" />
    <input name="x" type="button" id="3" value="1" code="307" />
    <input name="y" type="button" id="4" value="1" code="308" />
    </inputConfig>
    </inputList>



  • Uoooo ahora va perfecto eres un maquina :)))) me faltaba esta linea verdad?

    <!-- Nes30 Pro 2 BT -->

    Y solucionado el tema shaders como comentabas muchisimas gracias de verdad me traia loco xD

    Un saludo y muchas gracias por tu paciencia y ayudarme 🙂



  • No estoy seguro de que el problema fuera la linea <!-- Nes30 Pro 2 BT -->, creo que mas bien sería algún valor de los botones.
    En la última actualización de Recalbox hay algo que hace que el fichero es_input.cfg no se cree correctamente.
    De todos modos me alegro de que te funcione. Ha sido un placer haberte podido ayudar. 🙂

    Saludos



  • Un placer ati por ser tan amable 🙂



Want to support us ?

454
Online

79.9k
Users

21.2k
Topics

155.1k
Posts