Controller works in ES but not in games

  • My setup:
    Rpi 3B+
    Original Power Supply
    RB v6.1.1
    SanDisk Exteme 16GB
    USB: Retroflag Classic USB
    BT: 8BitDo M30 / 8BitDo N30 Pro 2 / Sony PS4

    Full log:

    Steps to reproduce:

    1. Clean install;
    2. Plug and configure Retroflag Classic USB;
    3. Pair and configure any other BT controller (8BitDo or PS4);
    4. Launch any game (console or arcade) and controllers will work only after re-connection (USB or BT).


    1. If set only one controller, BT (using a keyboard) or USB this doesn't happen. It seems some issue when setting more than one controller;
    2. The ES menu works fine, with one ore more controllers. The issue seems to be related with some messed configuration in RetroArch after setting more than one controller;
    3. I have tried to forget the BT controllers and configure it again with no success;
    4. Also tried to assign the controllers for P1, P2... with no success.

  • Global moderator Translator
    Translation Master
    Global moderator

  • @Zing these links are pointing to BT issues, in my case the connection is fine and stable, the controllers are working in ES. The problem is that after launching games it doesn't work, so I need to powercycle the controller to fix it. Thanks anyway!
    Trying the same setup with RetroPie it's working perfectly, but I prefer the Recalbox, so I'll keep trying to solve it.

  • Staff
    Global moderator

    @loula do both controllers stop working when in-game or just the bluetooth? Because if that only happens wirh the nluetooth controller, it might just be that you are using the wrong pairing mode. With an usb controller that should definitelly not happen (assuming that controller isn't player 2 as many games can only be controlled with player 1).

  • @paradadf both, I thought that it was a BT connection issue, but it's not. It seems that when I plug more than one controller the RetroArch configuration is messed up. Luckily I have two rpi's, so I'm using retropie in the other one with no issue. Someone may ask me to change the rpi and sd card's, I tried these things already.

  • Staff
    Global moderator

    @loula could you try on a clean installation? Something might have gotten messed up in the way. Otherwise I’d just suggest to wait a bit for the v7 to test again.

  • @paradadf I have tried several things already including a clean installation. Clearly seems something with RetroArch configuration, considering that the controllers are working fine in ES. If I do power cycle the BT controller when game is loaded it works. I'll wait v7, thanks a lot anyway!

Log in to reply

Want to support us ?