Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Custom GPIO Map funktioniert nicht bei Joy-IT Gamestation



  • Moinsen,
    ich bin neu hier und grüße alle, die hier unterwegs sind!

    Ich bin im Besitz einer Joy-It Gamestation. Die kommt von Haus aus mit Retropie, aber ich wollte einfach mal Recalbox ausprobieren. Leider bekomme ich die Tasten nicht in den Griff und vielleicht hat ja jemand einen Tipp für mich. Wenn ich das richtig verstanden habe, muss ich in der recalbox.config folgendes einschalten:

    controllers.gpio.enabled=1

    Dann muss ich ein Custom map anlegen, was ich mit folgender Zeile tue

    ;Map of the gpios :up, down, left, right, start, select, a, b, tr, y, x, tl, hk
    controllers.gpio.args=map=5 gpio1=25,22,26,21,3,5,20,19,14,16,15,13,4
    ;_________________Default-Werte: 4,17,27,22,10,9,25,24,23,18,15,14,2

    Und nu? Muss ich noch was aktivieren, oder deaktivieren? Meine Tasten und der Joystick tun nach einem Neustart nicht was sie sollen. Einige Tasten und Joystick rechts/links führen irgendwelche Befehle aus, aber nicht die richtigen. Nur Button X funktioniert, was wohl daran liegt, dass bei den Default-GPIO-Werten X auch den Wert 15 hat. Mir scheint, als würden meine Werte die Default-Werte nicht überschreiben. Was mache ich falsch? Bin für jeden Tipp dankbar...

    Achso: Ich habe das Image für den rpi3 mit Build 310261260 from pipeline 84322406 based on 6.1-Dragonblaze verwendet.

    MfG,
    Andy.



  • Moinsen,
    nach einem langen Abend mit Try und Error habe ich folgendes rausgefunden:
    Wenn ich mich per SSH einlogge und folgendes auf der Konsole eingebe, funktionieren die Tasten wie gewünscht:

    modprobe -r mk_arcade_joystick_rpi
    modprobe mk_arcade_joystick_rpi map=5 gpio=25,22,26,21,3,5,20,19,14,16,15,13,4
    /etc/init.d/S31emulationstation stop
    /etc/init.d/S31emulationstation start

    Ich stoppe also das Modul mk_arcade_joystick_rpi und starte es anschließend mit meinen Parametern neu. Dann muss ich noch die EmulationStation neustarten und dann geht es. Also sind meine GPIO-Einträge in der recalbox.config theoretisch richtig, sie werden nur beim ersten Start der Box nicht geladen. Die Frage ist immer noch, warum nicht...?
    Vielleicht könnte ich mk_arcade_joystick_rpi meine Parameter auch schon beim ersten Start mitgeben, aber ich finde leider nicht, wo das passiert. In modules.conf steht das z.B. nicht. Wo könnte das Modul noch gestartet werden? Jemand dazu vielleicht eine Idee?

    Bin immer noch für jeden Tipp dankbar...

    Gruß,
    Andy.



  • Ist ein bekannter Bug.

    Lösung hier: https://forum.recalbox.com/topic/18829/6-1-et-manettes-gamecon/30

    Greetings,

    Andy.



Want to support us ?

175
Online

58836
Users

18416
Topics

138569
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.