Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Probleme Sfc30 pro



  • Bonjour,

    Je suis en recalbox 6.1 et mes 2 manettes sont à jours en 1.32.

    Je les configure, je redémarre et la je suis iblige de tout reconfiguré. Mes manettes n'arrivent pas à se connecter.
    Quelqun a t il une solution pour éviter de refaire a chaque démarrage?



  • Bonsoir @larlouch
    Il y a plusieurs topics sur ce sujet sur le forum.

    Il faut que :

    • tu éteignes ta SF30 pro (start pendant + de 3 secondes, + de 8 secondes pour son reset)
    • tu démarres ta manette en mode Android soit Start + B (bouton jaune) simultanément
    • une fois ce mode sélectionné, tu lances l'appairage avec le petit bouton sur le flanc de la manette. Tes leds vont chainer. Tu lances la reconnaissance de ta manette sur recalbox (associer une manette)
    • la manette va être détectée, tu l'associes
    • si non détectée ou si association impossible, relance juste l'appairage (si t'as bien fait Start+B à l'allumage)
    • Configure ta manette dans l'ES.
      Pour éteindre, tu appuies sur Start pendant 3 secondes.
      Pour allumer, simple start (plus besoin de faire Start+B), ça cherche l'association et ça connecte seul.

    Si tu démarres dans un autre mode (MacOS, PC, Switch), ça ne marchera pas !

    Si tu as plusieurs matériels (comme moi PC, switch...), si tu l'appaires sur un de ces matériels, il faudra évidemment refaire un démarrage Android pour que RCB l'associe correctement. On ne peut avoir qu'une seule association différente à chaque fois (on ne peut pas avoir PC et RCB en même temps par exemple).

    Si malgré cela ça ne fonctionne pas, mets le firmware de ta manette à jour (site 8bitdo) au cas où et essaie de nouveau.

    En espérant t'avoir aidé.



  • @scavy

    Bonjour et merci pour ton aide.

    J'ai toujours le même problème, j'ai beau suivre la procédure que tu as donné, je suis malgré tout obligé de refaire la manip, menu associer les manettes, start+b et ensuite appareillage à chaque fois.

    C'est une vrai galère ses manettes 8bitdo...



  • @larlouch salut
    Y'a ptet une différence entre la SF et la SFC. J'ai aucun problème avec la mienne pourtant.



  • @larlouch la procédure de scavy n'a jamais rien donné pour moi non plus et je me suis toujours demandé pourquoi le wiki de Recalbox donnait cette liste interminable de "START+boutonA/B/X/Y" puisque, pour moi, ça marchait nickel juste avec START (ce qui est quand même bien plus intuitif)... Jusqu'à la réinstallation de Recalbox en v6.1.

    La solution, celle qui fonctionne chez moi en tout cas, la voici : après avoir détecté une manette 8bitdo, sors du menu de configuration. Tu peux ensuite y réentrer pour configurer les boutons si tu veux. Surtout, pense à sortir entre chaque manette pour que la configuration soit enregistrée.

    Les manettes, même en respectant cette procédure n'étaient pas reconnues d'un démarrage à l'autre. J'utilise un boîtier Retroflag avec le script 356ONOFFRESET. La solution a été pour moi d'éteindre la Recalbox "à l'ancienne", c'est-à-dire en passant par le menu d'extinction de la Recalbox. Depuis, les manettes restent reconnues et configurées. J'imagine que c'est dû à un enregistrement de la configuration qui se fait à l'extinction mais pas quand celle-ci se fait depuis un bouton ON/OFF. Ce n'est qu'une supposition, certes, mais le résultat est là pour moi : ça fonctionne ainsi et pas autrement.



  • @scavy

    C'est bien des SF30 pro que j'ai (erreur de frappe sur le téléphone).

    Quand tu redémarres ta recalbox, a quel moment tu allumes tes manettes?
    A l'écran de chargement ou sur émulation station?



  • @larlouch À l'écran de boot, un peu avant que Emulation Station ne prenne la main.



  • @tungstène

    Merci, je vais tester ta technique.
    J'ai également un boitier retroflag et utilise le même script que toi.

    C'est vrai qu'avant la 6.1, je n'avais pas ce soucis là.



  • @tungstène

    Bon j'ai essayer et toujours pareil, je suis obligé de refaire la manip...

    Je ne vois pas d'où peux venir le problème, surtout qu'avant la maj, cela fonctionnait correctement.

    Je précise que je suis en 6.1 avec un boitier retroflag (donc avec le script d'extinction sécurisé) et les firmwares des manettes sont à jour.



  • @larlouch @Tungstène
    Le start+B, je ne le fais qu'une fois pour l'appairage initial (puis si je joue avec ma manette sur la switch par exemple, et que je veux la reconnecter de nouveau sur la RCB).
    Sinon pour allumer ma manette si elle est déjà appairée et configurée, j'appuie juste sur start, lorsque l'ES est chargé.
    Sur la V6.1 je ne rencontre pas de souci pour le moment. J'ai un boitier NespiCase+ aussi et j'ai le script du safeshutdown activé. Mais ça marchait aussi avec le script désactivé.



  • @larlouch
    J’ai eu le même souci..
    Juste après la config des boutons , j’ai redémarré ES direct par le menu ( sans jouer avant ) et la magie , a chaque allumage , mes manettes (SN30 pro) sont configurées . Simple hasard ?? Je ne sais pas mais ça fonctionne très bien
    J’ai également attribué chaque manettes a un joueur ;

    Jouer 1
    #0#8bitdo XXXX
    Joueur 2
    #1#8bitdo XXXX



  • Ah oui tiens, moi aussi après l'appairage, je redémarre le système. Ca doit sauvegarder quelque chose.


  • Staff
    Moderator
    Team

    On est en train de revoir le bluetooth ;)

    0_1572766182643_IMG_20191103_082551.jpg



  • En voulant associer une seconde SFC30 (non pro) je me suis heurté au même soucis ce matin.
    Finalement j'ai appliqué la solution du wiki de l'appairage manuel avec la méthode bluetoothctl et les 2 manettes refonctionnent.



  • @outl4w

    Tu utilises le bluetooth du raspberry ou tu as un d'ongle?



  • @oyyodams Comment le BT pourrait fonctionner chez certains et pas d'autres avec le même hard et le même soft ? Qu'est ce qui pèche dans le BT ?



  • Le bluetooth du Rpi.
    La config c'est RPI 3, boitier superpi et 2 manettes SFC30 à jour.
    Pour les manips en mode console j'allume les manettes juste avec start et je les mets en mode appairage avec select (je vérifiais que c'était toujours actif pendant que j'entrais les commandes.



  • @outl4w

    Je viens de tester, ca ne fonctionne toujours pas.
    Toujours obligé de refaire les manips au complet.
    J'ai limpression qu'après chaque extinction du système, ça ne sauvegarde pas.



  • @scavy

    Je me pose les mêmes questions, j'ai suivi chacune des procédures décrites dans ce post et y a rien qui va.



  • @larlouch

    Ré-installe Recalbox.. 6.0 ou 6.1 comme tu veux mais si ça fonctionne chez les autres pas de raison que ça ne le fasse pas chez toi.
    Quelle plateforme ?
    Stockage ?
    C’est galère je te l’accorde mais y’a pas de raison que tu sois le(la) seul(e)



  • Et n’hésite pas a mettre une description complète du matériel utilisé dans ta signature..


Log in to reply
 

Want to support us ?

166
Online

61997
Users

18650
Topics

140088
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.