Wifi doesnt work on 6.1 (PC X64)

  • Since 6.1 my WiFi is not working (not connected). On 6.0 there is no Problem. Tested this on a different mini pc same result no wifi.

  • Have you tried to re-enter the WiFi key (PSK)? I had to do this on Pi to get WiFi working again. Maybe because there was a change so WiFi key is now stored unencrypted in config file - I don't know...

    If you've already tried that, it maybe would help developers, if you share information which WiFi chipset your mini pc is using.

  • @retroplayer88 I managed to find a workaround (but it's a bit tedious)

    Open the menu and go to Network settlings and put in all your wifi details then save it and reboot.

    After this go back to network settings and it might still say 'not connected' if so disable the wifi then press save and exit the menu. Go back into Network Settings and re-enable it (WIFI ENABLED will come up)

    The reason its tedious is that you have to do this every time you start recalbox. If it's any consolation, just remember to do this if you need to rescrape or transfer anything via SSH or WinSCP.

  • Same issue with Raspberry Pi 3 😞

  • For Example Netgear WNA3100M Nano Stick is listed in the compability list as "working". It doesnt work neither on 6.0 nor on 6.1

    I will get a Ralink RT5370 these days will check this also.

    Does anybody knows a usb wifi stick that works 100% on 6.1?

  • @lhari84 said in Wifi doesnt work on 6.1 (PC X64):

    If you've already tried that, it maybe would help developers, if you share information which WiFi chipset your mini pc is using.

    For Example Intel AC 7265 and Intel AC 8260. Both worked on Dragonblaze 6.0. None of them are working on 6.1

    Besides Ralink 5370T is also not working. I really apreciate the work of the devs but this Version 6.1 is really buggy. It 6.2 Version should come fastly without those Bugs.

  • Same issue for me on HP Elitedesk 800 G1 (USFF):

    lspci -vnn | grep -i net
    00:19.0 Ethernet controller [0200]: Intel Corporation Ethernet Connection I217-LM [8086:153a] (rev 04)
    06:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev 6b)

    Etehrnet works as expected. WiFi never connects.

  • Confirmed issue here. Tested on Optiplex 3040, 3046, 3060. 2018 NUC. I get that some of these platforms weren't probably supposed to run Recalbox but wanted to exemplify the range of systems this issue exists on.

    So this leads me to my next question. In general are fixes like this pushed via the built-in update mechanism?

    On my working build I'm on the latest version before 6.0 was introduced. I've never seen an update come through the built-in updates.

    I'm trying to weigh my options. (Install 6.0, roll with 6.1 and use the above workaround, use my old build and wait)

Want to support us ?