Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Problème joueur 2 dans jeux d'arcade 6 boutons



  • @voljega Je n'ai pas testé de jeu SNES, et je n'ai testé qu'un seul jeu PSX, et encore, celui-ci n'utilise que 3 boutons. Et à l'instar des jeux MAME utilisant 3 boutons, tous les boutons peuvent être mapés sans souci.

    Dans Parodius Da! (MAME 3 boutons) et Sexy Parodius (PSX), la configuration est ainsi :
    Boutons 1, 2 et 3 : Fonction 1 - Fonction 2 - Fonction 3
    Boutons 4, 5 et 6 : Fonction 1 - Fonction 2 - Fonction 3
    ...et ça marche pour les deux joueurs.

    Dans Street Fighter Alpha 3 et Mortal Kombat (MAME 6 boutons), c'est censé être comme ça...
    Boutons 1, 2 et 3 : Fonction 1 - Fonction 2 - Fonction 3
    Boutons 4, 5 et 6 : Fonction 4 - Fonction 5 - Fonction 6
    ...mais ça ne marche que pour le joueur 1, car le joueur 2 a ça :
    Boutons 1, 2 et 3 : Fonction 1 - Fonction 2 - Fonction 3
    Boutons 4, 5 et 6 : Fonction 4 - N/A - N/A

    Pourtant, comme je l'ai dit, quand je vais dans les paramètres de Retroarch pendant que SFA3 ou MK est démarré, le mapeur de touches détecte bien l'ensemble des touches du joueur 2 ! C'est à n'y rien comprendre...


  • Banned

    @tece-artiste rassure moi tu as bien configrué tes controlleurs et tous tes boutons dans EmulationStation ?



  • @voljega Je suppose que oui, car sinon, ces deux boutons ne fonctionneraient pas du tout, y compris sur Retroarch…


  • Banned

    @tece-artiste pas forcémznt



  • @voljega Ils agissent aussi sur EmulationStation, ils font la même chose que leurs équivalents du joueur 1. J'en déduis qu'ils ont été configurés comme il faut pour ce qui est d'ES.


  • Banned

    @tece-artiste pas forcément mais bon t'as l'air plein de certitude pour quelqu'un qui cherche de l'aide donc je vais te laisser t'amuser tout seul.



  • @voljega En même temps, "pas forcément" sans dire de choses à faire, ça ne m'aide pas des masses. C'est pourquoi je me suis d'ores et déjà "amusé tout seul" comme tu dis. À défaut de résoudre le problème, j'ai au moins pu voir d'où il vient : du core Mame2010 que j'utilisais, car quelqu'un dans le forum anglophone avait le même problème : https://forum.recalbox.com/topic/18099/a-and-r-button-of-2p-is-not-working-in-mame2010-core

    J'ai donc changé mes roms pour passer en Mame2003, et là il n'y a plus de problème.

    Je ne dirai pas "problème résolu", mais plutôt "problème contourné".


  • Banned

    @tece-artiste ben a minima quand on te demanee ce genre de trucs cnest bien de oa refaire la configuration dans ES



  • @voljega Refaire la configuration, oui, mais comment ? Je n'ai pas trouvé d'option de maping des touches… De toute façon, maintenant que j'ai réussi à contourner le problème en changeant de core, ça me rassure car ça veut dire que je n'ai pas à tout recommencer !


  • Banned

    @tece-artiste ben ça veut dire aussi que tu l'as jamais fait le mapping du coup... cherche dans le menu start ça se trouve facilement.....
    mais bon de fait si tu n'as pas eu de fenêtre te demandant de le faire, ça doit vouloir dire que c'est configuré par défaut, même si c'est parfois bon de refaire la conf soit même

    et effectivement le problème semble venir de mame 2010 peut-être ou des gpio sur mame2010.... du coup j''essaierai avec des manettes ps3 et te dirai ce que ça donne.

    sinon tu as toujours la solution fba libretro



  • Bonjour,
    Problème similaire , je suis repassé sur mame2003.



Want to support us ?

188
Online

78.5k
Users

20.1k
Topics

147.5k
Posts