Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[GPi Case] - Recalbox 6.1 Beta 4 (pre-release) DISPONIBLE !



  • Retour apres un bonne journee de test - deja j’ai mal aux doigts! J’avais oublie que la GB nous torturait lea doigts avec cette croix directionelle.

    Cote recalbox pour une beta c’est reellement genial! Les consoles tournent nickey (Megadrive) - plus comlique pour la SNES ou certains jeux rament legerement (Mario Kart) et donc le son gresille car le PI0 est a fond.

    Pour l’arcade - idem si c’est vieuz generalement ca tourne bien voir tres bien (sauf Super Sprint et Gauntlet la reaolution etait assez elevee a l’epoque). Pour Cave c’est plutot chaud (Donpachi et la serie).

    Par contre neo geo fonctionne tres bien (j’ai pas tout teste) et globalement c’est juste genial d’avoir autant de super jeux ! Une perle a decouvrir sur NES - micro mage qui vient juste de sortir et est genial a joue sur le GPi.

    Perso la seule ‘demande’ serait de pouvoir mette les shaders QUE sur GB pour avoir l’effet Vert de l’ecran et pas sur toutes lea emulateur car on sent quand meme que c’est dur pour le Pi0.

    Encore merci pour cette version- GPi plus Recalbox c’est un retour en arriere garantie avec enormement de plaisir!



  • Bon après avoir passé la journée dessus. Je me suis fait mon petit thème perso et je suis totalement séduit.
    Je remarque tout de même pas mal de petit problèmes qui seront peut être solutionable par la suite par la team.

    • Comme dis plus haut, le son est de qualité assez mauvaise (en montant le son a font sur l'interface, on arrive a améliorer ça)
    • Sur certains jeux tel que metal slug 3-4 sur neogeo... Pas de son ??!!??
    • Sur certains jeux Snes, ca rame. Alors oui je suis daccord que le pi0 est un peu limite mais sur la version retropie un même jeu fonctionne à merveille. Un exemple flagrant: Street Racer. Dans le menu principal (ou l'on vois la piste tourner en rond) ça saccade de dingue alors que sur la version Retropie ca rame pas du tout.

    Je pense qu'une amélioration a ce niveau la est possible. Non je partirais pas chez RetroPie, j'aime trop Recalbox lol.


  • Staff
    Moderator
    Team

    @darksonic En effet, le config.txt est resté l'original, et le hardware.log indique que ton GPi n'a pas été détecte :(

    Il se pourrait effectivement qu'il soit défectueux.

    Il y a un moyen de forcer la detection, et même si nous ne l'avons jamais testé, ça vaut le coup d'essayer:

    • Ouvre le fichier recalbox-boot.conf qui se trouve dans la partition BOOT.
    • Ajoute la ligne: case=GPiV1 (attention aux majuscules/munuscules, le 'i' est en minuscule!)
    • Sauve ton fichier et reboote.

    Il se peut que l'écran se mette a fonctionner, mais que ton pad ne réponde pas (c'est grace à l'USB du pad que nous détectons le boitier donc je crains que cette partie au moins ne soit défectueuse...)

    Dans tous les cas, tiens nous au courant.



  • @numerobiss

    Je confirme sur MetalSlug 3 et 4(et 5). Pas de son.


  • Staff
    Moderator
    Team

    @numerobiss Essayezde changer de core ;)

    D'ailleurs c'est valable pour tout le monde, si vous voyez qu'un core fonctionne mieux qu'un autre pour une console, merci de nous le faire remonter. Si tous les avis convergent, nous pourrons mettre les cores les plus rapide par défaut.


  • Staff
    Moderator
    Team

    Autre test à faire pour les testeurs:

    Dans le fichier config.txt de la partition BOOT il y a une clef audio_pwm_mode=0.
    Vous pouvez tester les valeurs 1 et 2, et nous dire si ça agit positivement ou négativement sur le son :)



  • @bkg2k said in Recalbox sur boitier GPi - Beta Publique!:

    case=GPiV1

    Effectivement sur la version de Recalbox (non optimisé GPI case ) que j"avais précédemment installé, subitement les commandes n'ont plus étaient détecté au bout de quelques minutes d'utilisation.

    J'ai testé en ajoutant la ligne sur recalbox-boot.conf mais ça ne change rien et en explorant à nouveau la carte SD la ligne ajouté a disparu...

    Merci



  • Personnellement j’ai une bizarrerie, j’installe RB sur la micro sd, il détecte le gpi, s’installe correctement, mais quand je mets mes Roms, il met longtemps à booter, le thème revient le thème de base, et impossible de sélectionner le thème gpi il a disparu ? Comme s’il etait revenu sans la détection du gpi !
    Je mets mes roms via la partition Share/roms directement sur la micro sous Mac. Je ne touche à rien d’autre (la micro sd a 3 partitions boot-recalbox et share)
    Je n’ai pas ce problème via recalbox manager mais dans ce cas je n’arrive pas à avoir les images des scraps.
    Et je n’arrive pas via filezilla : ip / login : root / mdp : recalboxroot

    Merci de votre aide



  • @ippokun la même chose que moi. J'ai l'impression que c'est du fait de copier les roms via le pc. Mac pour toi et Windows +paragon pour moi.

    Depuis réinstallation. Je ne pas remis de roms je suis bien resté sur le thème du gpi. Par contre je test les jeux présents et je suis éjecté du jeu au bout d'un moment sans raison.
    De plus si j'essaye d'aller dans les options wifi..l'écran se brouille, se pixelise. Il faut que je vous envoi la vidéo de tout ca.Comment je peux vous les envoyer? Avec les fichiers de configuration?



  • @alexkid806 j’étais justement en train d’essayer via un pc... on va voir ...



  • @bkg2k said in Recalbox sur boitier GPi - Beta Publique!:

    Autre test à faire pour les testeurs:

    Dans le fichier config.txt de la partition BOOT il y a une clef audio_pwm_mode=0.
    Vous pouvez tester les valeurs 1 et 2, et nous dire si ça agit positivement ou négativement sur le son :)

    Je viens de tester avec 1, on dirait que c'est plus clair le son.

    Bon par contre... a peine 10 minutes alumé, je tente un transfert via le wifi... et freez complet, impossible de cut avec le safeshutdown...

    Vous avez quoi comme sonde pour la température histoire de voir de grapher ca en ssh ?

    Edit : Lancement d'un jeu Neo-Geo ... 5 minutes, de nouveau freeze......

    Edit 2 : audio_pwm_mode=0 en 2 ralentit énormément l'os... la vidéo de début LAGGGGGGGGGGGGGGGGGUE.

    Edit 3 : avec le son en mode 1, GBA crash bandicout a oublier. 55 degres en jeu en mode 1, je tente mode 0 et gba.



  • Voila voila... test d'un jeu GBA, lenteur sur lenteur en mode son 0 ou 1, retour au menu, je tente de changer le thème, et la, freeze avant meme de valider (température a 55 sur le manager), c'est devenue comme ça sans rien faire âpres quelques secondes, et le même artefact reste après un reboot complet...

    j'ai retiré les piles quelques secondes et c'est revenu a la normal...

    alt text



  • @alexkid806
    Je n’ai pas les problèmes du wifi , il se connecte bien à mon réseau, mais accessible uniquement depuis le manager, impossible depuis Finder/explorateur



  • @bkg2k pour moi, pas de changement pour le son en passant sur audio_pwm_mode sur 1, ça grésille toujours autant, en continu (en jeu et sur es).
    Par contre, j'ai eu 2 redémarrages successifs (non voulus) après être passé sur 1



  • @aigleblanc said in Recalbox sur boitier GPi - Beta Publique!:

    Voila voila... test d'un jeu GBA, lenteur sur lenteur en mode son 0 ou 1, retour au menu, je tente de changer le thème, et la, freeze avant meme de valider (température a 55 sur le manager), c'est devenue comme ça sans rien faire âpres quelques secondes, et le même artefact reste après un reboot complet...

    j'ai retiré les piles quelques secondes et c'est revenu a la normal...

    alt text

    @aigleblanc ça j’ai u le problème car la cartouche du pi était mal en contact avec le GPI. Ça m’arrive assez souvent sur la mienne. Retire la carte et remet là pour voir.



  • @bkg2k said in Recalbox sur boitier GPi - Beta Publique!:

    Autre test à faire pour les testeurs:

    Dans le fichier config.txt de la partition BOOT il y a une clef audio_pwm_mode=0.
    Vous pouvez tester les valeurs 1 et 2, et nous dire si ça agit positivement ou négativement sur le son :)

    Peut tu m’expliquer à quoi sert cette option stp ? ;)



  • @rob1

    Sur le site de GPi ils indiquent que ca peut venir d’un mauvais montage / alignement du rpi et deur leux carte gpio.

    Poir le pb de son sur MetalSlug3 et 4 (et 5) ainsi que d’autres jeux neo geo je confirme le pb chez moi aussi.



  • @alexkid806

    J’ai personellement copie via wifi sur le PC et pas de probleme -c’est pas super rapide mais ca a marche.
    J’ai une carte 32gb samsung evo.



  • @bkg2k said in Recalbox sur boitier GPi - Beta Publique!:

    Autre test à faire pour les testeurs:

    Dans le fichier config.txt de la partition BOOT il y a une clef audio_pwm_mode=0.
    Vous pouvez tester les valeurs 1 et 2, et nous dire si ça agit positivement ou négativement sur le son :)

    Pour en revenir au son : avec ces paramètres, j'ai toujours un grésillement continu, dans ES et dans les jeux (c'est à dire pour jouer sans son dans un jeu) :

    • audio_pwm_mode=0
    • son du GPI mis à zéro avec la molette
    • volume systeme mis à zéro
    • musique de fond coupée
    • sortie audio sur auto
    • même constat avec ou sans casque branché sur le jack : le grésillement se répercute même dans le casque.

    ça n'a sûrement pas grand chose à voir mais sur mon raspiboy avec recalbox installé, c'était même problème. J'ai fini par l'ouvrir et débrancher le haut-parleur et ne jouer qu'avec les écouteurs (de tout façon ça agaçait ma chérie d'entendre la musique en plus de mes clics).

    Une petite suggestion pour les vidéos d'intro : que pensez-vous de retirer celles qui correspondent à des systemes qui ne tournent pas sur rpi0 ?



  • @rob1

    Rob ca ressemble a un probleme de masse si ca gresille meme volume au min. Si ca le fait avec pile ou avec alim c’est peut etre un pb de montage du pi0 sur le gpio



Want to support us ?

Join us on :

168
Online

52916
Users

17774
Topics

133742
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.