Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[GPi Case] - Recalbox 6.1 Beta 4 (pre-release) DISPONIBLE !


  • Staff
    Moderator
    Creator
    Team

    @d4rk_d3vil regarde les suggestions faites plus haut pour le son et fait nous des retours.
    pour l'indicateur de batterie c'est dans les cartons... ça arrivera, mais ça dépendait du firmware retroflag.



  • @ian57 Concernant le grésillement, j'ai testé avec 3 alims différentes et ça ne change rien. Par contre, celui-ci diminue un peu en passant sur des piles (sans pour autant le faire disparaitre).
    Suite à l'idée d'un problème de masse, j'ai aussi ré-ouvert la cartouche pour repositionner le pi, sans toucher au branchement de la nappe, sans changement notable.
    Faut-il que j'essaye de rebrancher la nappe ou aucun intérêt ?
    J'essaye la config proposée dès que je peux !



  • Je viens de tester sur piles et sur alim les deux configs :
    #disable_audio_dither=1
    enable_audio_dither=1
    audio_pwm_mode=1
    pwm_sample_bits=16
    et
    #disable_audio_dither=1
    enable_audio_dither=1
    audio_pwm_mode=1
    pwm_sample_bits=24

    à l'oreille, pas de différence notable entre celle de base et ces 2 là. Le grésillement reste présent, toujours moins fort sur piles que sur alim.

    Vous pensez que ça vaut le coup d'essayer de rebrancher la nappe ?


  • Staff
    Moderator
    Creator
    Team

    @rob1 Merci pour tes retours. c'est assez bizarre car chez moi ce la ne gresille pas, j'ai plutot un souffle... qu'un grésillement. Et sur retropie nada ? pas de souffle ni de grésillement? de quelle nappe parles tu? Aurais tu un exemple audio de ton grésillement stp;



  • @ian57 aarrg ! Honte à moi : grésillement/souffle.... c'est vrai que c'est plus un souffle !
    Par nappe, je veux dire le petit adaptateur (qui est appelé "C" sur la notice de Retroflag) et qui relie le PCB au Raspberry.
    Je n'ai pas de retropie sous la main et n'ai jamais vraiment testé cet os (j'avais tenté avec le raspiboy puis abandonné) : je ne serai donc pas très utile là dessus.

    Pas possibilité d'exemple audio maintenant, peut-être ce soir mais je ne promets rien....



  • Bonjour, malgré plusieurs tentatives je ne parviens pas à résoudre mon problème. En transférant les roms via PC dans La partition Share, il semblerait que cela « casse la configuration Gpi Case », plus de thème optimisé, temps de boot très long etc...
    Je ne suis pas le seul dans cette situation à priori.
    Le transfert de roms via le manager fonctionne mais dans ce cas impossible d’avoir les données du scrap, les dossiers médias ne veulent pas se transférer via le navigateur, j’ai impossible de me connecter au pi via l’explorateur (pourtant il apparaît dans le réseau, je ne l’explique pas).
    Alors je souhaiterai éventuellement faire comme j’ai toujours fait c’est à dire via filezilla.
    Quels sont les login et mot de passe à taper, j’ai essayé plusieurs combinaisons rien ne fonctionne.
    Merci par avance de votre aide.



  • just pour etre 100% sur @Ippokun tu transfers que des ROM?
    moi ca marche sans probleme inclue le scrap...

    par contre je ne change rien dans SYSTEM et les autres repertoire..



  • @snwfrd38
    Oui c’est ça qui est super bizarre , je ne copie rien d’autre que les roms, le fichier xml et le dossier média (skraper).
    J’ai cette cassure quand copie sur micro sd ,
    Mais pas via recalbox manager. Dans ce dernier cas, je n’arrive pas à transférer le scrap, j’ai la liste des roms dans la gpi mais pas les données,
    Je m’y prend mal pour recalbox manager ?
    Impossible de me connecter Au pi via explorateur sans comprendre pourquoi, les autres appareils en réseau chez moi sont biens fonctionnels (j’ai activé sur le pi le manager et l’API)


  • Staff
    Moderator
    Creator
    Team

    Concernant le pb de son par rapport à rétropie j'ai un début de piste :

    pi@retropie:~ $ /opt/vc/bin/vcgencmd version
    Mar 23 2018 16:31:10
    Copyright (c) 2012 Broadcom
    version d92349b3d22c277e44d508a2aae6af2b1e5bb224 (clean) (release)
    pi@retropie:~ $ uname -a
    Linux retropie 4.14.30+ #1102 Mon Mar 26 16:20:05 BST 2018 armv6l GNU/Linux
    pi@retropie:~ $
    
    

    et Recalbox :

    # vcgencmd version
    Mar 27 2019 15:45:53
    Copyright (c) 2012 Broadcom
    version 2e98b31d18547962e564bdf88e57b3df7085c29b (clean) (release) (start)
    # uname -a
    Linux RECALBOXGPI 4.14.62 #1 Sat Jun 22 19:34:22 CEST 2019 armv6l GNU/Linux
    

    le firmware intégré à RB est plus récent de 1 an. Du coup, la gestion du audio_pwm_mode a changé entre temps, et cela apporte le lot de pb.
    Avec ça, on déjà un début de piste de résolution



  • @ian57 said in Recalbox sur boitier GPi - Beta Publique!:

    Concernant le pb de son par rapport à rétropie j'ai un début de piste :

    pi@retropie:~ $ /opt/vc/bin/vcgencmd version
    Mar 23 2018 16:31:10
    Copyright (c) 2012 Broadcom
    version d92349b3d22c277e44d508a2aae6af2b1e5bb224 (clean) (release)
    pi@retropie:~ $ uname -a
    Linux retropie 4.14.30+ #1102 Mon Mar 26 16:20:05 BST 2018 armv6l GNU/Linux
    pi@retropie:~ $
    
    

    et Recalbox :

    # vcgencmd version
    Mar 27 2019 15:45:53
    Copyright (c) 2012 Broadcom
    version 2e98b31d18547962e564bdf88e57b3df7085c29b (clean) (release) (start)
    # uname -a
    Linux RECALBOXGPI 4.14.62 #1 Sat Jun 22 19:34:22 CEST 2019 armv6l GNU/Linux
    

    le firmware intégré à RB est plus récent de 1 an. Du coup, la gestion du audio_pwm_mode a changé entre temps, et cela apporte le lot de pb.
    Avec ça, on déjà un début de piste de résolution

    Parfait ca !! Pense tu que c'est lié a la différence de performance sur certains jeux plus fluide sur retropie ?



  • @ippokun

    Ok bizarre cette affaire j’ai comme toi sans probleme...
    Essaye de recommencer en virant tous les fichiers d’un reperetoire rom(ex: nes) - des fois qu’il ne copie pas tous les fichiers.

    As pire PM moi et je te file un repertoire avec des fichiers a tester.


  • Staff
    Moderator
    Creator
    Team

    @numerobiss oui t'as qu'a tenter un audio_pwm_mode= et tu vois voir comment ça ram
    ceci dit à la prochaine mise à jour de raspbian... toutes les gpicase vont être en rad sous retropie ;)



  • @ian57 j'ai essayer en effet ca rame. Comment comptez vous réglez ça (enfin si vous avez la piste :p).

    Par contre j'ai essayer la GBA, les jeux rament tous. C'est une torture sonore lol.



  • ça ne vaudrait pas le coup de séparer les topics : pb de transferts / gba qui rame / souffle-grésillement etc...
    Parceque ça commence à être dur à suivre !


  • Staff
    Moderator
    Creator
    Team

    @numerobiss bump ou retrobump de firmware... ou réglage fin si on a accès au paramètres fin du firmware, mais ils ne sont pas bien documenté.
    Pour GBA as tu vu ma video, moi je n'ai aucun soucis.


  • Staff
    Moderator
    Team

    A ceux qui ont des soucis de transfert de roms. Essayez repertoires par repertoire, en commançant pas les plus petits d'abord.

    Ensuite attention... Chez moi je passe de 35s à 47s de boot avec 6000 jeux dans le GPi et l'option "Gamelistonly" à ON. Donc je vous conseille d'y aller doucement, et une fois que tout est bon, enclenchez l'option Gamelist only, vous gagnerez du temps au démarrage, ça evite qu'EmulationStation rescanne tous les repertoires de roms.



  • bon je n'ai finalement plus de freezes avec un nouveau raspberry contrairement à mon ancien.
    le raspberry était en cause et non la gpi.
    @julien83 said in Recalbox sur boitier GPi - Beta Publique!:

    j'ai eu également des soucis avec la gpi case, en le laissant tourner quelques minutes j'ai des freezes, je dois enlever les piles et le redémarrer. J'ai vu sur reddit que certains ont eu aussi les mêmes problèmes et il conseille d'overclocker en modifiant le fichier config.txt, en effet cela marche mais j'ai quand même commandé un autre raspberry 0w.
    https://www.reddit.com/r/retroflag_gpi/comments/c177k9/having_an_issue_where_my_gpi_freezes_up_after/



  • ok petit retour d'OC sur mon PI0W.
    Ca marche pas mal avec ces settings "de base". Ca me permet d'avoir SNK vs CAPCOM en totalement jouable et (presque totalement) fluide.Le son n'est pas encore parfait mais c'a marche mieux qu'a 1Mhz.

    arm_freq=1100
    gpu_freq=500
    sdram_freq=500
    sdram_schmoo=0x02000020
    over_voltage=8
    sdram_over_voltage=2
    force_turbo=1
    boot_delay=1

    Pour test la tempature de votre PI, voila un ptit script a fair tourner sous SSH. Je tlourne a 1.1Mhz sous 50 degres (dans une piece a 23).

    (script monitor.sh)

    #!/bin/sh
    freq=`cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq`
    mhz=`expr $freq / 1000000`
    khz=`expr \( $freq - $mhz \* 1000000 \) / 1000`
    temp=`vcgencmd measure_temp`
    echo "Running @$mhz.$khz Mhz with $temp"
    

    PS: je cherche toujours la balise <code> de cet editeur....


  • Staff
    Moderator
    Creator
    Team

    @snwfrd38 tu as de la chance avec ton pi0, moi le mien freeze direct au dela de 1050 et ensuite c'était pas stable du tout.même avec la pastille cuivre



  • @alexkid806 Pareil que vous ici !

    J'ai installé l'image et j'ai mis 2 restart avant d'avoir un bon son.
    Ensuite j'ai installé des jeux via ma cartes SD mis dans mon mac et là à la recharge, thème par défaut et les jeux chargé n'apparaissent pas!

    Je vais reflasher la microsd pour voir



Want to support us ?

Join us on :

211
Online

52686
Users

17768
Topics

133695
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.