Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Problème Amiga 600



  • Je confirme ce que Voljega a dit, c'est comme ça et grâce à lui que j'avais réussi....

    Quel dommage pour les Xin-Mo...

    J'espère que ça sera vite réparé !



  • @voljega : Quand je sauvegarde, cela me fait retourner au menu ES. Je suis sortis du jeu et rien ne change dans le tmp. Je capte pas. J'ai l'impression qu'il ne change jamais. Il se créé au lancement du jeu. Puis, avant ou après que j'ajoute le gamepad, il ne change pas... Trop bizarre.



  • @oldgreg said in Problème Amiga 600:

    Puis, avant ou après que j'ajoute le gamepad, il ne change pas... Trop bizarre.

    ouais bah ça je sais pas, faudrait regarder le code en détail...



  • sinon il y a ça dans la FAQ d'amiberry :

    I have issues with my controller not being correctly selected by-default on loading each game, and/or I would like to use a real mouse/specific controller for mouse games. How do I do this?

    To specifiy which controller is used you will need to edit the hostprefs.conf file as detailed here: https://github.com/midwan/amiberry/wiki/WHDLoad-Auto-booting

    joy1 should be selected to use the first available joystick on the system. Note however that selecting a controller that is not available to the syste (e.g. joy3) will cause Amiberry to revert to default settings. Either mouse or joy1 can be selected on the CONTROLLER_MOUSE_1 option depending on whether you prefer to use a real mouse or a controller for mouse-based games.

    joy0 should be used if you wish to use the emulated 'keyboard as joystick' controller.



  • @voljega : Merci, je vais regarder de ce côté là. En effet, le soucis peut venir de là. Mon gamepad semble être considéré comme le joy 3. Les joy1 et joy2 sont mes joysticks xin-mo. C'est peut-être cet ordre qui fait planter la machine. Je vais revoir cela demain. ^^
    Si je trouve une solution je le posterai ici, si jamais quelqu'un rencontre le même problème.

    edit : ou un truc idiot, si je repars une config à zéro et que la première "manette" que je configure est le game pad et non mon xin-mo. Mon gamepad sera le joy1 et tout devrait aller plus facilement ? oO (ou il est tard et il vaut mieux que je réfléchisse le truc demain...)



  • @ninjaw Euh juste une petite question avec whdload et lha, quelqu'un a deja essayé de scrapper via skraper ?
    Quand j avais essaye aucun resultat avec le lha et par contre avec les zips ca scrappait.



  • @mrseguin : Il faut les laisser compressé en .lha
    Les jeux fonctionnent très bien et les jeux sont scrappés avec skraper.



  • @oldgreg bon ben je vais refaire un essai alors :) Merci pour la réponse :)



  • @oldgreg euh encore une question soit dis en passant... si je veux mapper/assigner les touches du clavier pour un jeu en allant dans le menu et sauvegarder cela, c'est possible ?
    Peut-on crée un fichier .uae pour cela aussi ?
    Quelqu'un a déjà fait ce genre de manip ?



  • @mrseguin Quand tu utilises skraper, penses à ajouter manuellement l'extension .lha dans les formats à scraper. Il n'est pas précisé par défaut, il faut le rajouter manuellement et tu verras, ça fonctionne bien après :)



  • @mrseguin techniquement c'est possible mais pour l'instant ça a l'air assez buggué...



  • @scavy Oh je ne savais pas qu'on pouvait le faire manuellement ! Merci pour l'info :)



  • @voljega Merci pour l'info :) je me doutais que c'est possible (bien que je ne sais point du tout comment faire précisément) mais bon si on part dans du hasardeux car c'est buggué vaux mieux investir son temps ailleurs ! Le peufinage de mon set amiga !
    Mais bon j'ai tjs ce vieux reve de finir "colorado" et "métal mutant" de silmarils dans mon canapé sans clavier sur ma recalbox....
    Pour le moment pas de versions whdload patchée pour le pad cd32 pour ces jeux....
    http://eab.abime.net/showthread.php?t=80645



  • @voljega :
    Concernant mon soucis de gamepad non reconnu au démarrage que je dois réaffecté à chaque fois. J'ai regardé ce que tu me disais mais je n'ai pas réussi à trouver le fichier à modifier, etc.
    Sinon j'ai fait dix milles essais sur le uae sans succès. Soit j'ai pas le gamepad au départ mais le jeu se lance. Soit le jeu plante (écran noir) mais dans rétroarch, le joystick est présent.
    Bref, j'abandonne.



  • Petite question sur les fichiers .uae
    Dans le systeme amiga 1200 (je suppose que ce serait pareil dans le systeme amiga600) j ai mis dans un dossier des whdload dezippes .A titre d'exemple un jeu comme rainbow island en whdload est : RainbowIslands_v1.4.1_0012.lha
    je le dezippe et j'obtiens donc un dossier "RainbowIslands" et un fichier RainbowIslands.info
    J'ai effacé le fichier info et j'ai crée un fichier texte avec le meme nom que j'ai renommé en .uae
    Or apparemment le dossier dans lequel se trouve ce jeu ne s'affiche pas quand je lance recalbox et que je vais dans mon syteme amiga1200. Il se trouve dans ce dossier qui est a la racine du dossier amiga1200:
    00--JOUABLE SANS CLAVIER (CD32 support) WIP

    Les fichiers .uae ne sont plus reconnus ? (dans la notice amiga il est ecrit que oui) Est-ce un bug de amiberry ?
    Ou ya un soucis avec le nom de mon dossier ?
    L objectif de cette manipulation etait de voir si le jeu se chargeait plus vite non zippé que zippé....



  • @mrseguin : Salut,
    Tu n'es pas obligé de dézipper le .lha (il est souvent moins volumineux mais tu peux le faire...)
    Le uae n'est pas dans le dossier du jeu. Juste dans le dossier de l'Amiga. (comme le dossier du jeu quoi...)



  • @mrseguin said in Problème Amiga 600:

    RainbowIslands_v1.4.1_0012.lha
    je le dezippe et j'obtiens donc un dossier "RainbowIslands" et un fichier RainbowIslands.info
    J'ai effacé le fichier info et j'ai crée un fichier texte avec le meme nom que j'ai renommé en .uae
    Or apparemment le dossier dans lequel se trouve ce jeu ne s'affiche pas quand je lance recalbox et que je vais dans mon syteme amiga1200. Il se trouve dans ce dossier qui est a la racine du dossier amiga1200:
    00--JOUABLE SANS CLAVIER (CD32 support) WIP
    Les fichiers .uae ne sont plus reconnus ? (dans la notice amiga il est ecrit que oui) Est-ce un bug de amiberry ?
    Ou ya un soucis avec le nom de mon dossier ?
    L objectif de cette manipulation etait de voir si le jeu se chargeait plus vite non zippé que zippé....

    Non les fichiers uae ne sont plus reconnus, la doc n'a pas du tout été mise à jour et est complètement obsolète, et les whdl dézippés ne fonctionnent plus a priori non plus. Les ADF en multi disks semblent HS et le format zip ne fonctionne pas très bien

    Il faut utiliser les lha sans uae maintenant, au deuxième lancement le chargement est bien plus rapide (mais uniquement tant que le raspberry n'est pas redémarré)



  • @voljega merci pour l'info :)
    Bon même si ya encore des bugs c est genial de pouvoir mappé n importe qu elle touche sur le pad pour un confort de jeu "canapé" ! Pas de possibilités de sauvegarder pour le moment mais bon ca viendra je suppose :)

    Ya 2 jours on a testé Tintin on the moon avec un pote qui connais ce jeu par coeur et sur le 1200 il est trop rapide.
    Donc on l a lance sur le 600 mais tjs trop rapide....La config du 600 pour le whdload ne doit pas etre a la vitesse du 500 je suppose...

    Bon malgré des petits soucis dans l'ensemble c'est quand meme fabuleux de pouvoir tater nos jeux amiga sur notre Raspberry :)

    Par contre les whdload avec dans le titre _files ou _images comme pour snowbros par exemple ne se lancent pas (ya aussi des versions de tintin).Faut faire quelque chose en particulier ?



  • @voljega Les fichiers .uae ne sont plus reconnus ? Ah bon ? Pourtant créer un fichier .uae avec dedans la ligne pour faire disparaître les LED fonctionne toujours très bien ??



  • @nerces au niveau du système avec .uaeconfig.uae peut-être, au niveau du jeu lui même pas sur ?

    quoi qu'il en soit pour tout le reste des paramètres je ne crois pas que ça marche encore... graphiques et controles en tout cas c'est mort, peut-être que les petits paramètres de tweak passent encore...


Log in to reply
 

Want to support us ?

Join us on :

189
Online

52690
Users

17768
Topics

133696
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.