Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Problème Amiga 600



  • edit**


  • Banned

    @ninjaw said in Problème Amiga 600:

    Les whdload se lancent dans A1200 uniquement

    non ils marchent ausi en A600

    et fonctionnent avec un autre emulateur que les ipfs A1200 ce qui ne les empechent pas de contenir la grande majorité des meilleurs jeux A500, mais aussi CD32

    Non c'est le même émulateur



  • Je confirme que les jeux se lancent en .lha

    Je confirme comme sur un autre sujet que les joysticks arcade sur une carte xin-mo ne sont pas compatible.

    Par contre, je rencontre un soucis avec mon usb gamepad.
    Il n'est jamais reconnu au démarrage d'un jeu. J'ai beau chercher à modifier le uae du jeu, cela n'y fait rien. Même en allant chercher le fichier /tmp/amiberry/uaeconfig.uae je ne parviens pas à ce que cela marche pour mes uae.
    J'arrive à promener les xinmo ou la souris d'un port à l'autre, mais le gamepad n'est jamais là au démarrage, je dois aller l'ajouter dans HK+B , input, menu déroulant du port 0 ou 1, je choisis le usb gamepad.

    J'ai bien sélectionné le gamepad dans ES.
    J'ai une sd et une clé usb sandisk
    Recalbox 6.0 dans un pi 3b+

    Le uae Amiga 600 de base :

    ;hardware
    fastmem_size=8
    ;controls
    config_version=2.8.1
    joyport0=mouse
    joyport0autofire=none
    joyport0mode=mouse
    joyportname0=MOUSE0
    joyport1=joy0
    joyport1autofire=normal
    joyport1mode=djoy
    joyportname1=JOY1
    input.autofire_speed=0
    input.mouse_speed=100
    button_for_menu=2
    button_for_quit=3
    ;graphics
    gfx_width=640
    gfx_height=256
    gfx_correct_aspect=true
    gfx_center_horizontal = simple
    gfx_center_vertical = simple

    Celui du tmp :

    a3000mem_size=0
    amiberry.cd_path=/recalbox/share/roms/amiga1200
    amiberry.floppy_path=/recalbox/share/roms/amiga1200
    amiberry.hardfile_path=/recalbox/share/roms/amiga1200
    amiberry.rom_path=/recalbox/share/roms/amiga1200
    amiberry.use_analogue_remap=false
    amiberry.use_retroarch_menu=true
    amiberry.use_retroarch_quit=true
    amiberry.use_retroarch_reset=true
    bogomem_size=0
    bsdsocket_emu=true
    button_for_menu=2
    button_for_quit=3
    cachesize=0
    cd_speed=100
    chipmem_size=4
    chipset=aga
    chipset_compatible=A1200
    chipset_refreshrate=50.000000
    collision_level=playfields
    compfpu=false
    config_description=Recalbox auto-generated configuration for Amiga subsystem: amiga1200
    config_hardware=true
    config_host=true
    config_version=4.1.0
    cpu_24bit_addressing=true
    cpu_compatible=false
    cpu_model=68020
    cpu_speed=real
    cpu_type=68ec020
    fast_copper=false
    fastmem_size=8
    floppy_speed=100
    fpu_no_unimplemented=true
    fpu_strict=false
    gfx_center_horizontal=simple
    gfx_center_vertical=simple
    gfx_correct_aspect=true
    gfx_framerate=0
    gfx_fullscreen_amiga=false
    gfx_fullscreen_picasso=false
    gfx_height=256
    gfx_linemode=none
    gfx_lores=false
    gfx_lores_mode=normal
    gfx_refreshrate=50
    gfx_refreshrate_rtg=50
    gfx_resolution=hires
    gfx_width=640
    gfxcard_hardware_sprite=false
    gfxcard_hardware_vblank=false
    gfxcard_multithread=false
    ide_mb_rom_file=:ENABLED
    immediate_blits=false
    input.analog_joystick_multiplier=15
    input.analog_joystick_offset=-1
    input.autofire_speed=0
    input.joymouse_deadzone=33
    input.joymouse_speed_analog=2
    input.joymouse_speed_digital=10
    input.joystick_deadzone=33
    input.mouse_speed=100
    joyport0=joy0
    joyport0_autofire=none
    joyport0_friendlyname=usb gamepad
    joyport0_mode=djoy
    joyport0_mousemap=right
    joyport0_name=JOY3
    joyport0autofire=normal
    joyport0mode=djoy
    joyport1=mouse
    joyport1_autofire=none
    joyport1_friendlyname=Mouse
    joyport1_mode=mousenowheel
    joyport1_mousemap=right
    joyport1_name=MOUSE0
    joyport1autofire=none
    joyport1mode=mouse
    joyport2=joy1
    joyport2_autofire=none
    joyport2_friendlyname=xin-mo.com Xinmotek Controller
    joyport2_mode=djoy
    joyport2_mousemap=right
    joyport2_name=JOY1
    joyport3=joy2
    joyport3_autofire=none
    joyport3_friendlyname=xin-mo.com Xinmotek Controller
    joyport3_mode=djoy
    joyport3_mousemap=right
    joyport3_name=JOY2
    joyportname0=MOUSE0
    joyportname1=JOY1

    kbd_lang=fr
    kickstart_rom_file=/recalbox/share/bios/kick40068.A1200.rom
    ksmirror_a8=true
    mbresmem_size=0
    nr_floppies=0
    ntsc=false
    pcmcia=true
    pcmcia_mb_rom_file=:ENABLED
    rtc=MSM6242B
    rtg_modes=0x112
    show_leds=yes
    sound_channels=stereo
    sound_filter=off
    sound_filter_type=enhanced
    sound_frequency=44100
    sound_interpol=none
    sound_output=exact
    sound_stereo_mixing_delay=0
    sound_stereo_separation=7
    sound_volume_cd=0
    use_gui=no
    waiting_blits=automatic
    z3mapping=real
    z3mem_size=0
    z3mem_start=0x40000000
    filesystem2=rw,DH0:DH0:/tmp/amiga/whdboot/boot-data.zip,10
    uaehf0=dir,rw,DH0:DH0:/tmp/amiga/whdboot/boot-data.zip,10
    filesystem2=rw,DH1:games:/recalbox/share/roms/amiga600/AventuresDeMoktar_v2.0_Fr_1636.lha,0
    uaehf1=dir,rw,DH1:games:/recalbox/share/roms/amiga600/AventuresDeMoktar_v2.0_Fr_1636.lha,0
    filesystem2=rw,DH2:saves:/tmp/amiga/whdboot/save-data/,0
    uaehf2=dir,rw,DH2:saves:/tmp/amiga/whdboot/save-data/,0

    J'ai testé en copiant collant la partie en gras dans le uae de base (à la place de la partie qui correspond) et cela ne passe pas.


  • Banned

    déjà je pense que le uae de base n'est plus du tout pris en compte... il faut que tu modifies en jeu, sauvegarde la conf, et aille voir ce qu'amiberry a changé dans /tmp/amiberry



  • Je confirme ce que Voljega a dit, c'est comme ça et grâce à lui que j'avais réussi....

    Quel dommage pour les Xin-Mo...

    J'espère que ça sera vite réparé !



  • @voljega : Quand je sauvegarde, cela me fait retourner au menu ES. Je suis sortis du jeu et rien ne change dans le tmp. Je capte pas. J'ai l'impression qu'il ne change jamais. Il se créé au lancement du jeu. Puis, avant ou après que j'ajoute le gamepad, il ne change pas... Trop bizarre.


  • Banned

    @oldgreg said in Problème Amiga 600:

    Puis, avant ou après que j'ajoute le gamepad, il ne change pas... Trop bizarre.

    ouais bah ça je sais pas, faudrait regarder le code en détail...


  • Banned

    sinon il y a ça dans la FAQ d'amiberry :

    I have issues with my controller not being correctly selected by-default on loading each game, and/or I would like to use a real mouse/specific controller for mouse games. How do I do this?

    To specifiy which controller is used you will need to edit the hostprefs.conf file as detailed here: https://github.com/midwan/amiberry/wiki/WHDLoad-Auto-booting

    joy1 should be selected to use the first available joystick on the system. Note however that selecting a controller that is not available to the syste (e.g. joy3) will cause Amiberry to revert to default settings. Either mouse or joy1 can be selected on the CONTROLLER_MOUSE_1 option depending on whether you prefer to use a real mouse or a controller for mouse-based games.

    joy0 should be used if you wish to use the emulated 'keyboard as joystick' controller.



  • @voljega : Merci, je vais regarder de ce côté là. En effet, le soucis peut venir de là. Mon gamepad semble être considéré comme le joy 3. Les joy1 et joy2 sont mes joysticks xin-mo. C'est peut-être cet ordre qui fait planter la machine. Je vais revoir cela demain. ^^
    Si je trouve une solution je le posterai ici, si jamais quelqu'un rencontre le même problème.

    edit : ou un truc idiot, si je repars une config à zéro et que la première "manette" que je configure est le game pad et non mon xin-mo. Mon gamepad sera le joy1 et tout devrait aller plus facilement ? oO (ou il est tard et il vaut mieux que je réfléchisse le truc demain...)


  • Theme designer
    Themer

    @ninjaw Euh juste une petite question avec whdload et lha, quelqu'un a deja essayé de scrapper via skraper ?
    Quand j avais essaye aucun resultat avec le lha et par contre avec les zips ca scrappait.



  • @mrseguin : Il faut les laisser compressé en .lha
    Les jeux fonctionnent très bien et les jeux sont scrappés avec skraper.


  • Theme designer
    Themer

    @oldgreg bon ben je vais refaire un essai alors :) Merci pour la réponse :)


  • Theme designer
    Themer

    @oldgreg euh encore une question soit dis en passant... si je veux mapper/assigner les touches du clavier pour un jeu en allant dans le menu et sauvegarder cela, c'est possible ?
    Peut-on crée un fichier .uae pour cela aussi ?
    Quelqu'un a déjà fait ce genre de manip ?



  • @mrseguin Quand tu utilises skraper, penses à ajouter manuellement l'extension .lha dans les formats à scraper. Il n'est pas précisé par défaut, il faut le rajouter manuellement et tu verras, ça fonctionne bien après :)


  • Banned

    @mrseguin techniquement c'est possible mais pour l'instant ça a l'air assez buggué...


  • Theme designer
    Themer

    @scavy Oh je ne savais pas qu'on pouvait le faire manuellement ! Merci pour l'info :)


  • Theme designer
    Themer

    @voljega Merci pour l'info :) je me doutais que c'est possible (bien que je ne sais point du tout comment faire précisément) mais bon si on part dans du hasardeux car c'est buggué vaux mieux investir son temps ailleurs ! Le peufinage de mon set amiga !
    Mais bon j'ai tjs ce vieux reve de finir "colorado" et "métal mutant" de silmarils dans mon canapé sans clavier sur ma recalbox....
    Pour le moment pas de versions whdload patchée pour le pad cd32 pour ces jeux....
    http://eab.abime.net/showthread.php?t=80645



  • @voljega :
    Concernant mon soucis de gamepad non reconnu au démarrage que je dois réaffecté à chaque fois. J'ai regardé ce que tu me disais mais je n'ai pas réussi à trouver le fichier à modifier, etc.
    Sinon j'ai fait dix milles essais sur le uae sans succès. Soit j'ai pas le gamepad au départ mais le jeu se lance. Soit le jeu plante (écran noir) mais dans rétroarch, le joystick est présent.
    Bref, j'abandonne.


  • Theme designer
    Themer

    Petite question sur les fichiers .uae
    Dans le systeme amiga 1200 (je suppose que ce serait pareil dans le systeme amiga600) j ai mis dans un dossier des whdload dezippes .A titre d'exemple un jeu comme rainbow island en whdload est : RainbowIslands_v1.4.1_0012.lha
    je le dezippe et j'obtiens donc un dossier "RainbowIslands" et un fichier RainbowIslands.info
    J'ai effacé le fichier info et j'ai crée un fichier texte avec le meme nom que j'ai renommé en .uae
    Or apparemment le dossier dans lequel se trouve ce jeu ne s'affiche pas quand je lance recalbox et que je vais dans mon syteme amiga1200. Il se trouve dans ce dossier qui est a la racine du dossier amiga1200:
    00--JOUABLE SANS CLAVIER (CD32 support) WIP

    Les fichiers .uae ne sont plus reconnus ? (dans la notice amiga il est ecrit que oui) Est-ce un bug de amiberry ?
    Ou ya un soucis avec le nom de mon dossier ?
    L objectif de cette manipulation etait de voir si le jeu se chargeait plus vite non zippé que zippé....



  • @mrseguin : Salut,
    Tu n'es pas obligé de dézipper le .lha (il est souvent moins volumineux mais tu peux le faire...)
    Le uae n'est pas dans le dossier du jeu. Juste dans le dossier de l'Amiga. (comme le dossier du jeu quoi...)


Log in to reply
 

Want to support us ?

249
Online

55953
Users

18224
Topics

137187
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.